Cubase AL4 upgrade questions...

For users of legacy Steinberg Cubase software
Post Reply
ZenobiaC
New Member
Posts: 1
Joined: Fri Oct 09, 2015 10:18 pm
Contact:

Cubase AL4 upgrade questions...

Post by ZenobiaC »

I looked around to see if my questions can be answered before posting here. Didn't find any.

Been working with Cubase AL4 on a MacBook Pro since 2009. With OSX upgrade issues, it was recommended that I not upgrade to the new OSX at that time. So I didn't.

My iPhone upgraded recently but no longer syncs with my iTunes so I must upgrade. iTunes cannot upgrade unless I upgrade the OSX. Considering Mavericks but not El Capitan.

So, do I also need to upgrade AL4 and to what? I rely on this midi set up as a composer and cannot afford to lose everything I've created so far.

I've read some very disappointing posts about upgrades so naturally, this makes me a bit nervous.

Suggestions are helpful.

Thank you. Zenobia

Martin.Jirsak
Forum Elder
Posts: 24135
Joined: Sun Mar 20, 2011 3:52 pm
Contact:

Re: Cubase AL4 upgrade questions...

Post by Martin.Jirsak »

Hi and welcome,

Cubase AI 4 is not supported with Mac OS X 10.7 or higher. So using it is on your "own risk". There is no upgrade from such an old Cubase version anymore. So if you want to be compatible with current Mac OS X version, you should buy Cubase Elements 8.
Martin Jirsak
How to show notes of the chord/scale only
Cubase Training

Cubase Pro (last officially supported version all the time)
macOS (last update)

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 8 guests