VST Performance in Cubase 8 vs 7.5

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
illespal
New Member
Posts: 3
Joined: Fri Dec 05, 2014 7:16 pm
Contact:

VST Performance in Cubase 8 vs 7.5

Post by illespal »

What to look out in Cubase 8 to preserve perfromance in VST2's like EWQL, XFer Serum and such.
It seem that a Cubase 7.5 project opened in Cubase 8 by default loads slower, and CPU-wise performs about 30% worse in Cubase 8 Pro.
I just tried a project full of 64 bit VST2s, and while it runs fine in Cubase 7.5 it eats much less CPU and does not stutter, in Cubase 8 it eats 30%+ of CPU and stutters in playback.
Ideas? What to turn off, look out for? It's a bit dodgy to expect something better with the upgrade, and get a default setting of worse performance.

dolphin767
New Member
Posts: 3
Joined: Mon Dec 15, 2014 2:18 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by dolphin767 »

Same here. I run many VST's in Cubase 7.5, and in 8, I am having stuttering problems. I can't figure out what is going on. It happens even when nothing is running. I will see the green bar go all the way to red, but it only happens intermittently. Otherwise the green bar is half way. I am thinking it may be a disk issue since I record on an external SSD and use my main HD for all my VST's. I tried turning off services etc. to no avail. I think for the money and claims of better performance, which is why I bought it, it should run a lot better.

Sony VAIO
i7 Quad Core
16 GB RAM
External SSD
Cubase 8

infasc
New Member
Posts: 1
Joined: Fri Jan 23, 2015 12:11 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by infasc »

Same problem: I've installed Cubase 6 and Cubase 8 parallel. When I open the same project file with Cubase 6 and afterwards with Cubase 8 - measuring and comparing the VST performance with the same settings - Cubase 6 operates better [ca. 10 %]. I'm very disappointed because the (alleged) improved audio engine was the main reason for me to upgrade. I also sent Steinberg a support inquiry concerning this on 12/05/2014. Until now [01/23/2015]: No answer!
I hope that there will be an update that really improves the VST performance...

Intel Core i7-2600
16.384 MB DDR3-RAM
240 GB SSD
RME Babyface
Windows 7 Home Premium SP1 64Bit

dinowax
New Member
Posts: 5
Joined: Mon Dec 30, 2013 6:41 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by dinowax »

If you press F12 you will see the same problem I'm having I think, maxed out disk, which makes no sense. Worked fine in 7.5, just installed Cubase 8, tried turning off half the plugins but still stuttering. Tried the new "Render In Place" for some plugin-heavy channels, but hasn't made a difference. Running Windows 7 64x 12gb RAM, 12 core i8. I will try to move the session to my local SSD drive but this was never a problem in 7.5.

dinowax
New Member
Posts: 5
Joined: Mon Dec 30, 2013 6:41 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by dinowax »

[SOLUTION] I had a monster session and after a little toggling... Just lower your buffer setting. Mine was originally 4096, took it down to 1024 and voila. I haven't even touched ASIO Guard, it's still off. Go Cubase 8!!!

Zaroff
New Member
Posts: 14
Joined: Tue Aug 09, 2011 11:30 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by Zaroff »

Old-ish thread and perhaps this has already been mentioned, but I just upgraded to C8 Pro today, and made quick comparisons between it and 7.5. At first, using the same parameters (except for audio power scheme), C8 was performing below 7.5. I had spikes in 8 that weren't there in 7.5, until... I ticked the Audio Power Scheme box, and what do you know, performance increased at once, with overall a 20-30% improvement over 7.5, in the same project.
So far no problems, and performance is indeed better in C8, not just in Asio, but UI is a lot snappier too.
Cubase Pro 9 x64 - jBridge | W10 x64 | Samsung Pro SSDs | Nanoxia Deep Silence 5 | i7 5960x @ 4.0GHz | ASUS X99-A | 32GB Corsair Vengeance LPX DDR4 C14 | MSI GeForce GTX 980 4G | RME HDSPe AIO | Dell Ultrasharp U3415W

The Valley
New Member
Posts: 25
Joined: Thu Dec 05, 2013 6:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by The Valley »

dinowax wrote:If you press F12 you will see the same problem I'm having I think, maxed out disk, which makes no sense. Worked fine in 7.5, just installed Cubase 8, tried turning off half the plugins but still stuttering. Tried the new "Render In Place" for some plugin-heavy channels, but hasn't made a difference. Running Windows 7 64x 12gb RAM, 12 core i8. I will try to move the session to my local SSD drive but this was never a problem in 7.5.
Same, same, same...

I've been using 8.05 since it's release hoping the cpu issue would go away, or at the very least get better, but I'm using a MacbookPro Retina 2012 and most sessions, even the ones I start from scratch with new templates (not carrying over any 7.5 by accident) are mostly unusable by the time I get a FEW plugins going. I've combed through these threads since the beginning of December and I know everyone's trying to tweak their systems, but this is a problem across the board I'm finding - both pc and mac. This can't be hardware. IMO it must be software and embedded into C8 somewhere. BTW I'm not complaining about C8. I love it. That's why I'm putting up with the stuttering. I just render in place CONTINUALLY. It's not my favorite way to work, but it's the only way I CAN work in C8. I jumped the gun and started too many projects in C8 and would have a really difficult time finishing them in C7.5. Those of you with no problems I would love to know what's different about your configs... (especially mac users)

I've been using Cubase and Nuendo since their inception and I've never encountered performance issues like these.

With all that said, if there is something I've missed as a Mac guy (I've played with every combo of asioguard and buffer settings) I'm all ears. The ONLY thing I can attribute this to is when ram reaches a certain threshold. I don't know if it's an absolute threshold, ie after 8 megs the cpu starts choking, or if it's how much space you have left in ram for system resources, but my 16 gig of ram macbook pro doesn't seem to like it when I have over 10 gigs of ram loaded. My templates are much larger than that and spread out among a mac mini slave via VEPro 5. Everything I have is SSD. My same system smoked in C7.5. However, when I do go back to experiment my cpu behaves similar to C8 with it's spikes. Hmmmmmm.......

I'm not sure if I'm rambling or just confirming a deeper issue. Either way, the past two months have been arduous composing and mixing. I love Steinberg software but this is no fun...
Mobile Rig: Cubase 10 64 bit, MacBook Ret Pro 16 GB Ram OSX 10.10.3, Mac Mini Slave OSX 10.8.5 Intel I7 w/16 GB Ram running VEPro5, UA Apollo Twin / 8P /Satellite Quad

smartinuf
Junior Member
Posts: 171
Joined: Sun Dec 19, 2010 10:40 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by smartinuf »

The Valley wrote: My same system smoked in C7.5. However, when I do go back to experiment my cpu behaves similar to C8 with it's spikes. Hmmmmmm.......
Just to clarify, are you saying that projects are behaving badly in 7.5 as well since installing C8?

Are these old projects that were created in 7.5 or projects created in or altered by (by saving in) C8?

I'm also in 10.8.5 mac and have purchased C8 but have been wary of upgrading.

Also wondering if the larger (9 gig) install makes a difference, mac or PC, as perhaps the installer is altering things in some way (hopefully not).
Mac Pro 8 core 2.8 Ghz (early 2008), 10.10.5, 12 gig RAM, RME Digiface, UAD2, Macbook Pro (Late 2008) Fireface 800, Cubase 8.0.35, 8.5.1, Wavelab 8.5.3, Wavelab Elements 8

The Valley
New Member
Posts: 25
Joined: Thu Dec 05, 2013 6:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by The Valley »

Smartinuf,

I discovered the cpu issue in 7.5 when I opened a 7.5 project in C8, had all the cpu issues and then reopened the original 7.5 file and found similar cpu issues happening there that were not before.

To accurately answer your questions I'd have to more reliably test out the differing scenarios of previous vs. new projects in both versions, which I have not done. With that said I did start a 7.5 from scratch after the example I just gave, and found 7.5 performance to be inferior of what it was before (higher cpu readings). The render in place is a game changer for me and the way I work so I've looked for multiple work arounds to make 8.0.5 work. I REALLY want to like it. Take care of the cpu issue and hands down it's my favorite version of Cubase ever.

And to your last observation, I did not install the larger 9gig version.
Mobile Rig: Cubase 10 64 bit, MacBook Ret Pro 16 GB Ram OSX 10.10.3, Mac Mini Slave OSX 10.8.5 Intel I7 w/16 GB Ram running VEPro5, UA Apollo Twin / 8P /Satellite Quad

bigboi
Junior Member
Posts: 159
Joined: Sat Mar 02, 2013 9:12 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by bigboi »

I can confirm EXACTLY what The Valley is saying. My VST performance dropped horribly in 8.0. I then went back to 7.5...and good GOD..it did the same thing there as well! Almost as if having 8.0 in the system had messed everything up.

How did I fix it? I did not fix it. I simply went and bought the most expensive, crazy computer ever. Haswell 5960 (cost $1000 for processor alone), new $350 motherboard, $500 worth of ram-32gig 2400 speed, and all ssd drives. Now, I drudge along fighting cpu performance spikes. And this is a BRAND NEW INSTALL ON BRAND NEW EQUIPMENT....top of the line equipment. It is basically still doing the same thing it did on my old system...however, now the system is so freaking robust it is fighting through it. When I even load up a blank project, I start off with around 5-10% performance showing.

I am so disappointed in Cubase. I love all the new features....but there is definitely something up. Just too many people having the same issues. To be clear, when not using VST instruments, it is working great. On plain audio tracks...awesome. But when I load a VST like Kontakt up....watch out....peaks are coming.

For the record, I am using Lynx Aurora converters, top of the line stuff.

www.solidsound.com

The Valley
New Member
Posts: 25
Joined: Thu Dec 05, 2013 6:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by The Valley »

bigboi is right. It's ONLY with VST instruments loaded. Pretty smooth with all else. I'm a composer. Not sure how to work around that...

With that said I can't say I've ever tried to create a new mix version of audio tracks only after my vst renders and unload all vsti instances. If I need to make changes in my midi tracks I like to keep my entire (very large) vsti template intact so there's no time wasted reloading instruments and searching for which string articulation I was originally using, etc... Only because I'm curious will I try this on my next mix which should be in a couple of days.

thanks to the rest of you who confirm these issues on these threads. I hope Steinberg is reading. I love their software. Most of us here are professionals and rely on our software as our main tool to work. This cpu issue, however, isn't a preference suggestion or complaint about the mixer gui. A lot of us simply can't or are having an extremely difficult time just using the software in it's most basic useage. Bigboi's last post confirms this is software related (IMO). Cubase was made for VST's. Funny (or not so funny) is that that seems to be what's causing this major splinter in what I assume is all of our favorite DAW platform (or we wouldn't be here)

I hope this gets fixed soon. It's been over two months now...
Mobile Rig: Cubase 10 64 bit, MacBook Ret Pro 16 GB Ram OSX 10.10.3, Mac Mini Slave OSX 10.8.5 Intel I7 w/16 GB Ram running VEPro5, UA Apollo Twin / 8P /Satellite Quad

bigboi
Junior Member
Posts: 159
Joined: Sat Mar 02, 2013 9:12 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by bigboi »

Valley, search for my other post....named "at my wits end"...you will find some interesting info there as well. I will be updating it soon.

User avatar
Ted Perlman
Junior Member
Posts: 124
Joined: Mon Jul 23, 2012 10:34 am
Location: Los Angeles, California USA
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by Ted Perlman »

Yes, I noticed that the CPU hit was higher in C8. But I then tried lowering the buffer setting instead of raising it. Voila! The CPU meter came down. Very cool Steinberg. Very cool.
Regards,

Ted "Theo" Perlman
Producer-Guitarist-Arranger-Theologian
Nuendo 10.3 / Cubase 11.0 / Wavelab 10
Macbook Pro i7 2017 Quadcore 2.7 16gb ram, OSX Catalina 10.15.7
misterperlman@gmail.com
http://www.facebook.com/ted.perlman

bigboi
Junior Member
Posts: 159
Joined: Sat Mar 02, 2013 9:12 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by bigboi »

I think I may be on to something here guys....please give this a go:

go to your motherboard bios...(usually tap delete over and over upon startup)

look thru the cpu settings and do this:

turn of hyperthreading
turn off c states
turn off speedstepping

save and reboot. I am getting a good bit less vst performace meter "jumping". It would just randomly jump around for no reason before...like a 20% hit...then back to nothing. Now...much more smooth. Let me know guys.

www.solidsound.com

User avatar
BriHar
Senior Member
Posts: 2159
Joined: Wed Dec 15, 2010 11:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by BriHar »

"...yes I think it can be easily done, just take everything down to Highway 61."

Sun Point Studio Turbenthal, Switzerland


Cubase Pro 10.5.20 - 64bit | Cubase AI 10.5 | WaveLab 9.0.10 - 64bit | PT10 | UR28M | UR44 | CMC-PD/4xFD/QC/AI/CH/TP | BCF2000 | Contour Shuttlexpress | Graphire Tablet | Cubendo Custom Keyboard | Lenovo E31 Workstation:Xeon E3-1225V2/3.2GHz; 14GB DDR3 SDRAM; 2x Intel-Flash520 SSD 180GB (C:/D:);1TB 7200rpm Sata3 (F:); DVD RW (E:); Ext. 3TB USB3 Freecom + WD 1TB; Nvidea GeForce GT 630 4GB DDR3 Video Ram AGP PCIE | Win 10 Pro 64 Bit

PeppaPig
Member
Posts: 939
Joined: Sat Jan 24, 2015 5:39 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by PeppaPig »

Oops sorry posted on wrong thread.
Cubase Pro. WaveLab 9 EL. RME FireFace 802, UA PCI Octo, UA Satelite Quad, Adam T5V, Intel i7 6850x@4.2Ghz (6C/12T), Asus x99 Deluxe II, AMD 6450 HD, Windows 10 Pro, Samsung 860 and 850 SSDs, various outboard for hybrid mixing.

smartinuf
Junior Member
Posts: 171
Joined: Sun Dec 19, 2010 10:40 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by smartinuf »

The Valley wrote:Smartinuf,

I discovered the cpu issue in 7.5 when I opened a 7.5 project in C8, had all the cpu issues and then reopened the original 7.5 file and found similar cpu issues happening there that were not before.

To accurately answer your questions I'd have to more reliably test out the differing scenarios of previous vs. new projects in both versions, which I have not done. With that said I did start a 7.5 from scratch after the example I just gave, and found 7.5 performance to be inferior of what it was before (higher cpu readings). The render in place is a game changer for me and the way I work so I've looked for multiple work arounds to make 8.0.5 work. I REALLY want to like it. Take care of the cpu issue and hands down it's my favorite version of Cubase ever.

And to your last observation, I did not install the larger 9gig version.
Thanks, but now I'm glad I waited, hope you get it sorted. I guess we're all waiting to see what the next update brings and I'll wait until then to try an install. I really need the render in place as well and also new routing options but not at the expense of current progress.
Mac Pro 8 core 2.8 Ghz (early 2008), 10.10.5, 12 gig RAM, RME Digiface, UAD2, Macbook Pro (Late 2008) Fireface 800, Cubase 8.0.35, 8.5.1, Wavelab 8.5.3, Wavelab Elements 8

User avatar
BasariStudios
Member
Posts: 272
Joined: Mon May 16, 2011 2:39 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by BasariStudios »

Lol...same here, with 6.5.5 i did not have this CPU issues, now even on brand new projects.
Cubase 8.5 Pro. Windows 7 X64. ASUS SaberTooth X99. Intel I7 5820K. ASUS GTX 960 Strix OC 2GB. 4x8 GB G.SKILL. 2 850 PRO 256GB SSDs. 1 850 EVO 1TB SSD. Acustica: Nebula Server 3 Ultimate (1.4.009), Murano, Titanium, Magenta 3, Navy, Ochre and RED EQ.

User avatar
BasariStudios
Member
Posts: 272
Joined: Mon May 16, 2011 2:39 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by BasariStudios »

Ted Perlman wrote:Yes, I noticed that the CPU hit was higher in C8. But I then tried lowering the buffer setting instead of raising it. Voila! The CPU meter came down. Very cool Steinberg. Very cool.
In your statement, what exactly are you praising Steinberg for?
Because the CPU went down when you lowered the Buffer? LOL
Cubase 8.5 Pro. Windows 7 X64. ASUS SaberTooth X99. Intel I7 5820K. ASUS GTX 960 Strix OC 2GB. 4x8 GB G.SKILL. 2 850 PRO 256GB SSDs. 1 850 EVO 1TB SSD. Acustica: Nebula Server 3 Ultimate (1.4.009), Murano, Titanium, Magenta 3, Navy, Ochre and RED EQ.

subamarin
New Member
Posts: 11
Joined: Wed Feb 11, 2015 9:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by subamarin »

yep,
postet it also in the german forum, same thing on my system!
Since the install of 8 and 8.0.5, also 7.5 lost power with vsti´s.
I had pretty heavy spiking with like 2 audiotracks and one Addictive keys,
then I trashed the preferences of 8 and the spiking was gone,
but the performance is still bad, it´s really totally annoying to hell.
I fired up Sonar X3 which i own as well as Ableton Live and both of these daws behave alot better,
especially Sonar..

bigboi
Junior Member
Posts: 159
Joined: Sat Mar 02, 2013 9:12 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by bigboi »

I can confirm Sonar stomps the guts outta Cubase 8 in terms of vst performance. I mean badly. Still in Cubase though...just saying

User avatar
silhouette
Senior Member
Posts: 1365
Joined: Fri Jan 14, 2011 12:45 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by silhouette »

I have just upgraded my computer (see below) and the improvement in performance is immense. I am running projects at 64 samples with Asioguard on low, and getting less of a CPU hit than when I was running them on the old machine at 256 or 128 samples. It is nice to play guitar without any noticeable latency. Perhaps there is something to be said for a clean install? Hyperthreading seems to be working for me.
Intel core i7 5960X CPU 3.0 GHz 64bit 32 gig RAM - Windows 10 - AMD RadeonHD 7700 - RME Fireface UC - Cubase 10.5 - UAD Solo + Duo + Quad - Nektar Panorama P1 - Komplete 12 - All uhe - Adam AX7 + Adam Sub 8 - BFD3 - Alchemy - PSP - FabFilter - Fender Telecaster- Wudtone Strat - Gibson L4, 335x2,330L,175 -Ibanez PM100 - Musicman Silhouette x 3 - Warwick Thumb Bass - Kemper Profiling Amp -https://soundcloud.com/silhouette-17

subamarin
New Member
Posts: 11
Joined: Wed Feb 11, 2015 9:10 pm
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by subamarin »

bigboi wrote:I can confirm Sonar stomps the guts outta Cubase 8 in terms of vst performance. I mean badly. Still in Cubase though...just saying
I will work on in Sonar until Steinberg figures that out,
This is an unacceptable situation for me, I don't see bouncin tracks every 10 minutes..

Zaroff
New Member
Posts: 14
Joined: Tue Aug 09, 2011 11:30 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by Zaroff »

silhouette wrote:I have just upgraded my computer (see below) and the improvement in performance is immense. I am running projects at 64 samples with Asioguard on low, and getting less of a CPU hit than when I was running them on the old machine at 256 or 128 samples. It is nice to play guitar without any noticeable latency. Perhaps there is something to be said for a clean install? Hyperthreading seems to be working for me.
My experience exactly. Happened on a totally fresh install of Windows 8.1, totally new machine (more or less same specs), and C8 Pro 8.0.5. Never been happier with Cubase actually.
Cubase Pro 9 x64 - jBridge | W10 x64 | Samsung Pro SSDs | Nanoxia Deep Silence 5 | i7 5960x @ 4.0GHz | ASUS X99-A | 32GB Corsair Vengeance LPX DDR4 C14 | MSI GeForce GTX 980 4G | RME HDSPe AIO | Dell Ultrasharp U3415W

bigboi
Junior Member
Posts: 159
Joined: Sat Mar 02, 2013 9:12 am
Contact:

Re: VST Performance in Cubase 8 vs 7.5

Post by bigboi »

Just to clarify....recording live is great. I am having issues with virtual instruments and performance. And I'd also like to say....I'm running the latest Haswell 5960 on an MSI mb with 32 gigs of ddr4 ram and a totally fresh windows install and straight to Cubase 8.05.....all on ssd drives (4 of them)

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 5 guests