0 velocity notes being deleted on import or export

Post general topics related to Cubase Pro 8, Cubase Artist 8 and Cubase Elements 8 here.
Post Reply
Peteracox
New Member
Posts: 5
Joined: Wed Oct 05, 2016 10:34 pm
Contact:

0 velocity notes being deleted on import or export

Post by Peteracox » Tue Jan 29, 2019 9:09 pm

Hi Guys, This is an issue I've requested support on but I've had no reply for sometime so was hoping maybe someone on here may be able to help, I'm running cubase 8.
Thanks Pete.

Hi, I’m currently using midi to run lighting via a midi to dmx lighting controller. The controller recognises note velocity as light fixture brightness I.e velocity 127 light full on velocity 0 light fixture off. I created a midi track some time ago on Cubase (possibly Cubase 7) to run a lighting show and have never had any issues. I now need to edit the midi track and this is where I have a problem. I have the original Cubase project I created for the show and all midi data is correct including the 0 velocity light fixture off notes I programmed in first time round, however once I edit it in Cubase then export the midi file and import it into a new project all the midi notes with 0 velocity have disappeared?? I’m unsure whether they are removed on export or import but they’re not there anymore. Thank you hope you can help.

User avatar
raino
Grand Senior Member
Posts: 3739
Joined: Tue Dec 21, 2010 2:41 am
Location: San Francisco
Contact:

Re: 0 velocity notes being deleted on import or export

Post by raino » Tue Jan 29, 2019 9:50 pm

There's a MIDI convention that might be coming into play. MIDI was designed to use note-on and note-off commands for turning notes on and off. But a lot of MIDI instruments also respond to a note-on velocity 0 message the same as if it were a note-off message. I'm guessing that at some point in your process the velocity 0 is getting converted to note-off.

In Cubase you should be able to see the messages in the List Editor. Outside Cubase I don't have any recommendation for a midi text editor - but google should help. You can use those, plus the MIDI Monitor Insert to gather more clues. Good luck.
rodger

Cubase Pro 10.0.40, Win10 Home, Halion6, BFD3, GPO, Komplete Ultimate 9, Waves Gold, Misc. other

i7 4771 Haswell Processor 3.5GHz, ADK LGA1150, 16GB RAM, GeForce GTX970, RME Fireface 400, 2x UAD-2

Peteracox
New Member
Posts: 5
Joined: Wed Oct 05, 2016 10:34 pm
Contact:

Re: 0 velocity notes being deleted on import or export

Post by Peteracox » Wed Jan 30, 2019 9:01 am

Thanks raino, I’ll have a look into this. Cheers Pete.

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 6 guests