Cubasis keeps turning on background audio

Post Reply
gswaan
New Member
Posts: 9
Joined: Mon Apr 17, 2017 8:05 pm
Contact:

Cubasis keeps turning on background audio

Post by gswaan » Wed Nov 22, 2017 1:13 am

Every time I load cubasis on my iPad Pro it seems to turn on the background audio. When I hit the home button the red bar comes on then I have to go back into cubasis and turn it off.
Is there a way to fix this?

User avatar
LSlowak
Steinberg Employee
Posts: 2818
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by LSlowak » Wed Nov 22, 2017 11:37 am

Hi gswaan,

Thanks for your message.

Gave it a short test in Cubasis 2.3 on iPad Pro 12.9 (running iOS 11.1.1).
Things work as expected here (background audio state is stored).

Please let me have the exact steps and I will give it another repro.

Thanks,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

gswaan
New Member
Posts: 9
Joined: Mon Apr 17, 2017 8:05 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by gswaan » Wed Nov 22, 2017 11:11 pm

Background audio seems to be turning on when I load Cubasis. After I force close it I’ll open it again and background audio will be on. When I press the home button the red recording bar comes up at the top. I can press on it to go back to Cubasis and turn off background audio, but it seems to turn itself on after a force close or when it gets booted from memory. Seems pretty consistent. I’ve got some synths loaded as au, one might be iaa, but I’ve checked them both and made sure background audio is turned off in their respective apps.
Attached a screen shot of what I’m loading when I start Cubasis.
Attachments
7D615B47-F2CC-42C4-B7F1-C2697D338641.png
(889.15 KiB) Not downloaded yet

User avatar
LSlowak
Steinberg Employee
Posts: 2818
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by LSlowak » Thu Nov 23, 2017 10:55 am

Hi gswaan,

Sorry, still not able to reproduce with Cubasis 2.3 on iPad Pro 12.9 (iOS 11.1.1).

Steps
- Launch Cubasis
- Go to setup/audio, turn off Background Audio
---
- (A) Tap Home Button and return to Cubasis
- (B) Shut off Cubasis and restart

Result
- Background Audio option is kept de-activated in Setup
- Cubasis (Recording) bar is not visible above home screen

Best,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

gswaan
New Member
Posts: 9
Joined: Mon Apr 17, 2017 8:05 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by gswaan » Thu Nov 23, 2017 11:20 pm

I’ve taken a screen recording of my iPad, please review the video. After force closing and reopening Cubasis you’ll see that background audio is turned on. I think animoog might be the culprit but I’m not sure.
https://youtu.be/Ekbm4QRyHec

gswaan
New Member
Posts: 9
Joined: Mon Apr 17, 2017 8:05 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by gswaan » Tue Nov 28, 2017 4:10 pm

Any word?

User avatar
LSlowak
Steinberg Employee
Posts: 2818
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Cubasis keeps turning on background audio

Post by LSlowak » Thu Nov 30, 2017 1:17 pm

Hi gswaan,

Sorry for the late reply.

The use of Inter-App Audio instruments and/or effects enables background audio automatically (intended), in order to display the IAA transport panel and allow the recording of IAA audio streams.

Best,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

Post Reply

Return to “Cubasis”

Who is online

Users browsing this forum: No registered users and 2 guests