Choppy Cursor Scrolling in 9.5

All topics on WaveLab 9 and WaveLab Elements 9
alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 4:33 pm

Fantastic update PG! Thank you for everything!

However I am noticing significant stuttering of plugins opening and closing and the scrolling of the cursor...any advice?

Wavelab 9 was butter smooth on my Quad 4.0 i7 iMac with 32gb ram.

Thanks - DL

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Tue Oct 24, 2017 4:42 pm

you mean, audio stuttering when inserting a plugin?
Cursor scrolling, always, or when opening a plugin?
Are you in HDPI?
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 4:56 pm

The whole program is very stutters. Cursor movement, level meters, spectrometer...looks like its going around 12 fps.

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Tue Oct 24, 2017 5:08 pm

Even if you load a single audio file and no plugin?
Please tell me more about your iMac. What exact model?
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 5:15 pm

Yes, even just playing back a montage now with no plugins running. The entire program is running at what looks like half the speed of normal frame rates. My machine details are:

iMac (Retina 5K, 27-inch, Late 2014)
Model Name: iMac
Model Identifier: iMac15,1
Processor Name: Intel Core i7
Processor Speed: 4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 32 GB
Boot ROM Version: IM151.0207.B29
SMC Version (system): 2.23f11

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Tue Oct 24, 2017 5:34 pm

I must say we tested until 4K, and 5K means twice more CPU needed.
Try to uncheck "Show Application in High DPI" in File > Preferences > Global > Display
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 5:50 pm

I don't see that as an option... see screen shot below.
Attachments
Untitled.jpg
(322.65 KiB) Not downloaded yet

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Tue Oct 24, 2017 5:53 pm

Oops, indeed, this option is only in the Windows version. It should be added to the Mac version too, in the next minor update.
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 6:15 pm

So will that option make it look like the old (blurry) version? I have been patiently waiting for Retina Display support for years and would hate to lose it! Can't you make a tweak to support the Retina iMac? I suspect you have MANY people using this machine!

Thanks - DL

User avatar
Justin P
Senior Member
Posts: 2501
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by Justin P » Tue Oct 24, 2017 6:26 pm

I seem to have good performance of meters/cursor scroll on my new 13" MacBook Pro retina/Touch ID as well as my non-retina iMac with 1080p Samsung display but I did some initial testing with a 4k TV as the external monitor from my MacBook Pro as soon I plan to get a new iMac and hopefully 4k Samsung TV for display and when I tested that, I definitely noticed some lagging with meters/cursor scroll.

Maybe it's related, I need to do more testing but initially it didn't look good.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Tue Oct 24, 2017 6:37 pm

PG...PLEASE update 9.5 to be compatible with the current and very heavily used iMac 5k!

wchrapcynski
New Member
Posts: 2
Joined: Mon Mar 17, 2014 7:50 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by wchrapcynski » Tue Oct 24, 2017 6:47 pm

I'm seeing the same problem with 9.5 Elements on my 5k iMac. Very choppy all together.

User avatar
Justin P
Senior Member
Posts: 2501
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by Justin P » Tue Oct 24, 2017 8:29 pm

wchrapcynski wrote:
Tue Oct 24, 2017 6:47 pm
I'm seeing the same problem with 9.5 Elements on my 5k iMac. Very choppy all together.
Ah, this is bad news maybe. I'm waiting for the new iMac Pro before upgrading my 2013 non-retina iMac and I also like to use an addtional larger 55" inch display that I'm hoping to upgrade to a 4k from 1080p TV which I use now.

The 4k TV seemed OK with native scaling but of course that is too small to really work, so as soon as any upscaling is enabled, the graphics are choppy.

One clue I noticed that is when zooming, the choppy graphics became almost frozen until the zooming is complete.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

wchrapcynski
New Member
Posts: 2
Joined: Mon Mar 17, 2014 7:50 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by wchrapcynski » Tue Oct 24, 2017 9:58 pm

It's definitely an issue with something in 9.5. Version 9.1 works just fine without any of these issues.

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Tue Oct 24, 2017 10:05 pm

The difference between 9.5 and 9.1, is that 9.5 displays in high resolution if the screen is 4K or 5K, hence has much more data to compute and transfer to screen. This means sharped graphics, but apparently, slows things too much on the 5K computers.
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Wed Oct 25, 2017 1:12 am

PG wrote:
Tue Oct 24, 2017 10:05 pm
The difference between 9.5 and 9.1, is that 9.5 displays in high resolution if the screen is 4K or 5K, hence has much more data to compute and transfer to screen. This means sharped graphics, but apparently, slows things too much on the 5K computers.

Can you do a little tinkering to make it all work with the iMac? It looks AMAZING now and 9.5 is a fantastic update ; )

stilus
Junior Member
Posts: 70
Joined: Tue Sep 09, 2014 1:10 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by stilus » Wed Oct 25, 2017 1:22 pm

https://www.youtube.com/watch?v=l3uolLngRgQ

Is this normal?? :(

On Mac Pro 5.1 12-core with ATI 7950 graphics card and Apple Cinema 27 display..
http://www.mmedia.si
Nuendo 10.2, WaveLab Pro 10 on Mac Pro 5.1 12-core, 64Gb RAM, 4x SSD, ATI HD7950 running macOS High Sierra 10.3.2
Yamaha DM2000 VCM / RME HDSPe RayDAT

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Wed Oct 25, 2017 2:42 pm

From about 00:05 in your video, the horizontal zoom factor is changing. Does this happen "on its own"? (in which case this is not normal), or upon some of your action (in which case, where is the problem in the video).
Philippe

User avatar
cheveyo
Junior Member
Posts: 116
Joined: Tue Aug 20, 2013 8:07 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by cheveyo » Wed Oct 25, 2017 7:41 pm

I think, the video wants to demonstrate the jumping cursor (in steps of some 100ms) in contrast to a smooth running cursor (as in WL9.1).
But it’s difficult to notice this in a YouTube video clip....
--
iMac Retina 5k (OSX10.14),
Cubase from Atari to 10.0.x, Wavelab from 5 to 9.5, StudioOne from 3.1 to 4.x, LogicProX 10.x
Notion 6, Sibelius 7.5, Guitar Pro 7, Dorico from 1.0 to 3
Scarlett 18i20, Line6-Helix

stilus
Junior Member
Posts: 70
Joined: Tue Sep 09, 2014 1:10 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by stilus » Wed Oct 25, 2017 10:00 pm

I just want to show how cursor jumps while playing, without any plugin loaded!

And btw, I checked before upload to youtube, it looks the same in "real world".
http://www.mmedia.si
Nuendo 10.2, WaveLab Pro 10 on Mac Pro 5.1 12-core, 64Gb RAM, 4x SSD, ATI HD7950 running macOS High Sierra 10.3.2
Yamaha DM2000 VCM / RME HDSPe RayDAT

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Wed Oct 25, 2017 10:18 pm

Do you have a 4K or 5K screen?
Philippe

stilus
Junior Member
Posts: 70
Joined: Tue Sep 09, 2014 1:10 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by stilus » Wed Oct 25, 2017 10:37 pm

No, Apple Cinema 27" 2560 by 1440 pixels and ATI Radeon HD 7950 MAC edition graphics card.
http://www.mmedia.si
Nuendo 10.2, WaveLab Pro 10 on Mac Pro 5.1 12-core, 64Gb RAM, 4x SSD, ATI HD7950 running macOS High Sierra 10.3.2
Yamaha DM2000 VCM / RME HDSPe RayDAT

PG
Moderator
Posts: 7175
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by PG » Wed Oct 25, 2017 10:45 pm

Apple Cinema 27" 2560 by 1440 pixels
Do you see a difference with WaveLab 9.1? Here on a similar setup, graphics are faster with 9.5
Philippe

alldigital
Junior Member
Posts: 76
Joined: Wed Oct 23, 2013 1:53 pm
Location: NYC
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by alldigital » Wed Oct 25, 2017 11:50 pm

I can confirm that on my 27 inch 5k iMac 9.1 is flawless and scrolls and behaves perfectly while 9.5 runs at about half the frame rate at all times.

stilus
Junior Member
Posts: 70
Joined: Tue Sep 09, 2014 1:10 pm
Contact:

Re: Choppy Cursor Scrolling in 9.5

Post by stilus » Thu Oct 26, 2017 1:06 pm

Plugins' GUI opens faster, but cursor moving is slower ... :/

I'm wondering where is the a problem, if f.e. any graphical demanding game today runs so smooth, but Steinberg's software does not. Is this macOS issue or?

I didn't use Windows for 10 years, but as I remember, under old Win XP was no such a problem with graphics, and the graphics were running smoothly. On much worse PC machine (Pentium IV) than a MAC (12-core) today...
http://www.mmedia.si
Nuendo 10.2, WaveLab Pro 10 on Mac Pro 5.1 12-core, 64Gb RAM, 4x SSD, ATI HD7950 running macOS High Sierra 10.3.2
Yamaha DM2000 VCM / RME HDSPe RayDAT

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 0 guests