MegaTrig bug

Use this forum for an overview of collected bugs and to report new ones.
Post Reply
savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

MegaTrig bug

Post by savinoff » Tue Jul 25, 2017 6:24 pm

Not sure if something is wrong with my setup, a user error, or is this a real mega bug in Megatrig that went unnoticed:
Once I add a Megatrig even with just the default Note-On rule any connected repeating notes start getting eaten. By connected notes I mean quantized repeating notes, like 1/8 notes with 1/8 length. Easy to try, same with samples as with synth layers. The first note sounds fine, the following notes are all chopped. As soon as I make a slight gap between the notes it starts sounding as it should. Extremely annoying.

jovemprogramador
New Member
Posts: 49
Joined: Thu Aug 15, 2013 7:43 pm
Contact:

Re: MegaTrig bug

Post by jovemprogramador » Thu Jul 27, 2017 4:12 am

Megatrig has eaten repeated notes, Layer Alternate too.

Gerrit Junge
Steinberg Employee
Posts: 161
Joined: Tue Feb 01, 2011 1:30 pm
Contact:

Re: MegaTrig bug

Post by Gerrit Junge » Thu Jul 27, 2017 9:30 am

Hi savinoff,
can you perhaps provide a HALion program with a synth layer that will show the behaviour you described?

best regards
Gerrit
Senior Quality Engineer
VST Instruments
Steinberg Media Technologies GmbH

savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

Re: MegaTrig bug

Post by savinoff » Thu Jul 27, 2017 10:11 am

Here it is (attached). One synth preset with Megatrig and a simple midi file. On my system only the first note of the file sounds correct, the rest are getting cut. As soon as you bypass Megatrig everything becomes normal. It affects any presets that have Megatrig including all the factory ones. Once a preset have a Megatrig anywhere you can't have connected notes.
Attachments
Megatrig bug.zip
(4.66 KiB) Downloaded 170 times

Gerrit Junge
Steinberg Employee
Posts: 161
Joined: Tue Feb 01, 2011 1:30 pm
Contact:

Re: MegaTrig bug

Post by Gerrit Junge » Mon Jul 31, 2017 12:05 pm

Hi savinoff,
even with your MIDI file and the HALion program is it not possible for me to reproduce the behaviour you described above.
With Cubase 9.0.20 build 209 (64bit) and HALion 6.0.15 build 1041 (64bit) it works as expected here with a RME Babyface Pro.

1. What will happen if you select all MIDI notes of the MIDI file and cut down their length in the key-editor step by step while playback?

2. Which Audio Interface are you using? Can you try different "Buffer Sizes" with your Audio Interface?

best regards
Gerrit
Senior Quality Engineer
VST Instruments
Steinberg Media Technologies GmbH

savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

Re: MegaTrig bug

Post by savinoff » Mon Jul 31, 2017 12:34 pm

My DAW is Sonar Platinum. I use RME Babyface as my Audio Interface. None of software instruments I used ever exhibited such problems so I doubt it has anything to do with the Audio Interface and buffer size (which is set to 128 samples). I've attached two mp3 files with how it sounds here: proper.mp3 is properly sounding file with MegaTrig bypassed, and bug.mp3 is how it sounds as soon as Megatrig added.

To answer your first question - as soon as I reduce note's length so they aren't connected, it starts sounding correctly.
Attachments
wave files.zip
(45.22 KiB) Downloaded 168 times

savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

Re: MegaTrig bug

Post by savinoff » Mon Jul 31, 2017 12:36 pm

BTW how long does it take for the messages to be automatically approved, it's so annoying to wait for more than a day for them to get posted...

Romantique Tp
External Moderator
Posts: 2881
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: MegaTrig bug

Post by Romantique Tp » Mon Jul 31, 2017 1:13 pm

I noticed this issue while playing the "Accordion Random Slides" preset (HAL factory) with my MIDI controller. I'm using the same Halion 6 and Cubase versions as Gerrit on Windows 7. My interface is a Edirol SD-90 and it happens even if I lower or increase the buffer size.
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

Re: Moving and relocating VSTSOUND file crashes HALion 6

Post by savinoff » Mon Jul 31, 2017 1:44 pm

I've just tried this file in Reaper and it doesn't sound correctly there either, so it appears it's not Sonar related.

Gerrit Junge
Steinberg Employee
Posts: 161
Joined: Tue Feb 01, 2011 1:30 pm
Contact:

Re: MegaTrig bug

Post by Gerrit Junge » Mon Jul 31, 2017 5:58 pm

Hi Romantique Tp,
I'm able to reproduce your problem with the "Accordion Random Slides" preset here. As this happens with notes, played staccato too, I'm quite sure that this is another problem. Its now in our Defect-Tracking-System and listed as Bug-ID "HALLY-7069".
I hope we can provide a fix for it soon.

Thanks for your report and please accept my apologies for any inconvenience caused.
Gerrit Junge
Senior Quality Engineer
VST Instruments
Steinberg Media Technologies GmbH

Romantique Tp
External Moderator
Posts: 2881
Joined: Fri Aug 07, 2015 3:25 pm
Contact:

Re: MegaTrig bug

Post by Romantique Tp » Mon Jul 31, 2017 6:39 pm

Yeah, this is probably a separate issue. I tried savinoff's files on Cubase and they play without issues regardless of tempo.
Every time someone says "it must be easy to add/fix", a programmer dies.

Cubase Pro and Wavelab Pro (latest), Windows 7 Ultimate 64-bit, MSI Z87-G45 GAMING, i5 4690k, GeForce GTX 760, almost every Steinberg plugin and expansion, Trilian, Komplete 10, etc etc etc etc

Gerrit Junge
Steinberg Employee
Posts: 161
Joined: Tue Feb 01, 2011 1:30 pm
Contact:

Re: MegaTrig bug

Post by Gerrit Junge » Tue Aug 01, 2017 10:51 am

Hi savinoff,
with the help of a MIDI Monitor I found the cause for the problems you encountered. The "Note off" of the previous note and the "Note on" of the next note are on the same timestamp. Back in the days with MIDI Hardware Synths only, this wasn't a good idea because many of them mixed up the events.
Therefore Cubase has a preference since day one to automatically shorten the notes by 2 ticks. This is the reason why it works for me here.
However, today with software synths it should be possible to distinguish events on the same timestamp. In general HALion is capable to do so, but the Megatrig module currently not. Its now in our Defect-Tracking-System and listed as Bug-ID "HALLY-7070".
I hope we can provide a fix for it soon.

Workaround: The workaround is to ensure that the "Note off" of the previous note will be send before the "Note on" of the next note (same pitch) by shorten the length of the notes by 1 - 2 ticks !!!

Thanks for your report and please accept my apologies for any inconvenience caused.
Gerrit Junge
Senior Quality Engineer
VST Instruments
Steinberg Media Technologies GmbH

savinoff
New Member
Posts: 14
Joined: Wed Jun 21, 2017 9:52 am
Contact:

Re: MegaTrig bug

Post by savinoff » Tue Aug 01, 2017 11:22 am

Thanks for pinning this down quickly, happy you've been able to work this out! Hoping for the fix soon.

jovemprogramador
New Member
Posts: 49
Joined: Thu Aug 15, 2013 7:43 pm
Contact:

Re: MegaTrig bug

Post by jovemprogramador » Wed Aug 02, 2017 3:34 am

I'm able to reproduce the problem with the "Accordion Random Slides" preset playing in live mode too. Megatrig and Layer Alternate eat the notes.

jovemprogramador
New Member
Posts: 49
Joined: Thu Aug 15, 2013 7:43 pm
Contact:

Re: MegaTrig bug

Post by jovemprogramador » Tue Sep 12, 2017 5:42 pm

Increment the polyphony keys from 4 to "Any".

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 0 guests