Samplerate Issues

Post all topics related to VST Transit Go here.
Post Reply
markrob1066
New Member
Posts: 10
Joined: Sun Apr 19, 2020 10:24 pm
Contact:

Samplerate Issues

Post by markrob1066 »

Hi,

I am just getting started using the VST Transit Go App along with Cubase 10 running on a PC on Windows 10 on a collaborative project. I ran into an issue with a collaborator today. I am the owner of the project and it is set to 44.1Khz in Cubase. My collaborator is using a Berhinger UMC202HD interface connected via a Lightning to USB adapter to record his parts. He is able to do that and it sounds fine locally on the iPad, but when he sync's his work to the cloud, the files I get back are at 48Khz and are out of pitch and time with my tracks. I was able to use them by making a copy and converting the copied tack to 44.1Khz. Is this normal or an issue with the iPad, the Behringer interface,or the Go ap? I can't find anyway to set the sample rate within the GO app. Do I have to run all of my projects at 48Kzh for this to work?

Also, is there anyway to fold the collaborator tracks into my project with going through the copy and paste process?

Any help would be appreciated,

Mark

User avatar
musicullum
Senior Member
Posts: 1148
Joined: Wed Dec 05, 2012 7:31 pm
Contact:

Re: Samplerate Issues

Post by musicullum »

Both sides should have the same sample rate, so I'd suggest for the Go side (Behringer) to change the sample rate to 48k.
"Also, is there anyway to fold the collaborator tracks into my project with going through the copy and paste process?"
You mean you want to change friend tracks? No, sorry, there is a strict read-only policy reg. tracks other than yours, and it has proven to be very efficient. Otherwise, sync would become extremely complex or even impossible altogether.
musi

markrob1066
New Member
Posts: 10
Joined: Sun Apr 19, 2020 10:24 pm
Contact:

Re: Samplerate Issues

Post by markrob1066 »

That's the issue. I can't find any way to force the sample rate on the iPad to 44.1 Khz. I'm re-doing the project at 48 Khz to see if that solves the problem. I'm pretty sure it will. I would expect that the iPad would force the Berhinger to the project sample rate. Since the overdub locally plays back fine, I suspect there is some sort of real-time sample rate conversion going on that can't be disabled. Can anybody confirm that this is correct behavior of the iPad and that all projects need to be at 48 Khz? Or is it a problem with how the default audio driver interacts with the Berhinger?

User avatar
musicullum
Senior Member
Posts: 1148
Joined: Wed Dec 05, 2012 7:31 pm
Contact:

Re: Samplerate Issues

Post by musicullum »

The audio device 'dictates' the sample rate. Usually there is some control panel delivered with the device to set sample rate, buffer size etc.
Then there is setting the rate programatically. So in 95% of all cases, when Cubase tells the Performer to change its rate because it doesn't match, it does that by asking the audio driver to do so. If that refuses the request, there is nothing we can do and it needs to be resolved manually. I don't know how to do that on an iPad with Behringer hardware, sorry.
musi

Post Reply

Return to “VST Transit Go”

Who is online

Users browsing this forum: No registered users and 0 guests