Plug-in windows won't close

Use this forum for an overview of collected issues and to report new ones.
Post Reply
User avatar
Keezix
New Member
Posts: 45
Joined: Tue Feb 26, 2013 11:47 pm
Location: Los Angeles
Contact:

Plug-in windows won't close

Post by Keezix » Mon Sep 26, 2016 11:18 pm

Fairly recently, I've encountered a new issue with the latest version of Cubase Pro (8.5.20). After editing plug-ins, I click on the red button on the upper left to close the window. Instead of closing, the window turns black, and controls are gone. Still visible are the uppermost VST controls found on all plug-ins (bypass, preset, etc.), including the red button for closing the window. These controls no longer operate and the red button no longer closes this window. It is possible to open a new plug-in window for the same device, but the old window remains open and is still black and still cannot be closed. This seems to happen mostly if "Always on top" is selected for the plug-in window and some editing has already been done. This happens for any plug-in, whether it be third party or a Cubase-only plug-in, an effects plug-in or a VSTi. As such, I sometimes wind up with several of these black windows open, which I try to at least move off-screen. Closing the project doesn't even close the windows! The only action that closes them is to quit Cubase. Re-start Cubase and load in same project and the black windows are gone, even if the project had been saved with them open.
Here are the steps:
1) Open a plug-in window
2) Right click in plug-in window to select "Always on top"
3) Do some sort of edit action in the plug-in window (turn a knob or something)
4) Attempt to close window by clicking on red button
5) Window turns black (standard VST controls remain but are inaccessible, but controls specific to the plug-in are gone, replaced with black background.
6) The disabled window can be moved around, but no other action can be taken. Only quitting Cubase removes the window(s).
black plug-in window.jpg
Attached is a screen shot of an disabled plug-in window (for a UAD Pultec EQ) as an example
(19.6 KiB) Not downloaded yet
Cubase Pro 10 & earlier versions
Apple Mac Pro Intel Xeon Quad-core w/11 gig RAM
running OSX 10.11.6
MOTU 2408 Mk3/ PCIe-424
MOTU midi express XT
iConnectivity MIDI2+
Apple iMac - Intel Core i3 w/4 gig RAM,
also running OSX 10.11.6
Steinberg UR 44 interface
A couple dozen MIDI devices, including 64 channel digital mixing console

User avatar
Fabio Bartolini
Moderator
Posts: 1275
Joined: Tue Oct 02, 2012 11:55 am
Contact:

Re: Plug-in windows won't close

Post by Fabio Bartolini » Tue Sep 27, 2016 8:14 am

Hello,

please see here: viewtopic.php?f=233&t=77989#p450866

Kind regards,
Fabio Bartolini, Test Engineer
Steinberg Media Technologies GmbH
Hamburg, Germany

Connect with Steinberg on Facebook, YouTube, Twitter, Instagram, SoundCloud and Google+!

User avatar
Keezix
New Member
Posts: 45
Joined: Tue Feb 26, 2013 11:47 pm
Location: Los Angeles
Contact:

Re: Plug-in windows won't close

Post by Keezix » Tue Sep 27, 2016 5:24 pm

Thanks. I had run a search on this before posting, but that page did not turn up.

I get the impression that Steinberg is saying that this is the fault of 3rd party plug-ins. But this happens with the built in Steinberg plug-ins as well.

Going back to 64 bit mode might solve this, but for the time being it would mean not using a certain 3rd party VSTi plug-in which is currently incompatible in 64 bit mode, and happens to be one of my most important tools.
Cubase Pro 10 & earlier versions
Apple Mac Pro Intel Xeon Quad-core w/11 gig RAM
running OSX 10.11.6
MOTU 2408 Mk3/ PCIe-424
MOTU midi express XT
iConnectivity MIDI2+
Apple iMac - Intel Core i3 w/4 gig RAM,
also running OSX 10.11.6
Steinberg UR 44 interface
A couple dozen MIDI devices, including 64 channel digital mixing console

User avatar
Fabio Bartolini
Moderator
Posts: 1275
Joined: Tue Oct 02, 2012 11:55 am
Contact:

Re: Plug-in windows won't close

Post by Fabio Bartolini » Tue Sep 27, 2016 6:21 pm

Hello,

there is no 'finger-pointing' to 3rd parties. As for the issue's closing comment from development, this happens when a Carbon window is overlayed on a Cocoa window. And won't be fixed because it only happens to 32-bit VST2. There won't be any further 32-bit Cubase, VST2 has been discontinued as well.

You are the first to report this happening to internal VST3 plug-ins, could you list which ones and possibly post screen-shots? I'd like to test here.

Thank you.
Fabio Bartolini, Test Engineer
Steinberg Media Technologies GmbH
Hamburg, Germany

Connect with Steinberg on Facebook, YouTube, Twitter, Instagram, SoundCloud and Google+!

User avatar
Keezix
New Member
Posts: 45
Joined: Tue Feb 26, 2013 11:47 pm
Location: Los Angeles
Contact:

Re: Plug-in windows won't close

Post by Keezix » Tue Sep 27, 2016 11:43 pm

Fabio Bartolini wrote: You are the first to report this happening to internal VST3 plug-ins, could you list which ones and possibly post screen-shots? I'd like to test here.
I had thought that I had witnessed this behavior with the "Stereo Delay" yesterday, but I was unable to reproduce that result today. I must have been mistaken.
Cubase Pro 10 & earlier versions
Apple Mac Pro Intel Xeon Quad-core w/11 gig RAM
running OSX 10.11.6
MOTU 2408 Mk3/ PCIe-424
MOTU midi express XT
iConnectivity MIDI2+
Apple iMac - Intel Core i3 w/4 gig RAM,
also running OSX 10.11.6
Steinberg UR 44 interface
A couple dozen MIDI devices, including 64 channel digital mixing console

neguscat
New Member
Posts: 2
Joined: Sun Jan 24, 2016 9:24 pm
Contact:

Re: Plug-in windows won't close

Post by neguscat » Mon Jul 23, 2018 8:12 am

Maybe a little late...
I find that in Wavelab 7 in El Capitan on a quad core i7 iMac, I get a blank white space, regardless of the plugin. The only way I find to avoid this is to not just select "none" for a plug, but rather to first red-"x" it out and then it disappears and won't show as blank. Then, "none" can be used. Bummer that Steinberg can't get it together on that one. Maybe someone there will have the intel to achieve something smooth and not so annoying.

Post Reply

Return to “Issues”

Who is online

Users browsing this forum: No registered users and 2 guests