MIDI notes too early

For users of legacy Steinberg Cubase software
creartistic
New Member
Posts: 18
Joined: Sat May 12, 2012 3:57 pm
Contact:

MIDI notes too early

Post by creartistic »

I know this has been asked before, but no thread (at least no one that I found) focused on the issue and came to a clear solution.

PROBLEM: Notes being played on my master keyboard in accordance with the metronome are recorded slightly too early, i.e. they appear slightly but noticably to the left in key editor.

PROBLEM DETAILS:
- The notes are recorded up to 1/32 too early, in average 1/64 (at 120 bpm).
- This "negative latency" seems to vary. Some are very near to the beat, others 1/32 early.
- I can't tell if the variation on "negative latency" comes from my playing or is part of the problem. However I feel playback differs from the way I recorded it. But that's just a feeling.

SETUP:
- Intel i7 notebook, 8 GB RAM, Seagate harddisk (internal), SSD (external, USB 3.0)
- RME Babyface (USB), Masterkeyboard Alesis Q25, M-Audio Keystation 88es
- Cubase 6.5.1, Vienna Instruments / Ensemble
- Windows 7 64-bit

TROUBLESHOOTING HISTORY:
- switching masterkeyboards didn't help
- connecting masterkeyboards via Babyface MIDI-in didn't help
- problem occurs on both Cubase and Cubase 64-bit
- disconnecting USB mouse and keyboard didn't help
- empowering Babyface with 2nd USB-plug didn't help
- de/activating "Use MIDI Timestamp" (DirectX and Windows MIDI) in every possible combination didn't help
- de/activating "constrain delay compensation" option didn't help
- using recording offset didn't help, in fact I haven't noticed any difference no matter what I entered here (-100.000 to +100.000)
- trying DirectX emulated MIDI port (instead of native Windows MIDI) didn't help
- reducing buffers on the Babyface to second lowest option did reduce the amount of "negative latency", but it's still there
- could be that switching from acoustic to MIDI output metronome helped a tiny bit, but I'm not completely sure on that, again it's just a feeling.

THE TILT:
- I installed the RME Babyface on my old system (Dual Core tower, Windows XP, Cubase SX 3.1) in order to see if it's the Babyface that causes the problem and: Suddenly I noticed the "negative latency" there, too. But:
- Then I connected the old system with my old RME Fireface 800 and: Same problem!!

That leads me to three possible conclusions:
1. The "negative latency" has always been there, and I just noticed it on my new system because there it was slightly bigger than on my old one. I can't be sure about that, and I believe that's not the case. I'm doing lots of percussion and drums "manually" and I'm very exact, I would have noticed if the notes were out of beat after recording.
2. The Babyface drivers are the problem, and by installing them on my old system I disrupted its (working) driver architecture, so that the issue also came up with the Fireface.
3. There's something wrong with the new USB eLicenser. It's the only thing (apart from the Babyface) I used with the new and the old setup.

This is a very tough and annoying issue. Has anyone any idea?
Thanks in advance!

Guest

Re: MIDI notes too early

Post by Guest »

Did you try to record some MIDI data from your Babyface's MIDI out to its MIDI in?
What's the result?

User avatar
Toronja
Junior Member
Posts: 74
Joined: Fri Mar 18, 2011 1:25 pm
Location: Argentina
Contact:

Re: MIDI notes too early

Post by Toronja »

I have the same problem with this configuration

OSX 10.7.3, intel i7 24 gb ram, Cubase 6.07 (and all the 6 versions)
Key AXIOM 49 (USB)
Music Composer / www.pabloborghi.com

Guest

Re: MIDI notes too early

Post by Guest »

Solution's in the manual, Knowledge Base and the old forums.

SteadyEddie
New Member
Posts: 42
Joined: Sat Feb 18, 2012 2:57 pm
Contact:

Re: MIDI notes too early

Post by SteadyEddie »

Someone here thinks he's a super guru, but is afraid to actually provide solutions because everyone would call him on it and show how wrong he can be. And he does this in the guise of saying that no one should be spoon fed.

There has been a lot of discussion related to this in another thread. I would try Niles suggestion of the Midi Out and Midi In test. I would also try the audio thump test. Without the click track, use a Mic to record the key being hit. Compare this to the placement of the midi note in another track. Zoom in to see the difference using the transport bar times.

With this test I had a difference of 13 msec using my Presonus Firepod. Midi is actually later than audio for me. I am now using a Fireface 800 and see a slight reduction using RME Direct Music driver. Midi is now around 9 ms after, audio. However, now I tried another Midi controller and see only 4 ms gap.
Last edited by SteadyEddie on Fri May 18, 2012 3:53 pm, edited 1 time in total.
Cubase 6.5.1 Creation Station 250 Core i5-2400
RME Fireface 800

User avatar
De-Fine music
Junior Member
Posts: 154
Joined: Sun Jan 16, 2011 6:22 pm
Contact:

Re: MIDI notes too early

Post by De-Fine music »

Did you try this?
MIDI notes in Cubase are getting recorded to the start of the MIDI clip.
If you are recording MIDI data into Cubase through the Saffire MIDI in port and find that it is all being recorded to the start of the MIDI clip then follow these steps to fix the problem:


1. Update your version of Cubase to the latest version (updates available from http://www.steinberg.de).

2. Browse to the Cubase SL/SX application folder (usually C:Program FilesSteinbergCubase SL/SX) and locate the folder "MIDI Port Enabler".

3. Open this folder.

4. Pick the file "ignoreportfilter" and move it into the Cubase SL/SX application folder (one directory up).

5. Start Cubase. You will now see 'Focusrite Saffire' and 'Focusrite Saffire [Emulated]' as available MIDI ports.

6. Select 'Device Setup...' from the 'Devices' menu.

7. Go to the 'Default MIDI Ports' page and set 'Focusrite Saffire [Emulated]' as both input and output.

8. Go to the 'All MIDI Inputs' page and make sure 'Focusrite Saffire' is not active and 'Focusrite Saffire [Emulated]' is activated (click on 'Yes' or 'No' in the 'Active' column to change it).

9. Go to the 'DirectMusic' page and check the 'Use System Timestamp' box.

10. Click 'Apply' and then 'OK' to exit Device Setup.
not sure if it still applys to the current version but i remember having the same issue a few years ago and this was what fixed it for me...

Guest

Re: MIDI notes too early

Post by Guest »

SteadyEddie wrote:Someone here thinks he's a super guru, but is afraid to actually provide solutions because everyone would call him on it and show how wrong he can be. And he does this in the guise of saying that no one should be spoon fed.
Yep. I'm a super guru. Used to have the issue, don't anymore. ;)

I've given where to find the answer over and over but you are too lazy/ stupid to bother to look for it yourself. :roll:

SteadyEddie
New Member
Posts: 42
Joined: Sat Feb 18, 2012 2:57 pm
Contact:

Re: MIDI notes too early

Post by SteadyEddie »

Yer Mom III wrote:Yep. I'm a super guru.
Perhaps you should start your own super guru forum where you can mingle with your own kind, and leave us mere mortals alone.
Cubase 6.5.1 Creation Station 250 Core i5-2400
RME Fireface 800

User avatar
mr.roos
Senior Member
Posts: 1610
Joined: Thu Apr 07, 2011 6:56 pm
Contact:

Re: MIDI notes too early

Post by mr.roos »

This is from the Help section of Device Setup:

"If timing problems with the recorded MIDI events occur with your operating system, try activating the “Use System Timestamp” options.
All MIDI interfaces timestamp their data before supplying it to the application. The application uses these timestamps to position incoming MIDI events in the sequencer. There may be situations in which these timestamps are not in sync with the internal time information of the sequencer, so recorded MIDI events will not be positioned correctly (usually, they occur “too late”). When you activate this option, the sequencer ignores the MIDI timestamps provided by the interfaces (for Windows MIDI and Direct Music inputs, respectively) and generates new timestamps (using the actual system time) for all incoming MIDI data."
Cubase 10.5 Pro from SX3, WaveLab Pro 10, Groove Agent 5, iC Pro remote app, Win10 64-bit (2004 update installed - latest OS build always), Intel i7 8700 Coffee Lake 6-Core 3.2GHz, 32G DDR4 3200, Gigabyte Z390 Designare MB, Radeon RX570 Graphics card, Mackie 1640i (FireWire via TI chipset PCI-E card), 1K iRig Pads, StudioLogic Numa Compact 2X 88-Key, and Roland FP-30.

Guest

Re: MIDI notes too early

Post by Guest »

Nope, wrong. :roll:

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: MIDI notes too early

Post by alexis »

creartistic wrote:I know this has been asked before, but no thread (at least no one that I found) focused on the issue and came to a clear solution.

PROBLEM: Notes being played on my master keyboard in accordance with the metronome are recorded slightly too early, i.e. they appear slightly but noticably to the left in key editor. ...

- reducing buffers on the Babyface to second lowest option did reduce the amount of "negative latency", but it's still there ...
What buffer size did you have originally, and what did you "reduce" it to as mentioned above?

Might also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Guest

Re: MIDI notes too early

Post by Guest »

Clueless. :roll:

Conman
Senior Member
Posts: 2116
Joined: Fri Dec 17, 2010 4:31 am

Re: MIDI notes too early

Post by Conman »

Try reverting your soundcard driver to an earlier one, or get the latest whichever applies.
Or even disable your soundcard and use the onboard soundcard to see if the same timing anomalies occur.
also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?
On some recent cards using a very high buffer rate can increase instability in the card or driver.
Try adjusting the ppqn rate in Preferences.
Asus P6T deluxe; Core i7 920 2.67gHz; 12gig ram; Win7 Pro SP1; Roland Octa-Capture usb inteface; Cubase 6; and no 3rd party additions couple of hard drives PSU 750watt; NVidia GE Force 9600.
"An entrepreneur accepts that the world is the way that it is and goes about changing it rather than waiting for someone to make it easy for them."

Guest

Re: MIDI notes too early

Post by Guest »

Conman wrote:Try reverting your soundcard driver to an earlier one, or get the latest whichever applies.
Or even disable your soundcard and use the onboard soundcard to see if the same timing anomalies occur.
also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?
On some recent cards using a very high buffer rate can increase instability in the card or driver.
Try adjusting the ppqn rate in Preferences.
Nope. Can't believe how quickly knowledge disappears. This has been covered so many times it isn't funny. One setting is all it takes to fix the issue without fail in the dozens of times this came up here and the old forums. I have M-Audio and Alesis kit that suffers from the issue without the fix. I initiate the fix and presto, my MIDI is spot on. ;)

msy
Member
Posts: 380
Joined: Wed Dec 15, 2010 11:37 pm
Location: Sweden
Contact:

Re: MIDI notes too early

Post by msy »

MIDI issues on Windows (from Steinbergs Knowledge Base):

https://www.steinberg.net/en/support/kn ... on-windows
Cubase Pro 10.5.20
HALion 6.3.1
OS: Windows 10 (1903)
Soundcard: RME Digiface USB with ADA8200 + ARC USB
DAW: AMD Ryzen 3950x | ASUS Prime x570-P | 32GB DDR4 3600MHz | Intel p660 NVMe M.2 2TB | Samsung EVO SSD 250GB SATA | Sapphire Pulse Radeon RX 5700 XT (set to PCIE 3.0 in BIOS w/drivers Adrenaline v19.11.3)
Screen: Philips 439P9H (Curved SuperWide 32:10) @ 3840x1200
Computer related hardware: 2xUAD-2 Duo PCIE, BCF2000 (MCU), Nord Wave, Eurorack via ES3/ADAT
Other DAWs: Bitwig 3.2

Conman
Senior Member
Posts: 2116
Joined: Fri Dec 17, 2010 4:31 am

Re: MIDI notes too early

Post by Conman »

Yer Mom III wrote:
Conman wrote:Try reverting your soundcard driver to an earlier one, or get the latest whichever applies.
Or even disable your soundcard and use the onboard soundcard to see if the same timing anomalies occur.
also try to do the same recording technique with the buffer size at MAXIMUM. Do the MIDI notes move earlier than the 8 msec they are now (1/64th note at 120 BPM)?
On some recent cards using a very high buffer rate can increase instability in the card or driver.
Try adjusting the ppqn rate in Preferences.
Nope. Can't believe how quickly knowledge disappears. This has been covered so many times it isn't funny. One setting is all it takes to fix the issue without fail in the dozens of times this came up here and the old forums. I have M-Audio and Alesis kit that suffers from the issue without the fix. I initiate the fix and presto, my MIDI is spot on. ;)
Don't panic, just belt and braces just in case. Midi to audio question next. :mrgreen:
Asus P6T deluxe; Core i7 920 2.67gHz; 12gig ram; Win7 Pro SP1; Roland Octa-Capture usb inteface; Cubase 6; and no 3rd party additions couple of hard drives PSU 750watt; NVidia GE Force 9600.
"An entrepreneur accepts that the world is the way that it is and goes about changing it rather than waiting for someone to make it easy for them."

User avatar
Toronja
Junior Member
Posts: 74
Joined: Fri Mar 18, 2011 1:25 pm
Location: Argentina
Contact:

Re: MIDI notes too early

Post by Toronja »

i can't fix it...
The same fu..... thing, midi too early, I can't understand why using Steinberg hard (mr 816) I have this problem
I have installed the driver again (mr) and nothing change.
MAC pro, 10.7.3 (64 bit) CB 6.07 (x64)
AXIoM 49 (1st generation)
intel i7 920 24 gb ram

Can somebody help me?
I have spent 2 days reading forums and I don't find the solution, is there one or is just a F.....Bug?

Pablo
Music Composer / www.pabloborghi.com

Guest

Re: MIDI notes too early

Post by Guest »

Toronja wrote: is there one or is just a F.....Bug?
There is one, no bug. The forum would be up in arms if it was a bug. Like I said, answer's in the KB and manual.

User avatar
Toronja
Junior Member
Posts: 74
Joined: Fri Mar 18, 2011 1:25 pm
Location: Argentina
Contact:

Re: MIDI notes too early

Post by Toronja »

answer's in the KB and manual.
I can't find the fix there.
I read also the hardware manual (MR 816) and nothing
Could you be more specific about it? I couldn't find anything in CB manual neither, just about buffer, but this is not my problem I think.

Thanks in advance

Pablo
Music Composer / www.pabloborghi.com

Guest

Re: MIDI notes too early

Post by Guest »

I've been more specific dozens of times at the old forum and here. The answer is in the Knowledge Base and specifically states the issue.

I've told you there is a solution and where to look for it, the rest is up to you.

User avatar
Toronja
Junior Member
Posts: 74
Joined: Fri Mar 18, 2011 1:25 pm
Location: Argentina
Contact:

Re: MIDI notes too early

Post by Toronja »

Could you post a Link?
I just find solutions for PC in KB, not mac.
Thanks
Music Composer / www.pabloborghi.com

Guest

Re: MIDI notes too early

Post by Guest »

Ah, Mac, that explains it. ;)

IIRC, someone posted a solution for Mac on the old Nuendo forum. Been too long to say for sure.

User avatar
Toronja
Junior Member
Posts: 74
Joined: Fri Mar 18, 2011 1:25 pm
Location: Argentina
Contact:

Re: MIDI notes too early

Post by Toronja »

ahh ok, I will try to find it in Nuendo forum, thanks for your help!

Pablo
Music Composer / www.pabloborghi.com

LeVzi
Member
Posts: 343
Joined: Sun Dec 19, 2010 8:37 pm
Contact:

Re: MIDI notes too early

Post by LeVzi »

Seriously guys, ignore "yer mom" he's full of **** and is trolling the hell outta this issue.

His username says it all tbh.

There is no working fix, it isn't in the old forums, knowledge base or anywhere else.

So just put the douche bag on ignore and maybe he'll get bored n disappear up his own arse.
AMD FX 8350 4Ghz , 16Gb DDR3 RAM, 1x1TB SSD, 1x1TB HDD 1x500gb HDD. Sapphire RX 560 4Gb Graphics, Audient ID 14 USB Interface, Alesis Q49 Keyboard. Cubase 10 Pro

Guest

Re: MIDI notes too early

Post by Guest »

LeVzi wrote:Seriously guys, ignore "yer mom" he's full of **** and is trolling the hell outta this issue.

His username says it all tbh.

There is no working fix, it isn't in the old forums, knowledge base or anywhere else.

So just put the douche bag on ignore and maybe he'll get bored n disappear up his own arse.
What a lazy crybaby. :lol:

You've said before you put me on ignore. Didn't work too well for you, eh?

If there's no fix, then how did I fix it here? ;)

You're the one with his head up his A S S, you prove it by not being able to follow simple directions to fix the issue yourself. You'd rather p i s s and moan than do a little legwork for yourself. Does mama still feed you when cry for the tit? :roll:

Once more, this has been covered more times than I can count and everyone on Windows has sorted it, without fail. :idea:

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 8 guests