MIDI notes too early

For users of legacy Steinberg Cubase software
Bassbase
Member
Posts: 833
Joined: Thu Nov 03, 2011 8:33 pm
Contact:

Re: MIDI notes too early

Post by Bassbase »

So why don't we start to post in this threads all systemspecs ? Specs in my signature have no midinotes too early symptomes.

So letz collect the good and the bad specs perhaps than we can see a pattern.

Greetz Bassbase
I7 3.2ghz / Asus P6t deluxe / Asus GTX260 / Rme Hdsp 9632/ Novation 49 sl compact / KRK Rokit 5 / Native Instruments Komplete 7 / Fabfilter Pro q, ....

Just to make sure you know the basics, come here.
Forum Knowledgebase from Users for Users
And if you like this idea or you have more stuff you think a beginner should know about, feel free to PM me so i can take it to the top. Together we know nearly everything...
Forum Knowledgebase von Usern für User Say hello after change

phmx1728
New Member
Posts: 2
Joined: Sat Jul 23, 2016 10:25 am
Contact:

Re: MIDI notes too early

Post by phmx1728 »

I have Cubase 8.5. Under prefs go to MIDI and activate delay compensation by default.

Earlier Cubase versions that don't have that option: Increase the ASIO buffer to 512 or 1024.
Depending on your project sample rate setting you should get around 20ms total latency.
This is better than auto quantize!

Sound check: use a midi device that also has a sound engine, record both audio and MIIDI and see if the waves line up with the MIDI notes.

easy peasy
:geek:

alsween
New Member
Posts: 2
Joined: Mon Jan 20, 2020 5:54 am
Contact:

Re: MIDI notes too early

Post by alsween »

Almost 8 years later but the answer is to go where it lists your audio interface (soundcard). Under VST Audio System you uncheck the box where it says "Adjust for Record Latency".


I see 6 more pages so someone probably answered but in case someone didn't I hope I was helpful as opposed to the arrogant guest.

hweinkum
New Member
Posts: 3
Joined: Tue Apr 14, 2020 9:39 pm
Contact:

Re: MIDI notes too early

Post by hweinkum »

Guest wrote:
Fri May 18, 2012 1:44 pm
Solution's in the manual, Knowledge Base and the old forums.
the solution is NOT in the manual OR the knowledge base!!!!!!!!!!!!!!!!!! It is super frustrating having this problem and nobody seems to have a solution. If you have one, post it here.

hweinkum
New Member
Posts: 3
Joined: Tue Apr 14, 2020 9:39 pm
Contact:

Re: MIDI notes too early

Post by hweinkum »

Guest wrote:
Sat May 19, 2012 6:12 pm
Toronja wrote: is there one or is just a F.....Bug?
There is one, no bug. The forum would be up in arms if it was a bug. Like I said, answer's in the KB and manual.
I checked the manual and spent DAYS reading thru forums, NO answer anywhere that works. Instead of spending your time giving monious anwers, why don't you tell us what to do?

hweinkum
New Member
Posts: 3
Joined: Tue Apr 14, 2020 9:39 pm
Contact:

Re: MIDI notes too early

Post by hweinkum »

LeVzi wrote:
Sat May 19, 2012 6:48 pm
Seriously guys, ignore "yer mom" he's full of **** and is trolling the hell outta this issue.

His username says it all tbh.

There is no working fix, it isn't in the old forums, knowledge base or anywhere else.

So just put the douche bag on ignore and maybe he'll get bored n disappear up his own arse.
I agree

philjump
New Member
Posts: 2
Joined: Tue Aug 23, 2016 4:46 am
Contact:

Re: MIDI notes too early

Post by philjump »

For what it's worth by way of info.....

I have used Cubase 7.5 for 6 years with a Windows 7 pc. I have used a Focusrite Scarlett 1820i with it. No problems at all with Midi latency....and lets be clear, I am talking about MIDI latency - not AUDIO latency......I have never had a problem with audio latency.

I recently was forced to start using a new Windows 10pro pc due to loss of support for the W7 machine and reluctantly spent days setting up Cubase on the new W10 machine from my original disk and all my vst plugins and licenses on that new pc.

When I finally started to actually record, suddenly I encounter this midi latency problem....i.e. (as in the posts below) ......when I record anything using my midi controllers (various) there is no sound latency as I'm playing, but I can see that all the midi notes are being offset to about 3/8th's of a bar earlier than when I actually play them and so if I play a note on the very first beat of the bar it is lost.

I've tried every fix suggested here and elsewhere, but nothing seems to work.

I still have Cubase 7.5 on my old Window 7 pc and can simply switch my Focusrite 1820i and elicenser back to that again to see if the midi latency happens on the old pc now

NO - IT DOESN'T!! - and I'm forced to go back to using the old pc.....minus half my plugins which are just too tedious to reload......

I have laboriously checked all the settings for everything mentioned below ...and more.....and set up Cubase identically on both machines.

Midi latency only happens for me on the Windows 10 pc......not on the Windows 7.....using all the same hardware and software.

So what is the problem here? My Steinberg support here in Singapore is great....but also unable to locate the source of the problem.

Does anyone in Steinberg central have an idea? This has obviously been going on for years judging by all the posts in different forums I've read.

philjump
New Member
Posts: 2
Joined: Tue Aug 23, 2016 4:46 am
Contact:

Re: MIDI notes too early

Post by philjump »

Finally.....this seems to have worked for me!!! Thanks Mr Roos!!

Re: MIDI notes too early

Post by mr.roos » Sat May 19, 2012 7:59 am
This is from the Help section of Device Setup:

"If timing problems with the recorded MIDI events occur with your operating system, try activating the “Use System Timestamp” options.

Go to "Devices>Device Setup> MIDI Port Setup" and tick the two boxes at the bottom of the popup

Alessio
New Member
Posts: 11
Joined: Sun Nov 25, 2018 5:03 pm
Contact:

Re: MIDI notes too early

Post by Alessio »

philjump wrote:
Mon Apr 27, 2020 9:44 am
I recently was forced to start using a new Windows 10pro pc due to loss of support for the W7 machine and reluctantly spent days setting up Cubase on the new W10 machine from my original disk and all my vst plugins and licenses on that new pc.

When I finally started to actually record, suddenly I encounter this midi latency problem....i.e. (as in the posts below) ......when I record anything using my midi controllers (various) there is no sound latency as I'm playing, but I can see that all the midi notes are being offset to about 3/8th's of a bar earlier than when I actually play them and so if I play a note on the very first beat of the bar it is lost.
This is a really interesting post! Because I (also) have Cubase 10 Pro and the same issue only occurs on Win10 Pro (Lenovo T480s). Everything works completely fine on two other computers (2x Lenovo T440s with Win8.1). So this is maybe a problem with MIDI on Win 10?

(Just for the record, I also had this issue on Cubase 4 on WinXP and the “Use System Timestamp” option solved it.)

Alessio
New Member
Posts: 11
Joined: Sun Nov 25, 2018 5:03 pm
Contact:

Re: MIDI notes too early

Post by Alessio »

FWIW, I installed a fresh Win10 partition on the same PC without removing the existing Win10 installation so I would be able to compare. On the new Win10 I installed Cubase 10 and Halion 6 only, plus my controller's MIDI/audio driver. Surprisingly, the new installation does not have problems with early MIDI notes, while the older installation (on the same PC) does have issues. Maybe at some point in time some software installation caused an issue on my older Win10. So although I was not able to pinpoint the exact cause, it seems worth making a fresh Win10 install and keeping it dedicated for Cubase use only. Although in your case it seems that is exactly what you did.

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: Google [Bot] and 4 guests