Page 1 of 1

TestGenerator pink noise levels incorrect. Cubase Pro 8.5.15

Posted: Wed May 11, 2016 11:32 am
by Simon Barden
I was messing about with the TestGenerator when I noticed that the peak output level for pink noise was higher than it should be by +2.5dB. All the sine, triangle, square, sawtooth,white noise and Brownian noise levels peaked at the level value set within TestGenerator, but for pink noise, the peak value was consistently higher than the output level setting e.g. set to -20dB it peaked at -17.5dB and -30dB peaked at -27.5dB.

Note that I had already set the panning law to 0dB, so that there was no reduction in the signal level from the channel to take into consideration.

Whilst the effect can easily be compensated for (if known about), it would be nice if this small error could be fixed. I couldn't see this issue raised anywhere else.

Thanks.

Re: TestGenerator pink noise levels incorrect. Cubase Pro 8.

Posted: Wed May 11, 2016 7:09 pm
by Simon Barden
Whilst I'm looking at the TestGenerator, could someone look at improving the sawtooth wave output? I attach a screendump of the output at 440Hz. It should obviously have a very sharp/instantaneous rise followed by a nice linear drop off. Instead it's all curves, and as a result, it has the wrong RMS value. It should have the same RMS value as the triangle wave i.e. -4.77dB below its peak value, but instead it's -5.3dB below, due to all those wavy edges. So useless for the purpose for which it's designed.