Page 1 of 1

Grand 3 - midi latency

Posted: Mon Dec 08, 2014 7:18 pm
by edipro
I just purchased the Grand 3 and it installed without a problem.
Playing a midi file is fine, but when I play live from a keyboard, there is latency; not very much, but enough to made a performer (I'm not a pianist) have problems. I have keyboards both with traditional midi cable and USB midi; no difference. Any suggestions?
Albert
Toronto, ON


Win7 64bit
Intel i5
16G ram
SSD drives (the samples are on a separate SSD; loading time for a piano is about five seconds or less)
Fireface 400 sound card (two Midi ins and outs)
Cubase 7.5

Re: Grand 3 - midi latency

Posted: Fri Dec 12, 2014 7:37 am
by Muziksculp
edipro wrote:I just purchased the Grand 3 and it installed without a problem.
Playing a midi file is fine, but when I play live from a keyboard, there is latency; not very much, but enough to made a performer (I'm not a pianist) have problems. I have keyboards both with traditional midi cable and USB midi; no difference. Any suggestions?
Albert
Toronto, ON


Win7 64bit
Intel i5
16G ram
SSD drives (the samples are on a separate SSD; loading time for a piano is about five seconds or less)
Fireface 400 sound card (two Midi ins and outs)
Cubase 7.5
This is Audio Latency rather than MIDI latency.

Try lowering your Fireface 400 buffer setting, to get lower latency. If it is set at a high value, you will get noticeable latency when you play a VST Instrument.

Re: Grand 3 - midi latency

Posted: Sat Jan 03, 2015 8:15 pm
by edipro
Thanks for the reply. I haven't had a chance to get back here last month. I will try this. Thank you again for your time.
I'd just like to add that replies are so few, that I no longer consider this forum as a reliable help source.
But today, I feel like I've won a lottery.