Macbook not powering up CI1

This section is about Steinberg's USB audio interfaces CI1, CI2 and CI2+
Post Reply
Cloon2
New Member
Posts: 1
Joined: Thu Apr 09, 2020 12:07 pm
Contact:

Macbook not powering up CI1

Post by Cloon2 »

This is the case: I own a MacBook Pro (Retina, 15-inch, Mid 2015) and a CI1 interface from Steinberg. I've used it many times and it still functions as of today (checked 2 days ago). I've given it to a friend because i have a new/bigger interface and he owns a Macbook as well. When he plugs in the (same) USB-cable and CI1, the USB-light on the CI1 does not light up and he is not able to see the interface in his settings. In the system overview panel however the USB section does show that it is connected and it nicely displays all the correct info and manufacturer of the CI1. I've instructed him to install the drivers correctly (which he has down several times by now) and also startup his Macbook without the USB being plugged in but unfortunately none of this has led to succes and i can't find any similar cases so far on the internet.

JustinBlack
New Member
Posts: 5
Joined: Fri Jun 19, 2020 9:57 pm

Re: Macbook not powering up CI1

Post by JustinBlack »

If your Mac doesn't turn on then you can follow this step:
1. Press and hold the power button on your Mac for 10 seconds, then press it again.
2.Reset the System Management Controller (SMC).
3.Make sure that your display's brightness is turned up. ...
4.Unplug all accessories from your Mac, including printers, drives, USB hubs, and mobile devices.

Post Reply

Return to “Steinberg CI Series”

Who is online

Users browsing this forum: No registered users and 1 guest