WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post questions and find answers on our latest WaveLab releases here.
Post Reply
intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Sun Oct 27, 2019 6:53 pm

I'm attempting to use / run WaveLab Elements 10 on a 2018 MacBook Pro w/ Touch Bar (Core i7 / Radeon Pro 555x / 16GB / 512GB SSD) and fresh install of macOS Mojave with updates installed (currently at 10.14.6)

I have a CalDigit USB-C Pro Dock connected via (an Apple 0.7m) Thunderbolt 3 Cable and also use an RME BabyFace Pro (with latest drivers) installed and connected to the dock via USB.

I tried the initial WaveLab Elements 10 install and also the 10.0.5 incremental update. I can get a new workspace to open, but whenever I try to open Preferences, the program just Force Quits / Crashes. I've tried with CalDigit dock connected and without the dock & interface connected (just on Battery power with no peripherals connected.) I've deleted the user preferences (under user/Library/Preferences/WaveLab Elements 10.0) with both the dock connected and while running on battery (again, without any additional peripherals connected.) Both versions for macOS are exhibiting the same behavior regardless of what I've tried.

Additionally, I've confirmed the (Software) eLicenser shows the correct license for this version.

Curious if anyone else is experiencing this issue and/or if there is a fix or possibly something I may have not tried as-of yet that may be causing this issue.

I can upload crash logs of both scenarios if necessary.
Last edited by intellect on Sun Oct 27, 2019 11:51 pm, edited 1 time in total.

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Sun Oct 27, 2019 9:03 pm

Please upload crash in PM. Thanks
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Sun Oct 27, 2019 11:52 pm

Done. Please see PM's. Thank you

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Mon Oct 28, 2019 2:50 pm

If you have the possibility, move your eLicenser to a Steinberg dongle.
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Mon Oct 28, 2019 6:44 pm

Hey PG - at this time, I don't own a Steinberg eLicenser dongle. Is this something that stood-out in the crash logs?

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Mon Oct 28, 2019 7:10 pm

Yes, we have a mysterious case that happens only an WaveLab Elements and in specific scenario and only on some machines (and the crash log shows this case). So far using a physical dongle cured the problem each time. This being said, we could have a solution for 10.0.10, if you can wait.
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Mon Oct 28, 2019 7:28 pm

How long do you expect before the 10.0.10 release is out? Also, would it be possible to have a license re-issued for 9.5 so I have something to work with in the interim? Thanks for your assistance.

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Mon Oct 28, 2019 9:11 pm

You can use WaveLab Elements 9.5 with the WaveLab 10 license. But the problem might happen in 9.5 too.
10.0.10 should happen in november, but not before mid.
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Tue Oct 29, 2019 12:02 am

Well, gave WaveLab Elements v9.5.50.208 a shot and was actually able to click-on Preferences, but crashed soon there-after (like you said would happen.) This really stinks. I tested on my PC (Lenovo X1 Carbon 6th Gen / Core i7-8550U / 16GB / 512GB SSD) and had no issues what-so-ever (and that was an in-place upgrade.) Guess it's a sit and wait game, since I really hate to spend the money on eLicenser dongle I will never use again once this is resolved.

User avatar
Arjan P
Senior Member
Posts: 2546
Joined: Wed Dec 15, 2010 6:28 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by Arjan P » Tue Oct 29, 2019 7:35 am

Also you have to realize that once you move the license to the eLicenser dongle, there is no way to move it back to the soft eLicenser..
--- "If anyone owes it all to Bach, it's God" - Emil Cioran ---
SOFT: (All 64 bit) | WaveLab 10.0.10 | Cubase 10.0.50 | HALion 6.0 | Win10 Pro - SoundCloud
HARD: i7-950 | Asus P6TD | 30GB | Tascam DM-3200 | DigiMax48 | Midisport 8x8 - SoundByte Studio

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Tue Oct 29, 2019 1:41 pm

Thanks for clarifying that Arjan. Even more reason to just hold-out for the 10.0.10 update at this time.

jlavancier
New Member
Posts: 2
Joined: Wed Oct 23, 2019 7:25 am
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by jlavancier » Thu Oct 31, 2019 8:19 am

PG wrote:
Mon Oct 28, 2019 7:10 pm
Yes, we have a mysterious case that happens only an WaveLab Elements and in specific scenario and only on some machines (and the crash log shows this case). So far using a physical dongle cured the problem each time. This being said, we could have a solution for 10.0.10, if you can wait.
Thank you for this very clear feedback
I'll wait for 10.0.10
For sure the same solution will be needed for WE 9.5.50 which crash same way on Audio Connection tab
Regards

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Fri Nov 01, 2019 1:16 pm

PG - Are you seeing this same issue happening in WaveLab Pro 10 as well?

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Fri Nov 01, 2019 1:18 pm

Are you seeing this same issue happening in WaveLab Pro 10 as well?
No. The crash when going to the preferences, is only on WaveLab Elements, and only on certain machines.
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Fri Nov 01, 2019 1:20 pm

Thanks for the quick reply PG - Was formerly an all PC / Windows 10 user but I'm doing more work on the macOS side recently and was considering purchasing WaveLab Pro, thus my asking.

enzyme
New Member
Posts: 3
Joined: Sat Nov 09, 2019 11:30 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by enzyme » Sat Nov 09, 2019 11:39 pm

I'm having a crash that is very similar to this, most often when using the 'Audio Files' tab in preferences. I'm on High Sierra though. Is it likely to be the same issue?

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Sat Nov 23, 2019 9:05 pm

Wondering how much longer for this 10.0.10 update that's supposed to alleviate this issue? It's almost the end-of-month and still no update.

PG
Moderator
Posts: 7066
Joined: Wed Dec 15, 2010 6:15 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by PG » Sat Nov 23, 2019 9:55 pm

Part of the WaveLab elements issue is solved with the latest elicenser version.
Philippe

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Sun Nov 24, 2019 1:56 am

I have the latest eLicenser. When I click on "Preferences" > "Audio Files" WaveLab Elements 10 crashes every time so, it's not fully resolved.

User avatar
Justin P
Senior Member
Posts: 2467
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by Justin P » Sun Nov 24, 2019 3:42 pm

intellect wrote:
Sun Nov 24, 2019 1:56 am
I have the latest eLicenser. When I click on "Preferences" > "Audio Files" WaveLab Elements 10 crashes every time so, it's not fully resolved.
Intersting. I was having that issue on my laptop (with Catalina installed), but the new eLicenser update solved it.

I wonder if some additional preference files need to be trashed as well.
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

intellect
New Member
Posts: 11
Joined: Sun Oct 27, 2019 6:34 pm
Contact:

Re: WaveLab Elements 10 on macOS Mojave - Crashing upon opening Preferences

Post by intellect » Sun Nov 24, 2019 8:46 pm

Justin P wrote:
Sun Nov 24, 2019 3:42 pm
Intersting. I was having that issue on my laptop (with Catalina installed), but the new eLicenser update solved it.

I wonder if some additional preference files need to be trashed as well.

Just tried trashing WaveLab Elements preferences (since I didn't stand to lose anything at this point in doing-so) and, the issue still persists. :|

Post Reply

Return to “WaveLab Pro 10 | WaveLab Elements 10”

Who is online

Users browsing this forum: Félix Turrión, Google [Bot], Hackej and 2 guests