Major Audio Dropouts On 2048 Buffer Size

Post general topics related to Cubase Pro 9, Cubase Artist 9 and Cubase Elements 9 here.
Post Reply
BasUitermark
New Member
Posts: 8
Joined: Tue May 22, 2018 4:56 pm
Contact:

Major Audio Dropouts On 2048 Buffer Size

Post by BasUitermark »

Hey guys!

I have been having this problem for a while now. I'm having major audio dropouts on Cubase 9.5 with about 85 plugins running, 10 virtual instruments and a buffer size of 2048. I thought by upgrading some parts of my pc that I would be able to fix it, but that only lasted a short time. I tried the optimizing guide from sweetwater but that did nothing for me.

I'm running Cubase from my main C SSD drive and have my project folders on a seperate SSD.

PC Specs:

CPU: Intel i7-7820X 3.60 GHz
COOLER: be quiet! Dark Rock Pro 3
MOBO: MSI X299 Raider
RAM: Corsair DDR4 Vengeance LPX 2x8GB 2666 C16
GPU: XFX R9 280X Black Edition
PSU: Seasonic M12II 620W
OS: Windows 10

SSD 1: Samsung 850 Evo 250 GB
SSD 2: WD Blue WDS100T2B0A 1TB
HDD 1: WD Black WD3003 FZEX 3TB
HDD 2: WD Black WD4005FZBX 4TB

Thanks for any help!

User avatar
peakae
Grand Senior Member
Posts: 3297
Joined: Sat Jan 05, 2013 8:15 pm
Location: Bedroom
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by peakae »

Soundcard/Audio device and drivers used ?
Have you disabled all power saving options in BIOS ?
Any heavy cpu hungry plugins on the Master Bus ?
Are all system drivers up to date ? (Including drivers for stuff that is not audio related)
Cubase Pro 10, Wavelab Elements 9, I7 3770K , win10x64, 16Gb Ram, RME Raydat, Steinberg MR816x, Motu 828mkII, Behringer ADA8200, Yamaha moXF6, Steinberg UR242, Yamaha THR 10, Grace Design m900, CMC TP, CMC CH.

BasUitermark
New Member
Posts: 8
Joined: Tue May 22, 2018 4:56 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by BasUitermark »

So quick update before answering your questions. I started up my system this morning and the session that I had trouble with yesterday is now behaving normally. The session is operating at about 30% average load. This does happen often where some days it operates normally and other days I just get major dropouts.

I'm using a Focusrite Saffire Pro 40 with the latest Saffire Mixcontrol 3.7.
Yes I have, including C-State, Turbo and hyperthreading.

The plugins I'm running on my master bus are:
1. Fabfilter Pro-Q2
2. Fabfilter Pro-MB
3. Izotope Ozone 7
4. Fabfilter Pro-L2
5. Magic AB

But removing these plugins doesn't seem to do much to ease the load. The perfomance only seems to go up when I run a maximum of about 40 plugins. Doesn't really seem to matter which plugins I remove.

I updated most of my system drivers last week.

Jari Junttila
Member
Posts: 241
Joined: Tue Oct 25, 2011 2:35 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by Jari Junttila »

Try the fls checker vst from this forum to check if you just run out of slots, known issue on win10

viewtopic.php?f=250&t=134715
Format c:

User avatar
Grim
Grand Senior Member
Posts: 5064
Joined: Thu Jan 06, 2011 5:08 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by Grim »

Jari Junttila wrote:
Thu Aug 16, 2018 2:15 pm
Try the fls checker vst from this forum to check if you just run out of slots, known issue on win10

viewtopic.php?f=250&t=134715
OP is having audio dropouts....not missing plugins or failure to load plugs :?
i7 5820k @3.7Ghz, 16Gb, W10Pro, Cubase 9.0x, Cubase 8.5.x, Audient iD22, Zoom UAC-2, Wavelab Elements 9.x, Nektar Impact GX61

User avatar
Prock
Grand Senior Member
Posts: 3970
Joined: Sat Jan 05, 2013 4:22 pm
Location: Connecticut, USA
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by Prock »

BasUitermark wrote:
Thu Aug 16, 2018 12:18 pm
So quick update before answering your questions. I started up my system this morning and the session that I had trouble with yesterday is now behaving normally. The session is operating at about 30% average load. This does happen often where some days it operates normally and other days I just get major dropouts.
Use the Windows Task Manager to compare what processes may be running on your "good" days and "bad". Who knows, maybe Windows is doing a background update of some kind. Maybe an unknown scheduled drive defrag or antivirus scan.

Regards 8-)
PRock Studio

DAW: Cubase Pro 10.5.20, OS: Win 10 Pro x64, CPU: Intel Core i7 4700K @ 4.0GHz, RAM: 32GB/DDR4/2800MHz, Graphics: 4GB GeForce GTX 960, Mobo: MSI Z170A Gaming Pro Carbon, AI: PreSonus Studio 192 Mobile, Mic Preamp: PreSonus TubePre, Headphone Amp: PreSonus HP4, Studio Monitors: Mackie MR5, 3rd Party VSTs: GSi VB3-II, SampleTank 3, Amplitube 4, Miroslav Philharmonik 2, EZDrummer 2

https://soundcloud.com/prockstudio

BasUitermark
New Member
Posts: 8
Joined: Tue May 22, 2018 4:56 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by BasUitermark »

So Cubase started being troublesome again and so I started comparing Windows Task Manager from when it was running fine and how it is running today. Not a whole lot is different. But what I did find out is that the same session with the same settings is acting differently. A couple of days ago it used 21% of my processor and 5.5 Gb of RAM, but today it uses 40% of my processor and 7 Gb of RAM.

A couple of days ago the average load was prett stable at about 30% and real time peak only started fluctuating when I was playing back sound, but today the average load is jumping between 70% and 100% and real time peak is constantly at around 30% while not even playing sound.

I'm a bit at a loss here. Anybody got an idea what's going on?

Here are some images while on standby:

Good day Performance Meter:
Image

Good day Task Manager:
Image

Bad day Performance Meter (taken right after eachother):
Image
Image

Bad day Task Manager:
Image

BasUitermark
New Member
Posts: 8
Joined: Tue May 22, 2018 4:56 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by BasUitermark »

I tried to summarize what happened the last couple of days with the audio performance and what the task manager showed me. I also included how many and what tracks I used, the plugins and the amount of plugins I used in this session.

Day #1 Thursday 16 Aug 2018 (Good Day):
Started up Cubase 9.5.30 at 10:30. Showed no problems whatsoever all day.

Buffer size 2048: During standby it reached a maximum of ~30% average load and real time peaks hovered around 0%. Task manager showed a 21% usage of the CPU and 5.5 Gb of RAM during standby.

I did no measurements during playback.

Day #2 Saturday 18 Aug 2018 (Bad Day):
Started up Cubase 9.5.30 at 18:30. Immediately the meters started spiking up to maximum and long audio dropouts concurred. Only when there is a small amount of tracks playing the dropouts lessen.

Buffer size 2048: During standby it reached a maximum of ~70% to 100% average load and real time peaks hovered around ~30%. Task manager showed a 40% usage of the CPU and 7 Gb of RAM during standby.
During playback it stays between 90% and a 100% average load and real time peaks hovers between 50% and 75%.

I did no measurements during playback of the task manager.

Day #3 Friday 19 Aug 2018 (Good Day):
Started up Cubase 9.5.30 at 12:30. Showed no problems whatsoever all day.

Buffer size 2048: During standby it reached a maximum of ~30% average load and real time peaks hovered around 15%. Task manager showed a 19% usage of the CPU and 4.2 Gb of RAM during standby.
During playback it reached a maximum of 60% to 70% average load and real time peaks hovered around 20%. Task manager showed between 26% and 29% usage of the CPU and 4.2 Gb of RAM during standby.

Buffer size 512: During standby it reached a maximum of ~40% average load and real time peaks hovered around ~25%. Task manager showed a 22% usage of the CPU and 4.3 Gb of RAM during standby.
During playback it reached a maximum of 60% to 70% average load and real time peaks hovered around 25%. Task manager showed between 33% and 38% usage of the CPU and 4.3 Gb of RAM during standby.

Buffer size 256: During standby it reached a maximum of ~45% average load and real time peaks hovered around ~30%. Task manager showed a 24% usage of the CPU and 4.1 Gb of RAM during standby.
During playback it reached a maximum of 65% to 80% average load and real time peaks hovered around 35%. Task manager showed between 33% and 34% usage of the CPU and 4.1 Gb of RAM during standby.

Buffer size 128: During standby it reached a maximum of ~50% average load and real time peaks hovered around ~35%. Task manager showed a 27% usage of the CPU and 4.1 Gb of RAM during standby.
During playback it reached a maximum of 70% to 80% average load and real time peaks hovered around 50%. Task manager showed between 36% and 39% usage of the CPU and 4.1 Gb of RAM during standby.

At 17:00 I tried closing and opening Cubase to see if the time of day makes a difference to the performance. Upon closing Cubase froze. Forced closing through task manager.

Upon reopening Cubase on a buffersize of 256 I had an average load of 45% and real time peaks hovered around 5%. Task manager showed a 23% usage of the CPU and 6.7 Gb of RAM during standby.

Session Information:

Settings
Sample rate: 44.1 kHz
Bit Depth: 24 Bit

Project
Tracks:
Group tracks: 15 + 1 Instrument Bus + 1 Master Bus
Instrument tracks: 16
FX Tracks: 5
Audio Tracks: 56


Plugins used:

Fabfilter Pro-Q2: 40
Fabfilter Saturn: 6
Fabfilter Pro-MB: 3
Fabfilter Pro-R: 2
Fabfilter Pro-L: 2
Fabfilter Pro-C2: 1
Fabfilter Pro-L2: 1
Helix Native: 2
iZotope Ozone 7: 1
JST Sidewidener: 3
JST Finality Advanced: 1
JST BG-Bass: 1
JST BG-Guitars: 1
JST BG-Keys: 1
Klanghelm MJUC: 1
Lexicon Concerthall: 1
LX480 Complete: 1
Magic AB V2: 1
Slate Virtual Mix Rack: 5
Slate Virtual Tape Machine: 4
Slate Verbsuite: 1
Slate Trigger 2: 3
Soundtoys Echoboy: 4
Soundtoys Phase Mistress: 3
Soundtoys Pan Man: 1
SPL Transient Designer: 1
Valhalla Room: 16
Valhalla Shimmer: 4
Waves API-2500: 2
Waves C4: 1
Waves Rbass: 1
Waves MaxxBass: 1
Waves S1 Imager: 1
Waves Soundshifter Pitch: 1
Waves L1: 1
Waves SSL Comp: 1

Total VST plugins: 120

VSTi’s:
Kontakt: GetGood Drums 2.0
Kontakt: Impact Studio’s Inferno Bass (4x)
Kontakt: The Giant
JST Subdestroyer
Xfer Serum (x4)

Total VST plugins: 7

chednb
Junior Member
Posts: 123
Joined: Mon Sep 10, 2012 1:25 pm
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by chednb »

Hi!

+1 for the performance issue

Did you already found out more about your performance issue?
I also struggle a lot with performance issues with my system... already under Cubase 9 / 9.5 and now also on Nuendo.
Sometimes it doesnt't need a lot... just a few vst instruments and a few plugins, and my system is completely on the edge.
I already found out, that some waves plugins are very very performance hungry! But that shouldn't be the thing at all... in my opinion.

Im working with Win10 Pro 64bit latest Updates
i7-4820K 3,80GHz
32GB RAM
Nuendo 10 latest
RME Fireface UFX+ latest driver
NVidia Graphics Card Geforce GTX 950 latest driver (my be a problem)

Win 10 and software is installed on my system SSD
Audio Libraries are on a seperate SSD
My projects are located on a seperate SSD

BIOS and Win are "optimized", but I never really felt any difference when optimizing windows for DAWs.

My "workaround" is freezing instruments + tracks, but this really slows down my workflow in a huge way...
Although I'm running on 2048 buffer size, my average load is mostly over 80% and higher. Often It is on 100% and clipping.
But I also have dropouts on 80% and lower. In this case, Nuendo cpu usage varies from 30% up to 65% in the Win task manager.

I don't really know what to do except freezing and thinking about to purchase a more powerful system, although I thought mine is not that bad...


all the best,
cheers
Win10 Enterprise 1909 | Nuendo 10.2.10 | Ryzen 9 3950X | Corsair Vengeance 32GB DDR4 3200 | ASUS Pro WS X570-ACE | NH-D15 SE-AM4 | Seasonic Focus RX-750 | 1x 512GB Samsung 970 Pro NVMe M.2, 1x 1TB Samsung 970 Pro NVMe M.2, 2x 2TB Intel 660p NVMe M.2, 1x 2TB Samsung 860 Evo | NVidia Geforce GTX Titan | RME Fireface UFX+ | Avid S1 | Komplete Kontrol M32

JohnP
New Member
Posts: 1
Joined: Sat Jul 25, 2020 9:43 am
Contact:

Re: Major Audio Dropouts On 2048 Buffer Size

Post by JohnP »

Hi,

I also had this problem on my machine, and couldn't figure it out for a long time. Finally I noticed that the power mode setting on my machine was set to High Performance, which seemed like a perfectly acceptable setting to use when the machine is plugged in. However, when I changed it to a power saving mode, the Cubase dropouts disappeared. The audio performance meter was no longer peaking and stayed relatively stable. I'll let Steinberg have a think about why this might be happening, but in the meantime, I will avoid using a high performance power mode. I suggest you take a look at you power settings and see if changing them makes a difference to the Cubase Audio dropouts, like it did for me.

Cheers,
John

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests