Page 1 of 1

"F" doesn't make a stationary cursor in the Project page ...

Posted: Tue Dec 13, 2016 12:43 am
by alexis
Hi - In Cubase 7.5.40, I had a key command where F would toggle the scroll to be a stationary cursor or a stationary page.

That key command is still in there, but it doesn't seem functional in the project page anymore. The cursor moves L>R across the page, and when it hits the right border, the page snaps to a newer one and the cursor appears on the left border to start moving L>R again. Very difficult to edit that way.

I can't remember, but I *think* it may be properly functional in the Lower Zone - that part I'm not sure about.

Any ideas?

Thanks much!

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 12:56 am
by Martin.Jirsak
Hi,

The F Key Command is assigned to the Auto-Scroll function, by default. It means, if this is On, and the cursor goes out of the screen, the page changes.

It works here. It's independent for the Project page, and the Editor page, in the Project window. It depend, where the focus is. Only if the Link Project and Lower Zone Cursors is enabled, then even the Auto-Scroll is in sync.

When you start to edit something on the page, the Auto-Scroll is switched Off automatically (by default, thanks to the Suspend Auto-Scroll when Editing settings).

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 1:05 am
by alexis
Martin.Jirsak wrote:Hi,

The F Key Command is assigned to the Auto-Scroll function, by default. It means, if this is On, and the cursor goes out of the screen, the page changes.

It works here. It's independent for the Project page, and the Editor page, in the Project window. It depend, where the focus is. Only if the Link Project and Lower Zone Cursors is enabled, then even the Auto-Scroll is in sync.

When you start to edit something on the page, the Auto-Scroll is switched Off automatically (by default, thanks to the Suspend Auto-Scroll when Editing settings).
Thanks, I'll go look at those preferences.

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 1:15 am
by stingray
The 'F' key was never specifically for selecting stationary cursor behaviour. It is for activating auto scroll, where the cursor automatically follows playback in either page scroll or stationary cursor mode.

To clarify, try the following:

- select 'Stationary Cursor' on the small downward pointing arrow on the project window toolbar (next to the auto scroll button
- start playback
- press the 'F' key to Follow the playback (or not Follow the playback) in stationary cursor mode

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 2:49 am
by alexis
stingray wrote:The 'F' key was never specifically for selecting stationary cursor behaviour. It is for activating auto scroll, where the cursor automatically follows playback in either page scroll or stationary cursor mode.

To clarify, try the following:

- select 'Stationary Cursor' on the small downward pointing arrow on the project window toolbar (next to the auto scroll button
- start playback
- press the 'F' key to Follow the playback (or not Follow the playback) in stationary cursor mode
Thank you! It was the stationary cursor I didn't have selected. Very happy now :) .

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 6:56 am
by alexis
So sorry - it still seems a little odd here: When I'm in the project page, and the cursor is off the screen, if I hit "F", Cubase brings me to the part of the project that makes the cursor visible. That's nice, and it's like it was in Cubase 7.5.40.

It used to be the same way if I were in the Edit page when I was in 7.5.40. But now, if I'm editing, and the cursor is off the page, I can't find it by hitting "F", no matter what combination of buttons I try up at the top (the Autoscroll button, and the Switch Auto Scroll Settings dialogues).

Can someone help me with the bolded part please (if it's possible in Cubase 9)?

Thanks!

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 8:43 am
by Martin.Jirsak
Hi,

Is Cubase playing back or is it stop at the moment, you describe?

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 9:09 am
by alexis
Playing, thank you.

And almost certain, but not quite, that it occurs with Cubase stopped too.

Thanks-

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 10:28 am
by Martin.Jirsak
It works as expected here on both Mac and Windows.

Sorry to ask again... Are you 100% sure the focus is in the Lower Zone editor, while pressing the F Key Command? Is there the while frame around the Lower Zone Editor, please?

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 1:43 pm
by stingray
alexis wrote:It used to be the same way if I were in the Edit page when I was in 7.5.40. But now, if I'm editing, and the cursor is off the page, I can't find it by hitting "F", no matter what combination of buttons I try up at the top (the Autoscroll button, and the Switch Auto Scroll Settings dialogues).

Ditto what Martin says. It works OK here. Are you sure you have the focus on the editor?

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 5:09 pm
by alexis
Can you guys try it in VariAudio please? It's the only window I can find that acts this way - while playing, if the cursor is off the screen I can't get Cubase to show it to me.

Thanks much!

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 5:41 pm
by stingray
Works as expected here, with or without variaudio. Auto scroll and all scrolling behaviour is entirely as expected.

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 5:49 pm
by alexis
Thx, Stingray.

I'll put together a repro. As of now, if my cursor is off the page in a VariAudio window, I can't have Cubase bring me to the cursor 's play position by hitting "F", like I can in Cubase 7.5.40.

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 5:51 pm
by stingray
Strange.

Variaudio should make no difference to playback and autoscroll behaviour. All playback and autoscroll behaviour is entirely normal and predictable here. Please tell us exactly what you are doing in a precise step-by-step procedure.

Re: "F" doesn't make a stationary cursor in the Project page

Posted: Tue Dec 13, 2016 7:18 pm
by Martin.Jirsak
Hi,

It works here, in the Sample Editor (VariAudio) as expected as well.