Page 1 of 1

Old Cubase Plugins

Posted: Sat Dec 10, 2016 1:22 pm
by polgara
hi there ,i still use the old double delay ,reverb A and rotary and a few more from way back now and again, they are very simple plugins and do what they say on the can . i don`t like it now that the policeman plugin sentinal has blacklisted them considering they were even actualy made by steinberg . when i open completed projects in cubase 9 now there are lots of missing plugs namely the ones i`ve mentioned ,if you can`t get these old simple plugsins i`ve mentioned working then shame on you.

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 5:33 pm
by zyguli
The reason they are blacklisted is that these are 32 bit plugins and Cubase 9 supports only 64 bit plugins. There is no way to make them work because Cubase since version 9 has got no framework for 32 bit plugins anymore.

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 6:55 pm
by polgara
there must be some way because i just loasded some old 32 bit plugs with jbridge, but can`t load the ones i previously mentioned at the moment .
i don`t know why steinberg hasn`t copied these old plugs , i heard somebody mention that plugs arn`t changed from one version to the next so that the sound will remain unchanged if you load a project into cubase 4 then into say cubase 8 your mix should remain the same .so how am i supposed to do that if they suddenly make something obsolete .

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 6:56 pm
by Haavard
Wouldn't it be nice if Steinberg could make sure that all its own previous plugs worked with 9, i.e. exist in 64-bit versions?

I actually like some of the older ones, including the synths A1 and Embracer, and Bitcrusher (the old version sound different from newer ones.

Even the not-so-great plugs or the ones that have clearly been superseded by something superior would have been nice to have around in order to be able to open old projects correctly.

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 7:08 pm
by scattitude
I emailed tech support on this issue, but they failed to answer my question, so I'll give it a shot here in case anyone has an answer:

While Cubase 9 has some cool features, some of us may want to stick with 8.5 for a while to take advantage of plugins that might be blacklisted (although I am aware you can un-blacklist them in C9). But as part of the upgrade decision-making process, many of us want to first review whether all of our plugins in 8.5 are 64-bit. A few users offered ways to identify 32-bit vs. 64-bit, but I am looking for the best method to identify all of them - either within Cubase 8.5 or in the file-directory structure on my hard drive (i.e. plug-ins folder). Any suggestions proven to work?

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 7:12 pm
by polgara
they don`t have anything like the old reverb A and doubledelay .the newer reverbs are all too dramatic and un transparent and too complicated.
also the rotary from SX3 days was far better than the one they replaced it with in cubase 4.

Re: Old Cubase Plugins

Posted: Sat Dec 10, 2016 10:24 pm
by zyguli
polgara wrote:there must be some way because i just loasded some old 32 bit plugs with jbridge, but can`t load the ones i previously mentioned at the moment .
I'm pretty sure that native Cubase plugins won't run in other VST hosts - which jbridge basically is.