Bug: Wake after sleep - audio is active

Discussions about our next-generation scoring application, Dorico.
Post Reply
User avatar
RedtideMusic
Member
Posts: 352
Joined: Fri Apr 10, 2020 2:14 pm
Contact:

Bug: Wake after sleep - audio is active

Post by RedtideMusic »

I've been consistently finding that on wake after sleep on the computer (Mac, with Dorico running) that the audio engine is running and takes MIDI input, even if Dorico is in the background, with no notes selected, so normally it silences itself*. You have to select Dorico, turn the audio output on and off again a time or two, and at some point the engine figures out itself and will remain silent when it's not the foreground app, and also when note input isn't the mode.

Also, a master mute up on the top bar, next to the metronome would be helpful. Or simply allow the "On" switch that is there to be turned off. I'm not sure what the purpose is other than to indicate the engine is ready. But the button acts like pressing it should do something, but it doesn't. Anyhow allowing us to turn that off and mute is an idea, but better for a dedicated mute button.

* The day before I ended in Logic or MainStage, doing work. Dorico was silent at that point. The next morning I'm getting double audio output first thing, first from MainStage or Logic that I'm looking at, and in the background Dorico likes to chime in
"Dorico is not only a writing partner, but also a composition partner." Paolo

Dorico 3.5, Cubase 11, clarinet (Bb, A & Eb Buffet), piano (Walter 6'5) and a bunch of Moog (Semi modular line)

User avatar
Daniel at Steinberg
Moderator
Posts: 18955
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Bug: Wake after sleep - audio is active

Post by Daniel at Steinberg »

The button at the top right-hand corner of the window is intended to allow you to specify whether the project is activated for playback, like in Cubase; but at the moment, Dorico always activates the frontmost project for playback, and whichever project gains focus and becomes frontmost will thus be activated.

I also find that Dorico does indeed respond to MIDI input when it's in the background, but that's intended (you can continue to e.g. audition notes on your MIDI keyboard to try out ideas). At the moment there's no option to disable this, but you could switch off 'Enable MIDI thru' on the Play page of Preferences if you prefer.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: dankreider, Derrek, FredGUnn, mmka, njfreestone and 8 guests