Doeico 3 died

Discussions about our next-generation scoring application, Dorico.
andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 12:33 pm

On boot up I get the following -

Audio Engine Process Died

Dorico 3 will not load....The only thing I have done is updated Cubase 10.5 to 10.5.12

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 1:03 pm

This file came out as a .Hang - I had to change it to .Crash in order to upload it

Please help someone
Attachments
Dorico 3_2020-03-26-120034_Andys-MacBook-Pro.crash
(1.88 MiB) Downloaded 12 times

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 1:12 pm

anyone?

User avatar
dankreider
Grand Senior Member
Posts: 4982
Joined: Thu Jun 28, 2018 3:45 pm
Contact:

Re: Doeico 3 died

Post by dankreider » Thu Mar 26, 2020 1:16 pm

Don’t bump threads, please. And you posted this 45 minutes ago.
Dan Kreider
hymnworks.com
Dorico 3, Windows 10

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 1:22 pm

dankreider wrote:
Thu Mar 26, 2020 1:16 pm
Don’t bump threads, please. And you posted this 45 minutes ago.
I have no idea what bump threads is?

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 1:22 pm

dankreider wrote:
Thu Mar 26, 2020 1:16 pm
Don’t bump threads, please. And you posted this 45 minutes ago.
I have no idea what bump threads is?

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 1:25 pm

ah, I know now, just looked it up, sorry bout that...

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 3:25 pm

Please can someone help me with this...

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 3:40 pm

Screenshot 2020-03-26 14.39.38.png
(84.54 KiB) Not downloaded yet

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 4:17 pm

So you can't get Dorico to start up anymore at all, right?
In that case please zip up the following two folders:
/Users/<yourname>/Library/Preferences/VSTAudioEngine3
/Users/<yourname>/Library/Library/Application\ Support/Steinberg/Dorico\ 3

and attach here. Furthermore, please have a look in
/Users/<yourname>/Library/Logs/DiagnosticReports
and see if you can find crash reports from either Dorico or, more importantly VSTAudioEngine3.
Please also zip those up and attach here. Thanks
Steinberg employee

User avatar
Daniel at Steinberg
Moderator
Posts: 16965
Joined: Mon Nov 12, 2012 10:35 am
Contact:

Re: Doeico 3 died

Post by Daniel at Steinberg » Thu Mar 26, 2020 4:22 pm

Have you tried restarting your computer?

Have you tried running Dorico before running any other applications, after restarting your computer?

After zipping up the VSTAudioEngine3 folder as Ulf suggests, try moving it out of /Users/your-username/Library/Preferences so that Dorico has to recreate it the next time it starts up.

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 5:33 pm

Daniel at Steinberg wrote:
Thu Mar 26, 2020 4:22 pm
Have you tried restarting your computer?

Have you tried running Dorico before running any other applications, after restarting your computer?

After zipping up the VSTAudioEngine3 folder as Ulf suggests, try moving it out of /Users/your-username/Library/Preferences so that Dorico has to recreate it the next time it starts up.
Tried restarting etc but still the same, I also downloaded dorico install and reinstalled but still the same - here are the two requested files.

Andy
Attachments
VSTAudioEngine3.zip
(312.88 KiB) Downloaded 6 times
Dorico 3.zip
(225.29 KiB) Downloaded 10 times

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 5:36 pm

also tries moving VSTAudioEngine3 folder out of preferences but no joy...

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 6:12 pm

And how about crash dumps from /Users/<yourname>/Library/Logs/DiagnosticReports ? Are there none?

Now I'm looking at the other zips...
Steinberg employee

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 6:32 pm

The log files don't give me any clue, I really need crashdumps.

There is only one thing at the moment that I could suggest and that is:
Try to move temporarily the file /Library/Audio/Plug-Ins/VST3/Steinberg/VST Connect PRO/VST Connect PRO.vst3
to another location and try to launch Dorico again. Does that make any difference?
Steinberg employee

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 7:00 pm

Ulf wrote:
Thu Mar 26, 2020 6:32 pm
The log files don't give me any clue, I really need crashdumps.

There is only one thing at the moment that I could suggest and that is:
Try to move temporarily the file /Library/Audio/Plug-Ins/VST3/Steinberg/VST Connect PRO/VST Connect PRO.vst3
to another location and try to launch Dorico again. Does that make any difference?
Hi, I dont have such a file?
I have Library/Audio/Plug-ins in this folder I have 3 folders Components, Digidesign, VST, All are empty.

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 7:03 pm

Here are the crash dumps from that folder.

Andy
Attachments
Archive.zip
(745.77 KiB) Downloaded 7 times

User avatar
PaulWalmsley
Steinberg Employee
Posts: 1935
Joined: Tue May 17, 2016 9:24 pm
Location: Steinberg, London
Contact:

Re: Doeico 3 died

Post by PaulWalmsley » Thu Mar 26, 2020 7:21 pm

At first glance, this looks to me like something else on your system that is causing problems. The vstaudioengine, vstscanner and Cubase are all crashing in the same code, eg for vstscanner:

Code: Select all

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x00007fff6f032e72 getMethodNoSuper_nolock(objc_class*, objc_selector*) + 124
1   libobjc.A.dylib               	0x00007fff6f034b99 _objc_msgSend_uncached + 73
2   com.apple.AppKit              	0x00007fff3605421c +[NSAppearance _performWithCurrentAppearance:usingBlock:] + 33
3   com.apple.AppKit              	0x00007fff36053da6 -[NSDynamicSystemColor recacheColor] + 305
4   com.apple.AppKit              	0x00007fff36053b44 -[NSDynamicSystemColor initWithSelector:tintedWithColor:] + 120
5   com.apple.AppKit              	0x00007fff360e5e3c +[NSColor controlBackgroundColor] + 122
6   com.apple.AppKit              	0x00007fff360e5d13 -[NSClipView initWithFrame:] + 108
7   com.apple.AppKit              	0x00007fff36277eef -[NSScrollView initWithFrame:] + 398
8   com.apple.WebKitLegacy        	0x00007fff497b09dc -[WebDynamicScrollBarsView initWithFrame:] + 60
9   com.apple.WebKitLegacy        	0x00007fff497b07ff -[WebFrameView initWithFrame:] + 319
10  com.apple.WebKitLegacy        	0x00007fff497af13d -[WebView(WebPrivate) _commonInitializationWithFrameName:groupName:] + 365
11  com.apple.WebKitLegacy        	0x00007fff498fa6e2 -[WebView(WebPrivate) _initWithFrame:frameName:groupName:] + 146
12  com.apple.AppKit              	0x00007fff360ddf34 -[NSView init] + 44
This is all Apple code. So it suggests to me that either your OS installation may be corrupt somehow, or a driver on your system isn't behaving, or that there is some other application you have running that is causing problems. It appears to be related to showing windows, so do you have any software that does 'clever' things with other applications, such as changing the appearance of windows, adding menu items, allowing screen sharing, etc?
Architect & Developer - Steinberg London

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 8:36 pm

Yes, Paul is right. And why did you not mention that also Cubase is now crashing all the time? So it is not only a Dorico issue.

Have you also updated something else except Cubase?

I did a Google search on getMethodNoSuper_nolock, and I found in the Reaper forum a thread where Reaper would crash in the same function, and it turned out to be Rewire that caused this. It's not very likely to be the same issue with you, but nevertheless worth asking: Do you also use Rewire?
Steinberg employee

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 8:39 pm

PaulWalmsley wrote:
Thu Mar 26, 2020 7:21 pm
At first glance, this looks to me like something else on your system that is causing problems. The vstaudioengine, vstscanner and Cubase are all crashing in the same code, eg for vstscanner:

Code: Select all

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x00007fff6f032e72 getMethodNoSuper_nolock(objc_class*, objc_selector*) + 124
1   libobjc.A.dylib               	0x00007fff6f034b99 _objc_msgSend_uncached + 73
2   com.apple.AppKit              	0x00007fff3605421c +[NSAppearance _performWithCurrentAppearance:usingBlock:] + 33
3   com.apple.AppKit              	0x00007fff36053da6 -[NSDynamicSystemColor recacheColor] + 305
4   com.apple.AppKit              	0x00007fff36053b44 -[NSDynamicSystemColor initWithSelector:tintedWithColor:] + 120
5   com.apple.AppKit              	0x00007fff360e5e3c +[NSColor controlBackgroundColor] + 122
6   com.apple.AppKit              	0x00007fff360e5d13 -[NSClipView initWithFrame:] + 108
7   com.apple.AppKit              	0x00007fff36277eef -[NSScrollView initWithFrame:] + 398
8   com.apple.WebKitLegacy        	0x00007fff497b09dc -[WebDynamicScrollBarsView initWithFrame:] + 60
9   com.apple.WebKitLegacy        	0x00007fff497b07ff -[WebFrameView initWithFrame:] + 319
10  com.apple.WebKitLegacy        	0x00007fff497af13d -[WebView(WebPrivate) _commonInitializationWithFrameName:groupName:] + 365
11  com.apple.WebKitLegacy        	0x00007fff498fa6e2 -[WebView(WebPrivate) _initWithFrame:frameName:groupName:] + 146
12  com.apple.AppKit              	0x00007fff360ddf34 -[NSView init] + 44
This is all Apple code. So it suggests to me that either your OS installation may be corrupt somehow, or a driver on your system isn't behaving, or that there is some other application you have running that is causing problems. It appears to be related to showing windows, so do you have any software that does 'clever' things with other applications, such as changing the appearance of windows, adding menu items, allowing screen sharing, etc?
Hi
Everything has been running fine, the only thing i have downloaded was the Steinberg Cubase 10.5.12 update, after I installed that Cubase will not boot up and Dorico will not boot...I have completely uninstalled Cubase and reinstalled it but it still wont boot.. and Dorico is the same :-(

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 8:57 pm

andyp13 wrote:
Thu Mar 26, 2020 7:00 pm
Ulf wrote:
Thu Mar 26, 2020 6:32 pm
The log files don't give me any clue, I really need crashdumps.

There is only one thing at the moment that I could suggest and that is:
Try to move temporarily the file /Library/Audio/Plug-Ins/VST3/Steinberg/VST Connect PRO/VST Connect PRO.vst3
to another location and try to launch Dorico again. Does that make any difference?
Hi, I dont have such a file?
I have Library/Audio/Plug-ins in this folder I have 3 folders Components, Digidesign, VST, All are empty.
I did not mean Library/Audio/Plug-ins/VST3 but /Library/Audio/Plug-ins/VST3. You see the difference, the leading slash before Library?
That means that Library folder is in the root of your hard disk and not in the user's home directory.
Steinberg employee

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 9:30 pm

Ulf wrote:
Thu Mar 26, 2020 8:36 pm
I did a Google search on getMethodNoSuper_nolock, and I found in the Reaper forum a thread where Reaper would crash in the same function, and it turned out to be Rewire that caused this. It's not very likely to be the same issue with you, but nevertheless worth asking: Do you also use Rewire?
From the crash dumps I can see that there is a library from Propellerheads loaded, namely /Users/USER/Library/Application Support/Propellerhead Software/*/REX Shared Library.bundle

I don't know if that is Rewire or not, but could you try moving that temporarily out of the way and see if it makes a difference?
Steinberg employee

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 9:30 pm

Ulf wrote:
Thu Mar 26, 2020 8:57 pm
andyp13 wrote:
Thu Mar 26, 2020 7:00 pm
Ulf wrote:
Thu Mar 26, 2020 6:32 pm
The log files don't give me any clue, I really need crashdumps.

There is only one thing at the moment that I could suggest and that is:
Try to move temporarily the file /Library/Audio/Plug-Ins/VST3/Steinberg/VST Connect PRO/VST Connect PRO.vst3
to another location and try to launch Dorico again. Does that make any difference?
Hi, I dont have such a file?
I have Library/Audio/Plug-ins in this folder I have 3 folders Components, Digidesign, VST, All are empty.
I did not mean Library/Audio/Plug-ins/VST3 but /Library/Audio/Plug-ins/VST3. You see the difference, the leading slash before Library?
That means that Library folder is in the root of your hard disk and not in the user's home directory.
Hi, just tried that but its still the same...

User avatar
Ulf
Steinberg Employee
Posts: 2178
Joined: Wed Jul 31, 2013 9:44 am
Location: Steinberg Headquarters
Contact:

Re: Doeico 3 died

Post by Ulf » Thu Mar 26, 2020 9:54 pm

And how about temporarily moving /Users/USER/Library/Application Support/Propellerhead Software/*/REX Shared Library.bundle out of the way? You definitely have that because it appears in the crashdumps.
Steinberg employee

andyp13
Member
Posts: 356
Joined: Fri Jan 30, 2015 10:40 pm
Contact:

Re: Doeico 3 died

Post by andyp13 » Thu Mar 26, 2020 10:22 pm

Ulf wrote:
Thu Mar 26, 2020 9:54 pm
And how about temporarily moving /Users/USER/Library/Application Support/Propellerhead Software/*/REX Shared Library.bundle out of the way? You definitely have that because it appears in the crashdumps.
Tried it, still the same?

Everything was working fine? all I did was download and install the Cubase 10.5.12 update - now Iv lost everything.

Post Reply

Return to “Dorico”

Who is online

Users browsing this forum: Albione, benwiggy, pianoleo, StefanF at Steinberg, vanmeule and 10 guests