why does WL crash when i change the sample rate of my system?

Post questions and find answers on our latest WaveLab releases here.
Post Reply
taylor12k
Junior Member
Posts: 102
Joined: Tue Jul 19, 2016 4:55 pm
Contact:

why does WL crash when i change the sample rate of my system?

Post by taylor12k » Thu Jul 11, 2019 2:51 pm

subject says it all... this has happened, well, always, for me... and i figured i'd ask about it here. it probably has to do with my specific system.. but every time i change the sample rate of my interface, if WaveLab's current playback or recording sample rate (ie: last open or currently opened file) is different, it crashes.

my audio system consists of a UA Apollo 16 hooked up to the Mac which is clocking a crane song HEDD that does my conversion.

when i switch the sample rate on the Apollo it auto switches the HEDD for me, and WL crashes.

i'm posting here because no other audio app crashes when i do this.

any way around this? or is it just the way it has to be?

Rat
Member
Posts: 671
Joined: Thu Dec 16, 2010 6:33 am
Contact:

Re: why does WL crash when i change the sample rate of my system?

Post by Rat » Fri Jul 12, 2019 1:56 am

taylor12k wrote:
Thu Jul 11, 2019 2:51 pm


i'm posting here because no other audio app crashes when i do this.
The reason for this might be that a number of audio apps 're-sample on the fly' to whatever your preference playback rates are set to. So it would not necessarily 'matter' that the sample rate changes. WL on the other hand plays back at the actual sample rate of the file being played. I've not experienced your issue but I have a colleague who runs OSX and UA that I'll ask.
Regards

Paul

Paul Rat Blakey
12th & Vine Post

Windows 10 Professional (x64), Intel Core i7 7700 Quad Core LGA 1151 3.6 GHz CPU, 32 GB RAM, Gigabyte Z270M-D3H LGA 1151 mATX Motherboard, 2 x Intel Pro 5400S Series 256GB SSD (system and session drives), RME HDSPe AIO, Mytek converters

WaveLab 9.5 Pro current release, ProTools, iLok, DMG (Dave Gamble), Sony Oxford, Weiss, Class A Solid State and Custom Stuff

User avatar
Justin P
Senior Member
Posts: 2410
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: why does WL crash when i change the sample rate of my system?

Post by Justin P » Fri Jul 12, 2019 2:39 am

In my experience, WaveLab is good at forcing a sample rate change to the audio device if it's using the internal clock of the device.

I've had cases where the session doesn't match the external clock a device is using, or if another app is also open and using the audio device, or is accidentally open to a different sample rate that WaveLab is using...WaveLab doesn't seem to like that surprise :)

Does the crash open happen if you have say a 96k montage open, but then change the clock of your interface to another sample rate?
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

Rat
Member
Posts: 671
Joined: Thu Dec 16, 2010 6:33 am
Contact:

Re: why does WL crash when i change the sample rate of my system?

Post by Rat » Fri Jul 12, 2019 3:59 am

I personally don't run a HEDD but a colleague that sometimes works out of my room does. He reminded me that the HEDD allows its DA and AD to operate at the same time at different sample rates. If the mac is clocking the HEDD (as per your post) this feature has the potential for unhappiness? The unit isn't here at the moment so I can't try. As Justin has said, my experience has been that WL is great at forcing sample rate changes if it is using the internal clock of the device.
Regards

Paul

Paul Rat Blakey
12th & Vine Post

Windows 10 Professional (x64), Intel Core i7 7700 Quad Core LGA 1151 3.6 GHz CPU, 32 GB RAM, Gigabyte Z270M-D3H LGA 1151 mATX Motherboard, 2 x Intel Pro 5400S Series 256GB SSD (system and session drives), RME HDSPe AIO, Mytek converters

WaveLab 9.5 Pro current release, ProTools, iLok, DMG (Dave Gamble), Sony Oxford, Weiss, Class A Solid State and Custom Stuff

User avatar
Justin P
Senior Member
Posts: 2410
Joined: Fri Aug 12, 2011 12:49 pm
Location: Milwaukee, WI USA
Contact:

Re: why does WL crash when i change the sample rate of my system?

Post by Justin P » Fri Jul 12, 2019 4:20 am

Justin P wrote:
Fri Jul 12, 2019 2:39 am
In my experience, WaveLab is good at forcing a sample rate change to the audio device if it's using the internal clock of the device.

However, I have had cases where the session doesn't match the external clock a device is using, or if another app is also open and using the audio device, or is accidentally opened to a different sample rate that WaveLab was using...WaveLab doesn't seem to like that surprise :)

Does the crash only happen if you have say a 96k montage open, but then change the clock of your interface to another sample rate while the session is open still?
https://www.mysteryroommastering.com/https://www.justincarlperkins.com/
https://www.facebook.com/groups/WaveLab/

iMac Pro 3.0GHz 10-Core • 64GB RAM • SSD for OS and audio • MacOS 10.14.6
Mac Mini 3.2 GHz Intel Core i7 (6-Core) • 32GB RAM • SSD for OS and audio • MacOS 10.14.6

RME AES HDSPe, MUTEC MC-3+ Smart Clock USB, Grace m905, Grace m900

Post Reply

Return to “WaveLab Pro 9 | WaveLab Elements 9”

Who is online

Users browsing this forum: No registered users and 2 guests