Page 1 of 1

Weird Fade in when applying Pitch or Time Stretch

Posted: Sun Jun 02, 2019 11:15 am
by Arionas
Hello,
always when I apply a Pitch change or a Time stretch in a selected area on a waveform, I get a fade in at the very start of the selection.
This is something that makes these 2 processes completely unusable.
I am on Mac OS X and I'd like to know if anyone else can confirm it
Later when I'll go to the studio I will take 2 screenshots to post here.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Sun Jun 02, 2019 3:49 pm
by Arionas
Here are 2 screenshots before and after applying time stretch.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Sun Jun 02, 2019 3:50 pm
by Arionas
Here are 2 screenshots before and after applying time stretch with ZOOM IN

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Sun Jun 02, 2019 5:58 pm
by PG
How much stretch do you apply? At the start, the algorithm has to guess what the audio is before, and this can be a weakness.
If you have WaveLab Pro, you can try various stretch algorithms.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Sun Jun 02, 2019 7:02 pm
by Arionas
PG wrote:
Sun Jun 02, 2019 5:58 pm
How much stretch do you apply? At the start, the algorithm has to guess what the audio is before, and this can be a weakness.
If you have WaveLab Pro, you can try various stretch algorithms.
Hi PG,
I'm on Wavelab Pro but that wasn't an issue at previous versions (9, 8.5, 8 etc). I started to deal with this after upgrading to version 9.5 about a year or more ago.
It happens even for 1 bpm change e.g. from 120 to 119 on every "quality" setting and on any algorithm.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Mon Jun 03, 2019 8:35 am
by PG
Wavelab Pro but that wasn't an issue at previous versions (9, 8.5, 8 etc)
The time stretch algorithm has not changed since many years.
But the effect you describe is typically dependent on your audio material.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Mon Jun 03, 2019 11:00 am
by Arionas
PG wrote:
Mon Jun 03, 2019 8:35 am
Wavelab Pro but that wasn't an issue at previous versions (9, 8.5, 8 etc)
The time stretch algorithm has not changed since many years.
But the effect you describe is typically dependent on your audio material.
It seems that I cannot say anything more that will make you believe that this is a real big issue that has anything to do with my audio material.
Is there any way to open a support ticket somewhere in Steinberg?
thanks

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Mon Jun 03, 2019 10:02 pm
by PG
Try the same audio material with the same settings with WaveLab 9 and WaveLab 9.5...

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Tue Jun 04, 2019 10:16 am
by Arionas
PG wrote:
Mon Jun 03, 2019 10:02 pm
Try the same audio material with the same settings with WaveLab 9 and WaveLab 9.5...
Hmmm.. I have to reinstall one of the previous versions.
I surely believe you that the algorithms are the same - you are the designer and you know better.
But that don't change the fact that whenever I apply a time stretch on a wave selection(with any audio material, algorithm or and quality setting) I get a weird "fade in" as in the screenshots I posted before. And that was not happening before (I am a Wavelab Pro user more than 15 years).
Maybe is something at the preferences or I don't know what else could be...
Could you check it on a mac please? Just to be sure if is a software issue or not?
thanks

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Thu Jun 06, 2019 6:11 am
by bob99
Arionas wrote:
Tue Jun 04, 2019 10:16 am
Could you check it on a mac please? Just to be sure if is a software issue or not?
thanks
Arionas, I'd never tried applying a time stretch to a time selection before (i've only applied it to whole files), but trying a selection now, I get exactly the same thing you're seeing, and I'm on Windows. And it's the same all the way back through Wavelab 7. The only way I don't get an audible dip and weird looking fade at the start edge is if I select the Quick Process quality, and even that is sometimes audible and visible.

I have to go back to Wavelab 6 and deselect Dirac to get pretty seamless in and out transitions with a 130% change on a time selection like in your picture. But it doesn't sound good at that percentage without Dirac.
Dirac in Wavelab 6 seems somewhat better on the IN than Wavelab 7-9, but the out can be worse than any of them depending on the program material.

I tried a number of the settings and percent change for all of these trials.

And you're right it doesn't have to be a big change. I get the same thing with a 101% change.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Thu Jun 06, 2019 12:30 pm
by Arionas
bob99 wrote:
Thu Jun 06, 2019 6:11 am
Arionas wrote:
Tue Jun 04, 2019 10:16 am
Could you check it on a mac please? Just to be sure if is a software issue or not?
thanks
Arionas, I'd never tried applying a time stretch to a time selection before (i've only applied it to whole files), but trying a selection now, I get exactly the same thing you're seeing, and I'm on Windows. And it's the same all the way back through Wavelab 7. The only way I don't get an audible dip and weird looking fade at the start edge is if I select the Quick Process quality, and even that is sometimes audible and visible.

I have to go back to Wavelab 6 and deselect Dirac to get pretty seamless in and out transitions with a 130% change on a time selection like in your picture. But it doesn't sound good at that percentage without Dirac.
Dirac in Wavelab 6 seems somewhat better on the IN than Wavelab 7-9, but the out can be worse than any of them depending on the program material.

I tried a number of the settings and percent change for all of these trials.

And you're right it doesn't have to be a big change. I get the same thing with a 101% change.
Hey bob99, thank you so much for taking the time to test that!
It's true that I don't remember which versions of Wavelab didn't have that issue - you are right, probably it was older versions than the ones I thought. But I'm very sure, as you, in the past I could time stretch a piece of audio inside the whole audio file without the weird fade in.
I totally agree that the new algorithms are much better that the older, but in my opinion in a such delicate and amazing wave editor as Wavelab is, that shouldn't be an issue. Lets suppose we need to do a serious mastering work on a final piece of music and the client, for some reason is asking to time-stretch the "refrain" few bpms up or down. What we will tell? Sorry but my Mastering software cannot do this? Or to quit Wavelab and do this job in iZotope RX or Pro Tools or whatever else software where there is NO ISSUE like the one we described?
I think PG has to take a deeper look and find a solution.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Fri Jun 07, 2019 6:58 am
by PG
When you meet such an issue (and it depends on the audio + chose algorithm),
what you can do is a stretch fade-in/out. But for time stretch, you need to do this manually with the envelope.
Like in the following picture. This way you have a control on the transition, and the algorithm is more "aware" of the audio before and after the region you want to stretch.
2019-06-07_07-54-40.png
(53.69 KiB) Not downloaded yet

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Fri Jun 07, 2019 8:02 am
by Arionas
PG wrote:
Fri Jun 07, 2019 6:58 am
When you meet such an issue (and it depends on the audio + chose algorithm),
what you can do is a stretch fade-in/out. But for time stretch, you need to do this manually with the envelope.
Like in the following picture. This way you have a control on the transition, and the algorithm is more "aware" of the audio before and after the region you want to stretch.
2019-06-07_07-54-40.png
Thanks, I'll try this to see how it goes.

Re: Weird Fade in when applying Pitch or Time Stretch

Posted: Fri Jun 07, 2019 1:11 pm
by Arionas
PG wrote:
Fri Jun 07, 2019 6:58 am
When you meet such an issue (and it depends on the audio + chose algorithm),
what you can do is a stretch fade-in/out. But for time stretch, you need to do this manually with the envelope.
Like in the following picture. This way you have a control on the transition, and the algorithm is more "aware" of the audio before and after the region you want to stretch.
2019-06-07_07-54-40.png
Well, it worked that way, thank you!