N7 & X-Keys problem

Post general topics related to Nuendo 7 here.
Post Reply
User avatar
Keyplayer
Senior Member
Posts: 1341
Joined: Mon Jan 17, 2011 3:09 pm
Contact:

N7 & X-Keys problem

Post by Keyplayer »

I have programmed an OPEN and CLOSE shortcut on my X-Keys unit to launch Nuendo. Every iteration since N4 has only required that I copy the shortcut address from the desktop icon to the address window in the associated key of the X-keys unit to get the new version to launch.

This time when I tested the launch button, N7 opened but it said there was no Eucon device! :shock: I quickly checked to see if I had accidentally written in the 32bit version address. But it was the correct address for the 64bit version. So, I don't know why it excluded the Eucon link. When I opened it directly from the desktop icon, N7 opened correctly WITH the Eucon link. Anybody have any idea why the launch address from the X-keys is causing this discrepancy? :?: :?: :?:
Nuendo 1.0 - 10 |VST Studio Connect Pro | Windows 10 Pro | Intel i9 - 9900K CPU @ 3.60 | 64-bit OS | 32GB of RAM |RME HDSPe RayDAT | NVIDIA GeForce GTX 750 Ti Video Card | Euphonix MC Control, 2 Mix & Transport | Xkeys | iConnectivity mi10 MIDI Interface | UAD-2 Octo Core with UAD-1 Legacy Ultra Pak | Isotope RX4 | Melodyne 3.2 | Voxengo Plugins | Real Guitar | B4 II | EZ Drummer | Drumagog 4 | Virtual Guitarist 2 | Korg, Roland, Kurzweil Synths | Apogee Big Ben | 32 Channel Panasonic DA-7 desk | Equator D5 (5.1) & Mackie 824 (St.) monitors | VS-1680 & 880 HDR's |

User avatar
Keyplayer
Senior Member
Posts: 1341
Joined: Mon Jan 17, 2011 3:09 pm
Contact:

Re: N7 & X-Keys problem

Post by Keyplayer »

This doesn't make ANY sense. I click on the "ON button," from my X-keys which carries this address:
Nuendo 7 Properties.jpg
(74.34 KiB) Not downloaded yet
and I get this.
Nuendo 7 Eucon Error Message On Launch.jpg
(44.01 KiB) Not downloaded yet
I turn it off and re-launch from the desktop icon and I get this.
Nuendo 7 Eucon Working.jpg
(703.39 KiB) Not downloaded yet
IT'S THE SAME ADDRESS, why is the X-keys: 1) not launching WITH the MC control and 2) not activating the key commands that were written on/in it on N6.5?!!?

Worse, I'm losing ground on this "one way street." For every advance I take to get up and running on N7, a door closes behind me that will not allow me to return to my old way of doing things. I launched N7 and lost the controller altogether in the 32bit version. I migrate to 64bit and program X-keys to launch N7. Again, I lose the controller, but now I can't got back to the 64bit version of N6.5! Since I CAN launch N7 WITH the controller from the icon, I'm scared to death to uninstall and re-install Eucon 3.2 as instructed by the X-keys Launch of the app. I'm afraid I'll lose the use of the controller altogether.

What is causing this??
Nuendo 1.0 - 10 |VST Studio Connect Pro | Windows 10 Pro | Intel i9 - 9900K CPU @ 3.60 | 64-bit OS | 32GB of RAM |RME HDSPe RayDAT | NVIDIA GeForce GTX 750 Ti Video Card | Euphonix MC Control, 2 Mix & Transport | Xkeys | iConnectivity mi10 MIDI Interface | UAD-2 Octo Core with UAD-1 Legacy Ultra Pak | Isotope RX4 | Melodyne 3.2 | Voxengo Plugins | Real Guitar | B4 II | EZ Drummer | Drumagog 4 | Virtual Guitarist 2 | Korg, Roland, Kurzweil Synths | Apogee Big Ben | 32 Channel Panasonic DA-7 desk | Equator D5 (5.1) & Mackie 824 (St.) monitors | VS-1680 & 880 HDR's |

User avatar
MattiasNYC
Grand Senior Member
Posts: 4252
Joined: Thu Dec 16, 2010 9:27 am
Contact:

Re: N7 & X-Keys problem

Post by MattiasNYC »

The X-Keys is a "regular" programmable keyboard using USB, right? So basically to the computer it's just looking like a keyboard sending key commands....

Would it make sense to try attaching the two devices - the X-Keys and the dongle - to two separate USB controllers/ports? I don't see what mobo you're using, but I know several have different controllers on it. Some run the internal headers on the mobo which typically go to the front or top of the case, and others may go to different rear ports.....

Just a thought.... Not that any of what you're experiencing makes any sense to me either...
Nuendo 10.2.2 build 396 / Lynx TWO-B / Windows 10 Pro 64-bit / Ryzen 1700 3.6GHz (oc) / 16GB Corsair Vengeance DDR4@3200MHz / Radeon VII / ASUS x370-A mobo ::::: RX Post Production Suite 4 / DaVinci Resolve

User avatar
Keyplayer
Senior Member
Posts: 1341
Joined: Mon Jan 17, 2011 3:09 pm
Contact:

Re: N7 & X-Keys problem

Post by Keyplayer »

Lydiot wrote:The X-Keys is a "regular" programmable keyboard using USB, right? So basically to the computer it's just looking like a keyboard sending key commands....

Would it make sense to try attaching the two devices - the X-Keys and the dongle - to two separate USB controllers/ports? I don't see what mobo you're using, but I know several have different controllers on it. Some run the internal headers on the mobo which typically go to the front or top of the case, and others may go to different rear ports.....

Just a thought.... Not that any of what you're experiencing makes any sense to me either...
They are attached to 2 separate USB ports. I really don't want to un-install and re-install Eucon again if I don't have to. I had JUST gotten it to where it appeared stable (no crashes or freezing for weeks!). On the other hand, the controller is almost useless to me WITHOUT the support the X-keys provides. So, it's a dilema either way. If the X-keys worked with using the icon, I could "take that hit." But since it doesn't, I might as well try to figure out how to get it ALL up and running again. I just don't know what that next move would be.
Nuendo 1.0 - 10 |VST Studio Connect Pro | Windows 10 Pro | Intel i9 - 9900K CPU @ 3.60 | 64-bit OS | 32GB of RAM |RME HDSPe RayDAT | NVIDIA GeForce GTX 750 Ti Video Card | Euphonix MC Control, 2 Mix & Transport | Xkeys | iConnectivity mi10 MIDI Interface | UAD-2 Octo Core with UAD-1 Legacy Ultra Pak | Isotope RX4 | Melodyne 3.2 | Voxengo Plugins | Real Guitar | B4 II | EZ Drummer | Drumagog 4 | Virtual Guitarist 2 | Korg, Roland, Kurzweil Synths | Apogee Big Ben | 32 Channel Panasonic DA-7 desk | Equator D5 (5.1) & Mackie 824 (St.) monitors | VS-1680 & 880 HDR's |

User avatar
Keyplayer
Senior Member
Posts: 1341
Joined: Mon Jan 17, 2011 3:09 pm
Contact:

Re: N7 & X-Keys problem

Post by Keyplayer »

I finally figured it out. The Eucon Workstation was missing. I re-loaded that and was finally able to launch from the X-keys device. Now I just have to figure out how to get the device to run all the other KCs without having to re-write the entire library again.
Nuendo 1.0 - 10 |VST Studio Connect Pro | Windows 10 Pro | Intel i9 - 9900K CPU @ 3.60 | 64-bit OS | 32GB of RAM |RME HDSPe RayDAT | NVIDIA GeForce GTX 750 Ti Video Card | Euphonix MC Control, 2 Mix & Transport | Xkeys | iConnectivity mi10 MIDI Interface | UAD-2 Octo Core with UAD-1 Legacy Ultra Pak | Isotope RX4 | Melodyne 3.2 | Voxengo Plugins | Real Guitar | B4 II | EZ Drummer | Drumagog 4 | Virtual Guitarist 2 | Korg, Roland, Kurzweil Synths | Apogee Big Ben | 32 Channel Panasonic DA-7 desk | Equator D5 (5.1) & Mackie 824 (St.) monitors | VS-1680 & 880 HDR's |

Post Reply

Return to “General”

Who is online

Users browsing this forum: No registered users and 4 guests