Page 1 of 6

[SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jun 09, 2015 5:29 am
by ggc
Greets n love@all:)

Re: proQ cubase crash

Posted: Wed Jun 10, 2015 9:08 am
by ggc
ok, here is the solution that helped me...

maaaaaybe, this method can be applied to ANY AND ALL misbehaving vsts crashing etc..-
(havent tested with other crashy vsts-... yet;))

Windows:
GOTO: Registry Editor.
Navigate to HKEY_CURRENT_USER\Software\FabFilter. *****<<<<--- or other vst name of choice*****
Right-click and select New > DWORD (32-bit) Value.
Name it GraphicsAcceleration and ensure its value is set to 0.

Mac OS X: Open Terminal and type: defaults write com.fabfilter.Common GraphicsAcceleration 0 ****<same deal****

Whoop whoop! ;)

p.s. my system: window 7 x64
p.p.s. please report any success using the above method here so others can benefit:) (system, plugin name)

Re: [SOLVED]proQ crash cubase 8.0.2 - read if u have crashy

Posted: Wed Jun 10, 2015 10:42 am
by ggc
Omg!

I applied this fix to my cubase folder in registry... ( the actual cubase8 folder, not a vst)

NO MORE CRASH ON EXIT!!!:):):)!!!

Edit: also no realtime peaky business nymore;)!

Whaaaaaa? Njoy;)

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Wed Jun 10, 2015 12:21 pm
by the_rpg_moogle
My dear god man! This actually works!

And the program seems faster to boot... :)

This should be a sticky, thanks a lot, a whole lot for this!

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 12:33 pm
by Guillermo
Hello,

Alright... this is very interesting, can anyone else confirm this?

Best regards,
GN

Re: proQ cubase crash

Posted: Thu Jun 11, 2015 3:56 pm
by Seraglio
ggc wrote:Right-click and select New > DWORD (32-bit) Value.
32-bit DWORD for 32-bit plug/apps and 64-bit QWORD for 64-bit plugs/apps?
Or 32 for everything?

Interesting... testing now

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 4:48 pm
by ggc
Just 32bit dword ...

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 4:52 pm
by richlum
So, 32 bit word even for 64 bit cubase pro if we add this to the cubase folder?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 4:53 pm
by ggc
Yup..

Exactly as stated above.. (Im also on 64bit windows btw)

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 8:32 pm
by Seraglio
Cewl!

So far my Cubase kindof feels a hair more sturdy and less flimsy now. But it might be imagination too. Haven't noticed anything bad, besides one thing with NI FM8. If I open its GUI and click the "Open sound.." and the dialog comes up, the dialog usually comes up in front of the FM8 GUI but now it came up behind FM8 GUI - like if FM8 was set to some 'keep on top always' setting. I got that setting set in Cubase, but FM8 is the only one who acted like this so far. It didn't before.
I closed the GUI without utilizing the Dialog at all, meaning the dialog kindof got stuck in some twilight dimension, Cubase went a bit unresponsive, then crashed. Not too strange though, especially with Cubases oversensitivity to graphic anomalies and strains.

In the coming 36 hours I'm about to do a full mix of a song including instruments and audio tracks. 100+ tracks. I'll keep you posted how this goes in relation to this hack.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 9:03 pm
by silhouette
I am getting the stopped working window.

The faulty module is: d2d1.dll

The same thing?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Thu Jun 11, 2015 9:58 pm
by estrica2000
i 've done: defaults write com.cubase.common GraphicsAcceleration 0
seems surprinsigly good.. could any one on OSX try this on terminal:

defaults read com.cubase.common GraphicsAcceleration


what value is outputed? it will just read and so no change will happen

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Jun 12, 2015 1:37 am
by JACKnight
Brilliant!

While I experience few to no problems with Cubase I often find it disturbing that the Little Red Light
is virtually always On on my VST meter....

I applied this fix to the Cubase 8 redistry entry (as mentioned above) and now no more VST clip light!

Also, loads a noticably faster.

Effin Cheers Bro! :D

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Jun 12, 2015 11:38 am
by ckon
estrica2000 wrote:i 've done: defaults write com.cubase.common GraphicsAcceleration 0
seems surprinsigly good.. could any one on OSX try this on terminal:

defaults read com.cubase.common GraphicsAcceleration
JACKnight wrote:Brilliant!

While I experience few to no problems with Cubase I often find it disturbing that the Little Red Light
is virtually always On on my VST meter....

I applied this fix to the Cubase 8 redistry entry (as mentioned above) and now no more VST clip light!

Also, loads a noticably faster.

Effin Cheers Bro! :D
So you're putting a new (32bit) D word 'GraphicsAcceleration' in:

[HKEY_CURRENT_USER\Software\Steinberg Media Technologies GmbH\Steinberg Cubase 8 64bit]
"GraphicsAcceleration"=dword:00000000

yes/no?

Interesting, so it's basically a targeted form of the very old DAW optimisation (not for win7/8 etc):

Reducing Graphics Hardware Acceleration

On your start menu click on SETTINGS and then on CONTROL PANEL.
Double click the SYSTEM icon.
Click the PERFORMANCE tab.
Click the GRAPHICS button.
Move the HARDWARE ACCELERATION slider to the left one notch.
Click OK.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Fri Jun 12, 2015 2:03 pm
by estrica2000
yes, i've done that in the OSX way. I doubt it's correct tho(would be a bit ridiculous ), but strangely it seems faster quitting and no problems for some quits i did. Can anyone on osx print what i asked previously?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Jun 14, 2015 6:26 pm
by registered
Back in those Win XP days the culprit in that workaround was the motherboard, BIOS, or the graphics hardware/driver.
Are all of those who are having this problem possibly using similar hardware?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Sun Jun 14, 2015 9:12 pm
by xenteq
Completely removed the peak overloads for me and so far I haven't had a crash on exit. I just added the DWORD to the Cubase line (rather than a specific VST) as per ggc and ckon's posts above.

Great work and thanks for sharing :)

(I'm still running 8.0.10 btw)

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Jun 15, 2015 7:42 am
by Patepro
Not working for me. When opening a few instances of musiclab relastrat then Crash when leaving the realstrat window. Set the dword value - not better. Any tips ?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Jun 15, 2015 8:37 am
by the_rpg_moogle
Okay, so I wanted to chime in on this again. I might have reacted a bit prematurely, but there certainly is a difference.

I still get VST peaks when loading instruments into Eastwest Play. I unfortunately don't seem to be able to completely get rid of this problem, no matter what I do. It's livable, but irritating non the less.

When it's working, it works really well. And since applying this fix, at least the constant crashing is gone. Loading a project does not feel like playing Russian roulette anymore. Everything works, everything is snappy. That permanent red peak (cpu overload) indicator is here to stay, at least for me.

But Cubase does feel snappier. Less sluggish. My system is totally up to par, and works flawlessly. I think Play just isn't optimized completely, and Cubase is what it is; great, legendary even, but still sometimes drawn back by years of legacy code, making it not completely optimal.

I'm not faulting Cubase; apart from the younglings like Studio One and Reaper, it seems all DAWs I've tried (all of the big ones, Digital Performer, Pro Tools, etc) seem to be like this.

I'm just glad it works. It's stable. It doesn't crash on exit. It's just that still, it seems a bit sluggish when saving, loading, or exiting. I've got 32GB of DDR4 ram, fast as heck, but I'm pushing it's boundaries. It seems that Cubase feels the need to flush this memory everytime I save, or exit. That's why I can't just press exit when I want to quit. Close the project. Wait for the rainbow wheel, then exit. It works. Aggrevating, I know, but it works.

I hope a permanent fix will come someday. But for me, I think, this is not Cubase's fault anymore. Play is still not there. It's coming, but not yet.

The fix has helped me a lot, making me feel safe and secure instead of trying to win the lottery every single time I start a project.

Now, if only the issue with the midi connections and expression maps could be solved (when disabling tracks)...

Anyway, thanks guys, happy music making!

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Jun 15, 2015 6:05 pm
by cmaffia
Could someone explain what this registry change is doing and what are the drawbacks (if any) in doing this change?

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Mon Jun 15, 2015 9:32 pm
by h3kt0
the_rpg_moogle wrote: I think Play just isn't optimized completely, and Cubase is what it is; great, legendary even, but still sometimes drawn back by years of legacy code, making it not completely optimal.
This.

I was so happy when I received my Hollywood Strings box. And so disappointed when I first loaded a patch in Cubase due to these peaking problems.

[SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jun 16, 2015 5:35 am
by peakae
So you simply are transferring the graphics calculations from GPU to CPU.
http://www.fabfilter.com/support/faq/18 ... y-computer
After a little more googleling, yes it forces the program/plugin to use software rendering instead of the driver/GPU.
That leads me to think, that either users that experience problems are using faulty drivers or GPU's. Or that there is a bug somewhere in Cubase that only triggers some combinations of software, drivers and GPU. Anyway it makes sense to update graphics drivers and disable any sort of virtual desktop or otherwise possible disruptive visual tools.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jun 16, 2015 8:41 am
by ggc
cmaffia wrote: the drawbacks (if any) in doing this change?
Smooth sailing in cubase:p

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jun 16, 2015 9:31 am
by Patepro
I checked that out with realstrat and reallpc from musiclab - not working. After checking some possibilities it seems that the problem is the realviewer from musiclab which behaves strange with cubase 8. It concerns the vst2 and vst3 version. So i bridged the vst2 64bit dll with jbridger into a 64bit version and - success. No crashes anymore.

Re: [SOLVED]crash on exit-Peaks-crashy vsts? Read this!)

Posted: Tue Jun 16, 2015 11:31 am
by cmaffia
ggc wrote:
cmaffia wrote: the drawbacks (if any) in doing this change?
Smooth sailing in cubase:p
I get your response but it doesn't answer the question. Others already have "smooth sailing" without this suggested registry change. Could someone from Steinberg please comment? If your offloading graphic processing from GPU to CPU, something's obviously impacted..