USB disconnect problem

Find topics on computers, studios and music-related hardware.
Post Reply
Maas
Junior Member
Posts: 172
Joined: Thu Jun 16, 2011 7:29 pm
Contact:

USB disconnect problem

Post by Maas » Mon Nov 10, 2014 2:08 pm

Hi Does anyone have an issue whereby they leave cubase open (PC) and after an hour or so of non use the USB components loose connection? On the odd occasion the same can happen within minutes.
I tried moving all the USB cables to see if any intermittent issue but none.

For example my CC121 always looses connection and the blue light flashes to show no connection.

I can sometimes just sit back and leave the pc alone with Cubase open and after an hour or so I can hear USB connections disconnect and try to reconnect.

I am wondering if I my 10 way USB interface is a bit dodgy as this has the CC121 and CMC controller attached.
I dont think this is the issue because I am pretty sure the CC121 did this before I have the CMC controllers and the 10 way interface.

Anyone with similar issues.
3770K, Asus P8Z77-V, 32GB, 120Gb SSD, 500GB SSD, 1TB HDD (7200)
Cubase 9.5 Pro Halion 6,Halion Sonic, Groove Agent 4, Omnisphere2.5, Neo Keys, Triebwerk, Hypnotic Dance,PadShop Pro,Korg VST Instruments, UR44, CMC 6 Pack,Ipad Air/Cubase iC Pro, Ultimate 10, S61mk2 Komplete Keyboard, S-EX1 Mic, TC Helicon Voiceworks Plus.

User avatar
Makumbaria
Member
Posts: 729
Joined: Fri Mar 09, 2012 6:41 am
Location: Brazil
Contact:

Re: USB disconnect problem

Post by Makumbaria » Mon Nov 10, 2014 4:58 pm

Are you using windows, right?

You can try to turn off USB power management:

https://www.youtube.com/watch?v=3IaQb0OAfbQ
Cubase Pro 10.0.30 / 6.5.5 / Cubasis 2.8 / CMC-TP/CH/AI/QC/PD / Cubase IC Pro 1.2.2
Windows 10 Pro 64 bits/ i7 3630QM / 2.4Ghz / 16 GB & i7 950 / 3.06Ghz / 8GB RAM / Focusrite Scarlett 18i8
Dorico 2.2.10 / Halion 6.2.10 / Halion Sonic 3.2.10 / Padshop Pro 1.2.10 / HSO 1.0 / The Grand 3.2.0/

Ivory II Italian Grand / Ravenscroft 275 / Vienna imperial piano / Alicia Keys Piano / Addictive drums 2 & Keys / Ezdrummer 2 / Abbey Road Modern Drums / GPO 5 / VSL / Vienna Mir pro 24 /Bias amp & FX 1 & 2/ Amplitube 3 & 4 / Kuassa Creme & One / TH2 & 3 / Mercuriall Spark & Reaxis / Nugen Audio / Slate Digital / Wave Arts / Waves V9 & V10 / Softube / Toneboosters / NI / Neural DSP Darkglass ultra / PSP audioware / Markstudio 2 /

Maas
Junior Member
Posts: 172
Joined: Thu Jun 16, 2011 7:29 pm
Contact:

Re: USB disconnect problem

Post by Maas » Mon Nov 10, 2014 6:38 pm

Yeah windows 7' thanks will have a look.
3770K, Asus P8Z77-V, 32GB, 120Gb SSD, 500GB SSD, 1TB HDD (7200)
Cubase 9.5 Pro Halion 6,Halion Sonic, Groove Agent 4, Omnisphere2.5, Neo Keys, Triebwerk, Hypnotic Dance,PadShop Pro,Korg VST Instruments, UR44, CMC 6 Pack,Ipad Air/Cubase iC Pro, Ultimate 10, S61mk2 Komplete Keyboard, S-EX1 Mic, TC Helicon Voiceworks Plus.

User avatar
Patanjali
Senior Member
Posts: 1328
Joined: Mon Dec 20, 2010 10:37 am
Location: Canberra, Australia
Contact:

Re: USB disconnect problem

Post by Patanjali » Tue Nov 11, 2014 3:30 am

Two areas to prevent the system from shutting down USB ports to save power. It is basically the same for XP up to 8.1.

Power Options
1) Control Panel --> Power Options --> Change plan settings link --> Change advanced power settings link.
2) For each power plan, change USB settings/USB selective suspend setting to Disabled.

Device Manager
If the above doesn't fix your issue, you may need to explicitly disable power down on each port. I do it anyway!
This is the steps that the video above covers.

1) Control Panel --> Device Manager.
2) For each item under the Human Interface Devices and Universal Serial Bus controllers sections:
__ 2.1) Double-click to open its Properties dialog.
__ 2.2) If it has a Power Management tab, click on it, else skip to next item.
__ 2.3) Uncheck the Allow the computer to turn off this device to save power box. Ignore if greyed out.

There can be a few, so a quick key sequence for each item is:
1) Down arrow --> select next item.
2) Enter --> open its dialog.
3) If Power Management tab, Crtl+Shift+Tab --> open panel.
4) If box checked, Space --> uncheck.
5) Enter --> close dialog.
6) Repeat for each.

Note that if you plug a device into another port, the setting may be reset to the default for the port, so just double-check each time you finish rearranging USB connections.
Patanjali
Comp: i7-4930K : Asus P9X79-E WS : 32GB : GTX 1050 : SSDx7 : UAD2Q : TCL 49C2US x2.
HW: YRG : uKEY2 : UR44.
SW: Dual boot Win10P : Cubase 8.0.30 Pro 64 : RX4Adv : Ozone6Adv : Goliath/SO/Pianos/Gypsy/SV : Sup.Drum 2

Maas
Junior Member
Posts: 172
Joined: Thu Jun 16, 2011 7:29 pm
Contact:

Re: USB disconnect problem

Post by Maas » Tue Nov 11, 2014 9:16 am

Thanks guys, I unchecked the power management for each of the USB connections. Cubase has been running for around 14 hours now (without use) and all connections still good. Pretty sure this has fixed my problem as it never goes more than an hour or two without disconnecting. Thanks again.
3770K, Asus P8Z77-V, 32GB, 120Gb SSD, 500GB SSD, 1TB HDD (7200)
Cubase 9.5 Pro Halion 6,Halion Sonic, Groove Agent 4, Omnisphere2.5, Neo Keys, Triebwerk, Hypnotic Dance,PadShop Pro,Korg VST Instruments, UR44, CMC 6 Pack,Ipad Air/Cubase iC Pro, Ultimate 10, S61mk2 Komplete Keyboard, S-EX1 Mic, TC Helicon Voiceworks Plus.

User avatar
meta-redundant
Junior Member
Posts: 182
Joined: Wed Jun 29, 2011 9:20 pm
Location: Los Angeles, CA

Re: USB disconnect problem

Post by meta-redundant » Mon Aug 14, 2017 9:24 pm

Patanjali wrote:
Tue Nov 11, 2014 3:30 am
Two areas to prevent the system from shutting down USB ports to save power. It is basically the same for XP up to 8.1.

Power Options
Device Manager
Sorry to necro an old thread - just wanted to say thanks Patanjali for this info. I was getting wacky behavior amongst my various USB peripherals, and realized that I had moved some cables around. I had forgotten you need to explicitly disable power management on a port by port basis, and had forgotten to do it after I moved things to new ports. Thanks for saving me a lot of headache!
Cubase Pro 10 | Wavelab 9.5 | Intel i9 7940x | Win10 | RME Fireface UCX (via USB) | 64Gb Memory | CC121 | UAD Quad | Intel RAID SSD array | Raven MTi2

User avatar
Patanjali
Senior Member
Posts: 1328
Joined: Mon Dec 20, 2010 10:37 am
Location: Canberra, Australia
Contact:

Re: USB disconnect problem

Post by Patanjali » Tue Aug 15, 2017 3:23 am

You're welcome. Glad it helped.
Patanjali
Comp: i7-4930K : Asus P9X79-E WS : 32GB : GTX 1050 : SSDx7 : UAD2Q : TCL 49C2US x2.
HW: YRG : uKEY2 : UR44.
SW: Dual boot Win10P : Cubase 8.0.30 Pro 64 : RX4Adv : Ozone6Adv : Goliath/SO/Pianos/Gypsy/SV : Sup.Drum 2

mmixer
New Member
Posts: 1
Joined: Tue Jul 03, 2018 8:26 pm
Contact:

Re: USB disconnect problem

Post by mmixer » Tue Jul 03, 2018 8:31 pm

Also many, many thanks from me ;)!! It helped me to fully install the Yamaha Asio driver again and stopped the awful sound quality and glitches after using an other usb port!!

(All I have to do now is cancel my USB hub, I ordered today, because I thought is was a power shortness :D )

Post Reply

Return to “Computer/Studio Hardware & Setup”

Who is online

Users browsing this forum: No registered users and 5 guests