Page 1 of 1

SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Fri Feb 16, 2018 1:19 pm
by CharlieDeltawhiskey
Hi Guys,

After a couple of years away from music making, I'm currently rebuilding my studio and experiencing a very painful problem with Avid Artist Mix, EUCon on Cubase.

This used to work fine a couple of years a go but now with updating the latest cubase 9.5 and the latest MAC OS I'm unable to actually use the artist mix and spent the last 3 days trawling the internet trying different things from forums for it not to work.

Can anyone please help me out? I would really appreciate it

Problem - in cubase the unit is unresponsive to all buttons expect "workstation application" and all the unit has got on the display of the channels are small yellow boxes. The unit does not respond to anything or light up in Cubase.

EU control connects to the unit and I can see that in the EU control settings.
Cubase seems to recognise EUcontrol and I can see it in studio settings.

I've tried with wifi on and off, firewall off, the latest EU conetrol software, I've rolled back to earlier EUcontrol versions and I've tried the artist mix on older versions of cubase but still get the same issue each time. I've tried adding a cubase9.xml file and still no joy.

Outside of cubase when running the test option the unit it works fine so the unit is fine and it must be a Cubase issue or user error.

I would really appreciate any of your wisdom.
Thank you
Cdw

Re: SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Sun Feb 18, 2018 12:21 pm
by CharlieDeltawhiskey
Hi Guys,

After a few more days of pain I suddenly recognised what the problem was. For anybody having similar issues with EUcon where it does not light up in cubase but is recognised in EUcontrol settings

You need to do a full uninstall of EUcontrol software instead of just updating. The problem must have been where I was installing the EUcon updates over the top of the last software, rather than uninstalling and doing a clean reinstall.

A learning point which could have saved me a lot of pain.
Thanks

Re: SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Thu Feb 22, 2018 9:04 am
by Dragon96
Same problem, thanks for sharing your information.

Re: SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Sat Feb 24, 2018 1:32 pm
by CharlieDeltawhiskey
You're most welcome Dragon96, I know how frustrating and painful things like this are! Glad I could be of help.

Re: SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Wed Feb 26, 2020 1:26 pm
by tomkiwi
Hello,

i installed, uninstalled, rebooted, installed, etc......but Cubase 10.5 Artist doesn't recognize my Avid Artist Mix. Whatever I do, nothing!
If I run Logic Pro X the Mixer is immediately ready and fully functional...very strange and frustrating at the same time.
Maybe I'm a bit harsh but neither Steinberg gives really support, nor Avid. Both are more or less outdated and not precise what to do.
Maybe some of you could help me to get this thing working :)
Many thanks in advance
best regards
Thomas

Re: SOLVED - Avid Artist Mix Problems - MAC Cubase 9.5

Posted: Thu Feb 27, 2020 1:09 pm
by tomkiwi
updated to PRO version and now it works fine.....artist 10.5 doesn‘t support EuCon
cheers
T.