ASIO Driver "Device Could not be Opened"

Find topics on computers, studios and music-related hardware.
Post Reply
mitchhill92
New Member
Posts: 10
Joined: Thu Dec 07, 2017 1:38 am
Contact:

ASIO Driver "Device Could not be Opened"

Post by mitchhill92 » Thu Dec 07, 2017 1:50 am

I've been using Cubase with no problems for a year and half. To my knowledge there have been no updates made to my computer, but now my driver has been switched to a generic low latency ASIO driver and when I try to switch back to the driver I've been using, Yamaha Steinberg USB ASIO, I get the error message "Device could not be opened". My driver shows up in the options in DEVICES>>DEVICE SETUP>>ASIO DRIVER dropdown, but can't connect. I've attached a screenshot. I know it is connected properly to the computer because when I play my guitar through it I hear it through the output.

What could be causing my issue? What do I need to do to switch to the Yamaha Steinberg USB ASIO Driver?
Attachments
Driver Issue.png
(111.78 KiB) Not downloaded yet

Kit Hugo
New Member
Posts: 1
Joined: Thu Dec 28, 2017 4:52 pm
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by Kit Hugo » Thu Dec 28, 2017 5:00 pm

Hi, got the same exact issue!

Had to get a new harddrive for my pc. Installed the most updated driver for my sound card, and installed Cubase without problems. But when I in Cubase had to choose a device and chose "steinberg" it started installing it, and got stuck in "preparing for installation" in Windows installer and couldn't be shut down unless I rebooted the computer.

So i uninstalled the driver for my sound card and installed the driver with the CD I got along the sound card, and now I'm in the same spot as you. "Device could not be opened."

Did you manage to resolve the issue?

User avatar
balinas
Junior Member
Posts: 147
Joined: Thu Nov 23, 2017 5:11 pm
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by balinas » Sat Jan 06, 2018 4:54 pm

perhaps try a different USB port and see what happens. reboot.

Open up device manager and make sure your device is there and working. Then start Cubase. Before opening a project, look at the audio devices and make your native ASIO driver the one that is selected.
Focusrite Scarlett 18i20, WIN 10 (1809), Intel i9 9900 5GHz, 32GB RAM, , MCU-PRO, Yamaha Classic Motif 6, Focusrite Asa ONE

unicoil
New Member
Posts: 6
Joined: Tue Apr 10, 2018 1:49 pm
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by unicoil » Tue Apr 10, 2018 7:29 pm

Was there a resolution to this problem? I am attempting to get a UR22mkII working with my HP Spectre 360 laptop, and I get the same result.

unicoil
New Member
Posts: 6
Joined: Tue Apr 10, 2018 1:49 pm
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by unicoil » Thu Apr 12, 2018 2:15 pm

FYI, my problem was SOLVED by using a different USB cable--I had to try three different cables. The one that worked was an extra-thick one that came with my old Line6 UX2. Better ground connection? Shielded? Not sure exactly why, but it works reliably, and I am up an running.

mitchhill92
New Member
Posts: 10
Joined: Thu Dec 07, 2017 1:38 am
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by mitchhill92 » Thu Jun 07, 2018 12:19 am

I've worked with customer service for a month or so and have not found a solution. To be clear, the cable connects power to the UR22mkII because I get a blinking USB indicator on the interface, indicating that the device is connected to the computer, but not recognized. The things customer service had me check for were:

- Downloading the latest version of Cubase
- Reinstalling the driver
- Checking that USB ports are 2.0 not 3.0
- Buying a new USB cable

None of these options worked. I was instructed to install everything on a different computer and see if that works, but I don't have a computer to try it on, so I've given up at this point and hope someone is able to figure out a solution.

mitchhill92
New Member
Posts: 10
Joined: Thu Dec 07, 2017 1:38 am
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by mitchhill92 » Thu Jun 07, 2018 12:25 am

unicoil wrote:
Thu Apr 12, 2018 2:15 pm
FYI, my problem was SOLVED by using a different USB cable--I had to try three different cables. The one that worked was an extra-thick one that came with my old Line6 UX2. Better ground connection? Shielded? Not sure exactly why, but it works reliably, and I am up an running.
I tried 2 different cabled and neither worked, but both produced a blinking USB indicator light on the interface. With the 2 cables that didn't work, did your USB indicator light on the UR22mkII blink, but the third one connected with a solid indicator? Wondering if I might need to try some more different cables.

unicoil
New Member
Posts: 6
Joined: Tue Apr 10, 2018 1:49 pm
Contact:

Re: ASIO Driver "Device Could not be Opened"

Post by unicoil » Sun Jun 24, 2018 6:52 pm

Sorry for the delay in replying. I wasn't getting ANY lights turning on. The third one just worked. I don't have any others to try it with, sorry.

Of course, I hadn't used the thing in a month, and today when i turn it on I get the eLicenser problem (apparently as a result of a Windows 10 update). I fixed that, but trying to install the NEW USB driver update fails, and now I'm back to a non-functional UR22mkII again, even WITH the "good" USB cable.

This shouldn't be that hard.

Post Reply

Return to “Computer/Studio Hardware & Setup”

Who is online

Users browsing this forum: No registered users and 4 guests