[3rd Party Issue] Freeze/unfreeze corrupts project

Post Reply
dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

[3rd Party Issue] Freeze/unfreeze corrupts project

Post by dancehallwraith » Wed May 15, 2019 9:51 pm

Pad Pro, iOS version 12.2

I’m having an issue with the play button failing. Sometimes when I freeze a track the audio doesn’t match the original track. I then unfreeze. This can cause the play button to stop working - I press it and the button goes green but play doesn’t start.

This then breaks the project permanently as I can’t play it. Restarting Cubasis or the iPad doesn’t restore it. It doesn’t affect other projects; if I switch to another it works fine, but when I switch back it stops working again.

If I create a snapshot of the project at this point, the snapshot is also broken in the same way.

I can’t use Cubasis until I have a fix, as I never know when all my work on a project will be lost.

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Thu May 16, 2019 8:43 am

Hi dancehallwraith,

Thank you for your message.

Please provide us with a step description, allowing us to reproduce the problem.
In this regard, please find our bug report form.

Thank you for your help!
Lars

Reporting Form

1. Summary/Title
(Provide a short but descriptive sentence that summaries the issue or feature request)

2. Description
(Provide a detailed description and list the step by step process to reproduce the issue to help the team to understand and reproduce the problem)

3. Expected Results
(Describe what you expected to see)

4. Actual Results
(Describe what you actually saw)

5. Environment
(Count the hardware and software including version numbers being used)
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: Freeze/unfreeze corrupts project

Post by Hiltmann » Thu May 16, 2019 9:16 am

Hi dancehallwraith,

to help you we need an detail step by step describtion as Lars wrote you above.

> Sometimes when I freeze a track the audio doesn’t match the original track.

- are you using an AU instrument/plugin?
- is your "Hardware Latency" setup set to "Medium"?
- is your "Real-time and Freeze" mode or "Audio Unit Mixdown Compatibilty Mode" active in Setup/Mixdown/Share?

If you use these 3 options together, please change your "Hardware Latency" in Setup from "Medium" to "Ultra low" and re-execute the freeze function.

best Jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

John1289
Junior Member
Posts: 107
Joined: Mon Oct 23, 2017 9:03 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by John1289 » Thu May 16, 2019 3:55 pm

I also reported a similar issue when freezing with Audiolayer on iPad Pro 11.
When I freeze with the mixdown options, the audio file is incorrect
When I freeze without the options, the file is correct but Cubasis freezes and can’t do anything till I restart the app.
This is more an issue with Audiolayer, because even when i try to delete an Audiolayer track, Cubasis would freeze for a while.

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Thu May 16, 2019 4:02 pm

John1289 wrote:
Thu May 16, 2019 3:55 pm
I also reported a similar issue when freezing with Audiolayer on iPad Pro 11.
When I freeze with the mixdown options, the audio file is incorrect
When I freeze without the options, the file is correct but Cubasis freezes and can’t do anything till I restart the app.
This is more an issue with Audiolayer, because even when i try to delete an Audiolayer track, Cubasis would freeze for a while.
Hi John1289,

Thanks for your message!
You might be correct, the "playback freezing" issue above sounds familiar to your case, previously reported.

As already mentioned, I've notified VirSyn about the freeze issue, who promised to look into it.
Will get back to you, once we hear back from them.

@dancehallwraith
Please let us know, if your project contains third party apps or effects plug-ins as well.
If so, please let us know which apps are involved!


Thanks,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Thu May 16, 2019 9:38 pm

Some more information: my iPad has frozen and crashed twice while I’ve been trying to submit my reply. I’ve had the corrupt Cubasis project open in the background so I can see the settings. The screen freezes except for the red mic symbol in the top rhs. Could this be a memory issue from Cubasis using more and more ram in this state?

This isn’t the same issue as John1289 describes, as restarting the app doesn’t reenable play; this project seems corrupt and unusable.

I think my original post covers all the questions in the bug report form, apart from a few:

Other vsts - yes: KB-1, iSymphonic, Patterning, Animoog, ToneStack, Waves Eos 2 and Dubstation. I can’t remember what the other corrupt projects had.

The steps I gave to reproduce the issue don’t work reliably, but this has happened to 3 projects in perhaps 10 hours of Cubasis use, and I think it’s always been related to unfreeze.

Hardware latency is ultra low. Neither real time... nor audio unit... modes are active. I’ll post my Cubasis version in a second; I don’t the corrupt project to cause me to lose this post.

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Thu May 16, 2019 9:40 pm

Cubasis version 2.7.

John1289
Junior Member
Posts: 107
Joined: Mon Oct 23, 2017 9:03 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by John1289 » Fri May 17, 2019 7:52 am

dancehallwraith wrote:
Thu May 16, 2019 9:38 pm
Some more information: my iPad has frozen and crashed twice while I’ve been trying to submit my reply. I’ve had the corrupt Cubasis project open in the background so I can see the settings. The screen freezes except for the red mic symbol in the top rhs. Could this be a memory issue from Cubasis using more and more ram in this state?

This isn’t the same issue as John1289 describes, as restarting the app doesn’t reenable play; this project seems corrupt and unusable.

I think my original post covers all the questions in the bug report form, apart from a few:

Other vsts - yes: KB-1, iSymphonic, Patterning, Animoog, ToneStack, Waves Eos 2 and Dubstation. I can’t remember what the other corrupt projects had.

The steps I gave to reproduce the issue don’t work reliably, but this has happened to 3 projects in perhaps 10 hours of Cubasis use, and I think it’s always been related to unfreeze.

Hardware latency is ultra low. Neither real time... nor audio unit... modes are active. I’ll post my Cubasis version in a second; I don’t the corrupt project to cause me to lose this post.
I think I’ve also had this issue this week.i would close Cubasis when done with a project, the next time I launch it, it say project corrupted or something like that and it opens a new project

John1289
Junior Member
Posts: 107
Joined: Mon Oct 23, 2017 9:03 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by John1289 » Fri May 17, 2019 8:25 am

I think the issue is not with Cubasis but with third party apps

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Fri May 17, 2019 8:46 am

dancehallwraith wrote:
Thu May 16, 2019 9:38 pm
Some more information: my iPad has frozen and crashed twice while I’ve been trying to submit my reply. I’ve had the corrupt Cubasis project open in the background so I can see the settings. The screen freezes except for the red mic symbol in the top rhs. Could this be a memory issue from Cubasis using more and more ram in this state?

This isn’t the same issue as John1289 describes, as restarting the app doesn’t reenable play; this project seems corrupt and unusable.

I think my original post covers all the questions in the bug report form, apart from a few:

Other vsts - yes: KB-1, iSymphonic, Patterning, Animoog, ToneStack, Waves Eos 2 and Dubstation. I can’t remember what the other corrupt projects had.

The steps I gave to reproduce the issue don’t work reliably, but this has happened to 3 projects in perhaps 10 hours of Cubasis use, and I think it’s always been related to unfreeze.

Hardware latency is ultra low. Neither real time... nor audio unit... modes are active. I’ll post my Cubasis version in a second; I don’t the corrupt project to cause me to lose this post.
Hi dancehallwraith,

Thanks for the additional information.

I have seen similar cases with AudioDamage plug-ins in the past.

Please provide me with the project via WeTransfer (please upload to WeTransfer, addressing it to yourself, let me know the download link via private message). We will check to provide you with a project version leaving out these plug-ins, to evaluate and check if this solves the problem.

Best,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Fri May 17, 2019 4:17 pm

Thanks for that. You should have just received a pm.

dw

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Wed May 22, 2019 6:32 am

Hi Lars,

I’ve just noticed that my pm is in my outbox not sent items. I can’t see a send button. I tried again with the same result.

Have you received a pm from me?

Thanks,
dw

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Wed May 22, 2019 6:34 am

To try to shortcut the process, here's the corrupt project:

https://wetransfer.com/downloads/c64c2d ... 411/0e0725

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Wed May 22, 2019 6:34 am

Well, that failed too. Try this:
https://we.tl/t-FSO6WdEDnA

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: Freeze/unfreeze corrupts project

Post by Hiltmann » Wed May 22, 2019 7:31 am

Hi dancehallwraith,

Thank you for the Project !

I can confirm "Crash after launch Dub Gold.zip", crashlog is generated.

Your issue is listed as CB-4650 in our Bugbase.

We will inform you as soon as we know more details or when we have a fix.

best
Jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: Freeze/unfreeze corrupts project

Post by Hiltmann » Thu May 23, 2019 4:10 pm

Hi dancehallwraith,

I send you an private message include download link, where you can download the fixed project.

On tracks 5 and 6 there is an AU MIDI effect that is not installed on the iPad.
The Cubasis bug is that it crashes if a project with an unknown AU MIDI effect is loaded.
This may have happened to the user because the AU MIDI effect app that has been used in the project changed its name in a recent update.

Please let us know if the project is now loadable on cubasis 2.7 again.

thank you
best
jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Sat May 25, 2019 9:44 am

Hi,

I loaded the project, but have the same problem: the play button turns green when pressed but nothing happens. No audio, no bar sweeping across the screen.

dw

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: Freeze/unfreeze corrupts project

Post by Hiltmann » Mon May 27, 2019 10:26 am

Hi dancehallwraith,

I can't reproduce this with iPad Pro 11,iOS 12.3 + iPad 10.5, iOS 12.3, Cubasis 2.7.

- I'm loading "Dub Gold repaired" project
- I start the Playback
Result : Project is loaded as expected, playback starts as expected

Unlike you, an iAA on track 5+6, third insert slot is not loaded because I did not install it.

Which iAA plugin did you load on track 5+6, third insert slot ?

best jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Tue May 28, 2019 2:24 pm

dancehallwraith wrote:
Sat May 25, 2019 9:44 am
Hi,

I loaded the project, but have the same problem: the play button turns green when pressed but nothing happens. No audio, no bar sweeping across the screen.

dw
Hi dw,

Please let us have some more information:

- are Audio Damage plug-ins used in the project?
- What exact iPad model do you have in use?

If Audio Damage plug-ins are loaded, please

- create and load a snapshot of the project*
- unload the Audio Damage plug-ins in the project copy
- double check if the project playback issues still appear

As written earlier above, I'm aware of an issue, where using Audio Damage plug-ins on the iPad Pro 12.9" 1st Gen model lead to serious playback problems.

Looking forward to your feedback.

Thanks,
Lars

* How to create a project snapshot:
- Go to Media/Projects
- Select a project (if not already selected)
- Tap the snapshot icon (camera icon)
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Tue May 28, 2019 7:14 pm

You’re right; it’s Audio Damage plug-ins. I’m using QuatroMod and Dubstation 2 (this is slot 3). When I remove these from the project it runs fine. I’ve been using Dubstation 2 in particular a lot, which explains why I’ve seen this problem so often. Thanks very much for your help.

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Wed May 29, 2019 6:18 am

Hi dw,

Thank you for your immediate testing and reply. Good to know we’ve nailed down, where the problem is related to.

I will share the topic with our friends at Audio Damage, to exchange about the issue. If possible, please make them aware of the problem as well.

Thanks again for your help!

Best wishes,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: Freeze/unfreeze corrupts project

Post by Hiltmann » Wed May 29, 2019 7:23 am

Hi All,

Additional Information :

- not reproducible with Audio Damage Plugins and iPad Pro11, iOS 12.3 + iPad 10.5, iOS 12.3 + Cubasis 2.7

It seems to be reproducible only with the 3rd gen iPad Pro 12.9 or iPAD Air 1 + Audio Damage + iOS ?

greetings
Jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

dancehallwraith
New Member
Posts: 10
Joined: Wed May 15, 2019 9:47 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by dancehallwraith » Wed May 29, 2019 4:29 pm

I’ve told Audio Damage.

Mine is a first gen iPad Pro, not 3rd. iOS 12.2.

User avatar
LSlowak
Steinberg Employee
Posts: 2646
Joined: Thu Aug 08, 2013 12:36 pm
Contact:

Re: Freeze/unfreeze corrupts project

Post by LSlowak » Fri May 31, 2019 9:34 am

dancehallwraith wrote:
Wed May 29, 2019 4:29 pm
I’ve told Audio Damage.

Mine is a first gen iPad Pro, not 3rd. iOS 12.2.
Hi dw,

Thanks again for your message.

As mentioned before, I'm able to reproduce the issue on iPad Pro 12.9" 1st Gen, too.

Please keep us updated, if you hear back from Audio Damage.
Will make sure to notifiy them about the problem as well.

Best,
Lars
Lars Slowak - Project Management & Team lead Cubasis
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook

User avatar
Hiltmann
Steinberg Employee
Posts: 199
Joined: Mon Jan 07, 2013 11:41 am
Contact:

Re: [3rd Party Issue] Freeze/unfreeze corrupts project

Post by Hiltmann » Tue Jun 11, 2019 8:50 am

Hi All,

All our test results are consistent, regardless of the iOS version:

It works on all iPad Pro's that are faster (or newer) than 1st generation:

- Works as expected on iPad Pro 12.9" 3rd gen, on iPad Pro 11" 3rd gen and on iPad Pro 10.5" 2nd gen

On all iPads that are 2015 or older, the problem occurs with Audio Damage:

- So it doesn't work on iPad Air 1, iPad Pro 12.9" 1st gen for example.

best
Jan
Jan Hiltmann, Test Engineer - Content
Steinberg Media Technologies GmbH
Hamburg, Germany

Post Reply

Return to “Cubasis”

Who is online

Users browsing this forum: No registered users and 3 guests