Page 1 of 1

ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 9:01 pm
by corlenbelspar
Forgive me if this is a stupid question or if I missed a previous post that had this answered already, I tend to miss things easily, but I have a Sound Blaster X-Fi Titanium sound card and I would like to use its "Creative ASIO" for Cubase 6 but it is not showing up in Cubase's list of ASIO drivers. ASIO4ALL is showing up (which has served me well for a year or two but it's time to move on) but not Creative ASIO. Any help would be appreciated. :D

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 9:17 pm
by HowlingUlf
Why not try the desperate stuff when you're still relatively calm and not hyperventilating ... ? ;)

You're sure you've installed the drivers properly?
Try reinstallin just to get that out of the way. The drivers are not working anyway so ...

HTH :)

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 9:39 pm
by corlenbelspar
lol well I have Reason 5 and some other audio programs that use ASIO and Creative ASIO shows up for them, but I guess I can try that.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 9:46 pm
by HowlingUlf
Naw, then it's kind of pointless? :?
So now it's only 2435 other things to try! :lol:

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 9:51 pm
by corlenbelspar
After a bit of poking about I noticed Creative ASIO is only showing up in 32-bit applications and never 64-bit applications. Perhaps this is something that I should ask on the Creative forums.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 10:11 pm
by Guest
May need 64 bit drivers and firmware, if applicable.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 10:15 pm
by corlenbelspar
Yeah I just did a search after suspecting that when I discovered it isn't showing up for 64-bit programs and found out Creative is an a-hole and doesn't supply 64-bit ASIO drivers up front. :evil: I did a bit of searching and found the 64-bit drivers by pure luck but my problems may not be over because in the past I've had the 32-bit drivers cause my computer to actually blue screen when they even try to initiate. :( Oh well, as soon as this install of RealStrat finishes so I don't lose the progress of it, I'll see if Cubase 6 can run it without a blue screen of death.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 10:28 pm
by Guest
To be honest, Blasters are more of a gaming and sound playback soundcard and not really for DAW use. Yes, they can be used, but you see yourself some of the issues. Investing in a good interface would be your best course.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 11:14 pm
by matjones
mashedmitten wrote:To be honest, Blasters are more of a gaming and sound playback soundcard and not really for DAW use. Yes, they can be used, but you see yourself some of the issues. Investing in a good interface would be your best course.
+1!
yep great for games... not so good for DAW usage.... at that end of the market you would be MUCH better off with something like an Maudio Audiophile.

Re: ASIO Drivers Not Showing

Posted: Thu Jun 16, 2011 11:22 pm
by corlenbelspar
Yeah I think I will be changing sound cards if I can't put enough band aids on this to fix it up.