6.02 patch - crackles!

For users of legacy Steinberg Cubase software
User avatar
plectrumboy
Member
Posts: 660
Joined: Thu Jan 06, 2011 4:48 pm
Contact:

Re: 6.02 patch - crackles!

Post by plectrumboy » Mon May 23, 2011 7:27 pm

Just read this thread - it contains clear and detailed informaion about saving out the vst3 plugin set from Cubase 6.0 somewhere convenient like your desktop and then swapping this for the 6.02 plugin set.

Steve.
Scan 3XS desktop i7 5820 @ 4.0 Ghz on Asus x99 Pro 32Gb running Windows 10 pro with Thunderbolt card; MacBook Pro 2018 32gb, 2x UR824, UAD Apollo Twin Mk II Quad; Icon Qcon Pro X + 1x Pro XS, Cubase 10.5 (most recent), Jamstix 4, The Grand 3, HSO, Wavelab 9.5, Halion 6, BFD3, NI Studio Drummer, Session Horns Pro, Mark 1, Groove Agent 4, Stylus RMX, Trillian, Kontakt, VST Connect Pro.

andreasm
Steinberg Employee
Posts: 177
Joined: Mon Jan 03, 2011 4:37 pm
Contact:

Re: 6.02 patch - crackles!

Post by andreasm » Tue May 24, 2011 10:22 am

markmcfarlane wrote:I'm on Mac OSX. I started getting the crackles after the 6.0.2 upgrade and I do not knowingly use Steinberg's multiband or any other steinberg VSTs
About the 'not knowingly': you can open the plug-in information window and see how many instances of a certain plug-in is used. Could you please check that. As I already stated, the MB-Compressor creates CPU-peaks for small ASIO-blocksizes (<=128) after the 6.0.2-fix.
Andreas Mazurkiewicz, Technical Lead Plug-in Set
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

User avatar
matjones
Senior Member
Posts: 1302
Joined: Wed Dec 15, 2010 6:44 pm
Location: Here....
Contact:

Re: 6.02 patch - crackles!

Post by matjones » Tue May 24, 2011 10:28 am

I've not used the MBC AT ALL and i was still experiencing crackles... only on new projects though... until i replaced my vst3 plugins file with the 6.0.0 version.
Cubase 10.0.40 Asus Z390-Plus, i9 9900 @ (3.7) 5GHz, 64GB DDR4 3000Mhz RAM, RME Multiface II PCIe, SSL Alpha Channel, UAD2 Octo/Solo/Quad, UA6176, Neve 8801, Loads of plugs, WL9.5, Melodyne Studio 4, Arturia VC7, iZotope MPS, Eventide XI, Various toys, Telefunken, Neumann, AKG, Sontronics, Shure Mics, Adam A7X and Avantone monitors, AKG K702, ATH-M70x, Nektar P6, Warwick, Spector Basses, Gibson Les Paul Studio & loads of other junk.


Minds are like parachutes, they work best when they're open.

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: 6.02 patch - crackles!

Post by alexis » Tue May 24, 2011 4:08 pm

matjones wrote:I've not used the MBC AT ALL and i was still experiencing crackles... only on new projects though... until i replaced my vst3 plugins file with the 6.0.0 version.
OK, thanks for this! I was wondering if this was really a MBC issue at all, or if it was just a vst3 folder issue.

Are you able to use the MBC without crackles now after replacing the VST3 folder (6.00 into 6.02)?

I wonder why not everyone has this problem ...
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Metallion
Junior Member
Posts: 52
Joined: Wed Mar 16, 2011 3:00 pm
Contact:

Re: 6.02 patch - crackles!

Post by Metallion » Tue May 24, 2011 7:15 pm

1 more here, from Portugal.
I've been struggling for 3 days now, had an embarrassment with a band here too because of this.
I'll try to trade just those files from my Cubase 6 DvD as soon as i can.
As soon as i turn off the MBCompressor, the sound stays good...

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: 6.02 patch - crackles!

Post by alexis » Tue May 24, 2011 7:32 pm

Metallion wrote:1 more here, from Portugal.
I've been struggling for 3 days now, had an embarrassment with a band here too because of this.
I'll try to trade just those files from my Cubase 6 DvD as soon as i can.
As soon as i turn off the MBCompressor, the sound stays good...
Hi Metallion - If you are able, please report back whether you can use the MBC normally (without crackles) after exchanging out the VST3 folder ...

Thanks!
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Metallion
Junior Member
Posts: 52
Joined: Wed Mar 16, 2011 3:00 pm
Contact:

Re: 6.02 patch - crackles!

Post by Metallion » Tue May 24, 2011 7:44 pm

i'm struggling to find that on my Cubase 6 Dvd ...i'm on mac.. :|

Edit...
i'm installing again all new from dvd. and then i'll try older sessions.


I found this problem this way:

I have 1 iMAC and 1 MacBook Pro..

I opened a session coming from MacBook Pro with Cubase 6.0 with my iMAC with Cubase 6.0.2 (This seemed to broke the session)

Then i opened the live session, already prepared in iMAC, with MacBook Pro, with Cubase 6.0...
Result? Ultra Latency, the general quality of the sounds/inputs and loudness disappeared.
As soon as i found/turn of MBCompressor, the latency and crackles disappeared.

But now, im worried. I'll install Cubase 6 again.
Open a previous session, never opened with Cubase 6.0.1 and Cubase 6.0.2 ...and i will work only with Cubase 6.0...

Santuzzo
Junior Member
Posts: 158
Joined: Sun Dec 26, 2010 1:30 pm
Contact:

Re: 6.02 patch - crackles!

Post by Santuzzo » Tue May 24, 2011 11:13 pm

For going back to 6.0 from 6.0.2, is there another option than uninstalling and re-installing form the DVD?

nexis
Member
Posts: 225
Joined: Wed Jan 05, 2011 10:49 pm
Contact:

Re: 6.02 patch - crackles!

Post by nexis » Wed May 25, 2011 2:28 am

yup, count me in too. I get crackles too. I'm running Cubase 6 64 bit. I have a "clean" Win 7 64 bit install. I have 2 MR816 CSX's. All with the latest drivers and updates. I tracked a simple session recording drums on 5 tracks with nothing else on the inserts or anything else and I get these annoying crackles. It's pretty embarrassing for me in front of the band that I'm recording. Here I am singing praises on how cool this new computer is, and I can't even play a few tracks without these crackles. By the way, I also have 3 TB Western Digital Black Caviar hard drives. 1 is for OS and VST's, 1 for all my samples, and the 3rd one is my recording drive, I have 12 gigs of ram in this thing too...

nexis
Cubase 10.5 PRO, Steinberg MR816 CSX (2 of them), Windows 10 Pro, i7 Processor, 24 gigs of RAM, 3 Separate TB Drives, BluRay Burner Dual Monitors

andreasm
Steinberg Employee
Posts: 177
Joined: Mon Jan 03, 2011 4:37 pm
Contact:

Re: 6.02 patch - crackles!

Post by andreasm » Wed May 25, 2011 2:15 pm

Who of you experience crackles with 6.02 patch and:

1. don't use Multiband Compressor but other Steinberg VST3 plug-ins ?

2. don't use any Steinberg VST3 plug-ins ?

Please make sure there are no plug-ins in control room or any other 'forgotten' slots. ;)

Please try to reduce the complexity of your project or even better start with a fresh project. When does crackling start ? Even when playing back a stereo track ?
Andreas Mazurkiewicz, Technical Lead Plug-in Set
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

User avatar
matjones
Senior Member
Posts: 1302
Joined: Wed Dec 15, 2010 6:44 pm
Location: Here....
Contact:

Re: 6.02 patch - crackles!

Post by matjones » Wed May 25, 2011 5:14 pm

andreasm wrote:Who of you experience crackles with 6.02 patch and:

1. don't use Multiband Compressor but other Steinberg VST3 plug-ins ?

2. don't use any Steinberg VST3 plug-ins ?

Please make sure there are no plug-ins in control room or any other 'forgotten' slots. ;)

Please try to reduce the complexity of your project or even better start with a fresh project. When does crackling start ? Even when playing back a stereo track ?

In the one new project i started with 6.0.2 i only had an instance of HS running and when i tried to run either reverance, studio chorus or studio delay i got crackles... when i used the mono-stereo plug it was fine. i also used an instance of the kerjhaus (or however it's spelled) classic comp on an fx send, again this caused no issues.. this was on 32bit 6.
ALL of the issues seem to have gone since swapping the vst3 plugins file for the earlier version... can't really say more than that.
Cubase 10.0.40 Asus Z390-Plus, i9 9900 @ (3.7) 5GHz, 64GB DDR4 3000Mhz RAM, RME Multiface II PCIe, SSL Alpha Channel, UAD2 Octo/Solo/Quad, UA6176, Neve 8801, Loads of plugs, WL9.5, Melodyne Studio 4, Arturia VC7, iZotope MPS, Eventide XI, Various toys, Telefunken, Neumann, AKG, Sontronics, Shure Mics, Adam A7X and Avantone monitors, AKG K702, ATH-M70x, Nektar P6, Warwick, Spector Basses, Gibson Les Paul Studio & loads of other junk.


Minds are like parachutes, they work best when they're open.

RJH Music
New Member
Posts: 42
Joined: Tue Apr 12, 2011 7:15 pm
Contact:

Re: 6.02 patch - crackles!

Post by RJH Music » Wed May 25, 2011 6:04 pm

Wow! I thought I was going nuts until I read this post. I was also getting ready to go ballistic on Tellow Tools, but maybe the problem is Cubase. Runing Cubase 6.0.2 on MAC Book Pro. Small project with three MIDI tracks and one VST, YT Independance Pro. Probelm is I cannot remember when it started in what version, but here is what happens.

WIth YT Acoustic Guitar & Oragami loaded, both in record and in playback mode, I get crakles and pops when ever a lot of notes are played like a fast arppegio, then almost instantly, cubase skips so to speak. Timing goes nuts for a few seconds, and my drum machine skips timing. I do not use the MBC or any other instert effects in cubase. I thought it was YT Independance, but now Trillian is also doing the same.

Can't balme my hardware because it is top notch - Mac Book Pro, 2.54 ghrtz machine intel core 2 duo, 6 GB ram, 500 GB hybrid HD with 32mb cache and 4 gb of SD flash, MOTU 828 II, Audio Samples from G-Tech G-Raid mini with hybrid drives in Raid 0 config, (One Large drive) connected to ExpressCard port on MAC. (I need to start a different post on the question conerning the use of Hybrid drives)

I was getting ready to also blame the new G-Raid mini drive and will try to confirm tonight by using another G-Tech single drive to see if problem still exists. Again, my biggest problem is that I do not know when the trouble started, as it has been going on for a couple of weeks now, and I do not remember when I installed 6.02. But I do know for sure that if I turn off the FX in Inepdendance, the problem goes away, so it has to be related to usage spikes.

RJ
MAC Book Pro 10.8, 16 gb ram, iMAC 21.5 16 GB ram | G-Tech Raid Mini | MOTU 828 II | MTPAV (2) | Cubase 4 - 7 + SX | EWQL PLAY; VOP, Goliath, SC, SOP, Gypsy, Pianos, SD 1&2 | Ilio; Omnishere, Trillian | YT, INDY Pro 3 | Kontakt 4 | Vienna Ensemble Pro | The Sax Brothers | Real Guitar | BFD 2 | Melodyne | Logic Pro 9 | LAS | MACHINE Complete | Hardware - Roland JV,1000, JV 1080 XP80, Fantom, XV 5080, 3080, R-70, DR-880 | Korg M1, M3R, O3R/W, Triton Rack, TR Rack | Mackie 32 X 8, HUI, d8b, Yamaha Motif X7

User avatar
JHP
Member
Posts: 755
Joined: Wed Nov 03, 2010 1:58 pm
Contact:

Re: 6.02 patch - crackles!

Post by JHP » Thu May 26, 2011 2:55 pm

At first let me point out that in general the Cubase 6.02 patch does not crackle, as the topic suggests.

This might be obvious to most of your but just to point it out:
One must understand that by adding more and more plugins to your projects, especially the heavy ones like for instance the MBCompressor or the Reverence, you will of course increase the strain on the system and ASIO crackles could occur. The ASIO buffersize set in the ASIO driver control panel is a dynamical value that one should alter depending on the production phase. The buffersize is not a value that you dial in and then never touch again. For example, when you record you would reduce the buffersize and when you come to the mixing stage you would increase the buffersize to have more power for plugins. It is very common to work this way in a DAW environment. You will find that this is a common procedure in production setups and professional studios. In audio engineering we do not need close to zero latency when we mix. So again, it is absolutely normal to turn up the buffersize so you can add more plugins without driving system performance to its knees.

As you can see "andreasm" is already replying to your posts and we are prepared to deal with your reports and have a closer look. But this is not a bug that comes with a repro and is clearly defined. There are a lot of dependencies that could be involved and we need to check up on the specifics. It must be absolutely clear how your projects are setup.

To exactly pin point this issue I would like to ask all of you to please PM the problematic projects that you are referring to in your posts to me so I can hand them over to andreasm. By sending us your *.cpr (Cubase Project File) you can be assured that your specific project setups are considered by our experts and plugin specialist when investigating on the problem. When you send us the *.cpr please give us as much informatioen about your system as possible and please also state with which ASIO device, with which ASIO driver and with which buffersize you have encountered the "crackels".


Just to show that the issue is not easily reproducible:
Attached to my post there is a animated gif that shows low buffersize ASIO settings in conjunction with Cubase 6.02 and a couple of factory 6.02 VST3Set Plugins. There is no problem on playback and you can see that VST performance meter on the transportbar is relatively calm.
Crackles6.02_NotOnThisSystem.gif
(21.54 MiB) Not downloaded yet
Thank you in advanced for your constructiveness. :)
Gr,
JHP
Jan Peters, QA
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

User avatar
plectrumboy
Member
Posts: 660
Joined: Thu Jan 06, 2011 4:48 pm
Contact:

Re: 6.02 patch - crackles!

Post by plectrumboy » Fri May 27, 2011 8:20 am

JHP wrote:At first let me point out that in general the Cubase 6.02 patch does not crackle, as the topic suggests.

This might be obvious to most of your but just to point it out:
One must understand that by adding more and more plugins to your projects, especially the heavy ones like for instance the MBCompressor or the Reverence, you will of course increase the strain on the system and ASIO crackles could occur. The ASIO buffersize set in the ASIO driver control panel is a dynamical value that one should alter depending on the production phase. The buffersize is not a value that you dial in and then never touch again. For example, when you record you would reduce the buffersize and when you come to the mixing stage you would increase the buffersize to have more power for plugins. It is very common to work this way in a DAW environment. You will find that this is a common procedure in production setups and professional studios. In audio engineering we do not need close to zero latency when we mix. So again, it is absolutely normal to turn up the buffersize so you can add more plugins without driving system performance to its knees.

As you can see "andreasm" is already replying to your posts and we are prepared to deal with your reports and have a closer look. But this is not a bug that comes with a repro and is clearly defined. There are a lot of dependencies that could be involved and we need to check up on the specifics. It must be absolutely clear how your projects are setup.

To exactly pin point this issue I would like to ask all of you to please PM the problematic projects that you are referring to in your posts to me so I can hand them over to andreasm. By sending us your *.cpr (Cubase Project File) you can be assured that your specific project setups are considered by our experts and plugin specialist when investigating on the problem. When you send us the *.cpr please give us as much informatioen about your system as possible and please also state with which ASIO device, with which ASIO driver and with which buffersize you have encountered the "crackels".


Just to show that the issue is not easily reproducible:
Attached to my post there is a animated gif that shows low buffersize ASIO settings in conjunction with Cubase 6.02 and a couple of factory 6.02 VST3Set Plugins. There is no problem on playback and you can see that VST performance meter on the transportbar is relatively calm.
Crackles6.02_NotOnThisSystem.gif
Thank you in advanced for your constructiveness. :)
Gr,
JHP
Hello JHP,

I didn't realise that andreasm was a Steinberg colleague.

I tried to separate out one specific problem I was facing (http://www.steinberg.net/forum/viewtopi ... =19&t=8592) following the upgrade to 6.02. I have only run small projects and have not noticed a problem with crackles, but I have noticed a problem with greatly increased latency. The latency problem disappeared when I swapped out the 6.02 plugin set and replaced it with the 6.0 vst3 plugin set. I associated this problem with my use of the multiband compressor. Other users seem to be able to reproduce this.

I notice above that andreasm asked whether people are noticing a problem with any other vst3 plugins apart from the multiband compressor. Does this mean you have identified an issue with this particular plugin?

Regards,

Steve.
Scan 3XS desktop i7 5820 @ 4.0 Ghz on Asus x99 Pro 32Gb running Windows 10 pro with Thunderbolt card; MacBook Pro 2018 32gb, 2x UR824, UAD Apollo Twin Mk II Quad; Icon Qcon Pro X + 1x Pro XS, Cubase 10.5 (most recent), Jamstix 4, The Grand 3, HSO, Wavelab 9.5, Halion 6, BFD3, NI Studio Drummer, Session Horns Pro, Mark 1, Groove Agent 4, Stylus RMX, Trillian, Kontakt, VST Connect Pro.

andreasm
Steinberg Employee
Posts: 177
Joined: Mon Jan 03, 2011 4:37 pm
Contact:

Re: 6.02 patch - crackles!

Post by andreasm » Fri May 27, 2011 10:59 am

plectrumboy wrote:
Does this mean you have identified an issue with this particular plugin?
Yes, as it has been already posted: The Multiband Compressor does have a latency since patch 6.0.2.
And it should have had it before. But it didn't, that was a bug. Now it is working correctly. Only that for small block sizes (<=128) the system is prone to crackle, because of nervous CPU-consumption of that particular plug-in. I'm
still working on it. That is why I asked those two questions in my post above.
Andreas Mazurkiewicz, Technical Lead Plug-in Set
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

User avatar
plectrumboy
Member
Posts: 660
Joined: Thu Jan 06, 2011 4:48 pm
Contact:

Re: 6.02 patch - crackles!

Post by plectrumboy » Fri May 27, 2011 11:51 am

andreasm wrote:
plectrumboy wrote:
Does this mean you have identified an issue with this particular plugin?
Yes, as it has been already posted: The Multiband Compressor does have a latency since patch 6.0.2.
And it should have had it before. But it didn't, that was a bug. Now it is working correctly. Only that for small block sizes (<=128) the system is prone to crackle, because of nervous CPU-consumption of that particular plug-in. I'm
still working on it. That is why I asked those two questions in my post above.
Thanks very much Andreasm for the reply; I'm sorry I didn't realise this was already known. Yes, I've been running usually at 256 samples. It's a real shame the low latency pre-6.02 MBC is the bugged one, when the new high-latency one is not! I must try both versions and see what the audio differences are. Good luck with your continued work.
Scan 3XS desktop i7 5820 @ 4.0 Ghz on Asus x99 Pro 32Gb running Windows 10 pro with Thunderbolt card; MacBook Pro 2018 32gb, 2x UR824, UAD Apollo Twin Mk II Quad; Icon Qcon Pro X + 1x Pro XS, Cubase 10.5 (most recent), Jamstix 4, The Grand 3, HSO, Wavelab 9.5, Halion 6, BFD3, NI Studio Drummer, Session Horns Pro, Mark 1, Groove Agent 4, Stylus RMX, Trillian, Kontakt, VST Connect Pro.

User avatar
sonicstate
Member
Posts: 467
Joined: Wed Dec 15, 2010 9:28 pm
Contact:

Re: 6.02 patch - crackles!

Post by sonicstate » Fri May 27, 2011 3:26 pm

JHP wrote:Just to show that the issue is not easily reproducible:
Attached to my post there is a animated gif that shows low buffersize ASIO settings in conjunction with Cubase 6.02 and a couple of factory 6.02 VST3Set Plugins. There is no problem on playback and you can see that VST performance meter on the transportbar is relatively calm. [/size]
Crackles6.02_NotOnThisSystem.gif
Thank you in advanced for your constructiveness. :)
Gr,
JHP
JHP, I'm glad to see that it works perfectly for you. :idea: May I please ask you to reveal your system? I need to buy new machine, and I wouldn't mind getting exactly the same as works in your case. Thank you.
Cubase Pro 8.5, Win 64bit, i7-4770K @4.3GHz, ASUS Z87-K, 16Gb, RME HDSP 9652, BCF 2000, BCR 2000, Novation Launchpad Mini, M-Audio TriggerFinger, M-Audio Axiom AIR Mini 32, Korg NanoKey, plenty outboard synths and fx, 24ch Studiomaster mixer, Yamaha NS10s, Dynaudio BM5, Samson Rubicon R8a Ribbon, etc...

User avatar
JHP
Member
Posts: 755
Joined: Wed Nov 03, 2010 1:58 pm
Contact:

Re: 6.02 patch - crackles!

Post by JHP » Fri May 27, 2011 5:20 pm


Here are the specs of the system that the gif was created on.
System optimized as described in:
https://www.steinberg.net/en/support/kn ... -for-daws/
OS: MS Windows 7 Ultimate 64bit (Tested with Cubase 6.02 32bit)
CPU Type: QuadCore Intel Core 2 Quad Q9300, 2500 MHz (7.5 x 333)
Motherboard Name: Asus P5K (3 PCI, 2 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)
Motherboard Chipset: Intel Bearlake P35
4GB RAM: DIMM1: Kingston 2G-UDIMM 2 GB DDR2-800 DDR2 SDRAM (Channels#: Dual, DC Mode: Symmetric)
Video Adapter: NVIDIA GeForce 7600 GT (256 MB)
Disk Drive: WDC WD5000AAKS-22A7B0 ATA Device (465 GB, IDE)
Soundcard: Yamaha Steinberg MR- 816x
I was at 128 samples or 256 samples buffersize when I made the gif.
Here is a guide to DAW Components:
http://www.steinberg.net/en/support/ste ... t_daw.html
Gr,
JHP
Jan Peters, QA
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

Santuzzo
Junior Member
Posts: 158
Joined: Sun Dec 26, 2010 1:30 pm
Contact:

Re: 6.02 patch - crackles!

Post by Santuzzo » Fri May 27, 2011 5:42 pm

Thanks for all the new input!

Yesterday I tried to re-create the crackles I had but no luck. When I played back what I had previously recorded there were no crackles, but I did not try to record. I will do that this weekend, and post my results.

One different problem I had noticed (also not last night but about a week ago or so after installing the 6.0.2 patch):
When playing back my project it played back slowed down as if I had applied a slow down software of some kind. It sounded really strange.
When I hit stop and play again, it was back to normal, but I had this happening a few times, and only after I installed the 6.0.2 patch. Before this patch I had never had this problem.

Does anybody have an idea what the cause of this could be?

Thanks,
Lars

TechBytes
Junior Member
Posts: 54
Joined: Wed Dec 15, 2010 8:36 pm
Contact:

Re: 6.02 patch - crackles!

Post by TechBytes » Sat May 28, 2011 10:30 pm

andreasm wrote:
plectrumboy wrote:
Does this mean you have identified an issue with this particular plugin?
Yes, as it has been already posted: The Multiband Compressor does have a latency since patch 6.0.2.
And it should have had it before. But it didn't, that was a bug. Now it is working correctly. Only that for small block sizes (<=128) the system is prone to crackle, because of nervous CPU-consumption of that particular plug-in. I'm
still working on it. That is why I asked those two questions in my post above.
Let me get this straight,

So previous to 6.02, the MB compressor should have had a delay but didn't because of a "bug" in the earlier version, which you fixed, which has now introduced a delay because you fixed the bug, but it has now subsequently caused crackling ?

Am I close the peg ?

Also, to be clear, you are saying that using the MBC that has been around for years without causing delays, has always had a bug which you have now fixed and can't be used without inherent delay being introduced.. ?

I'm confused.. !

@ JHP,

Your 101 on dynamic ASIO buffer setting seems to miss one vital point , that many of us require the systems to run at ultra low latencies for the vast majority of time due to using virtual instruments , so raising buffers for mixing is irrelevant to the working environments being posed on this thread. Also many with good audio hardware can set and forget modern native systems at 064/128 samples and never touch the dial , the so called common practice of raising buffers depending on the production stage is not as valid as it was on past systems, it just sounds like a cop out.

If the majority here had no problem what so ever on 6.00 and 6.01, then it would be wise to focus on resolving the issues that you have introduced instead of shifting the blame on the end user's working environments / systems.

I seriously have to question who is BETA testing this , this was an elephant in the room, and it was missed !

cenk
Junior Member
Posts: 64
Joined: Thu Jan 13, 2011 2:36 pm
Contact:

Re: 6.02 patch - crackles!

Post by cenk » Wed Jun 01, 2011 9:12 am

Hello,

I was always using Multiband Compressor on Cubase 5 without any problems but after Cubase 6.0.2, I cannot play midi keyboard because of the latency if the multiband compressor is on (there are no any other plugins on while I'm testing this latceny). When I play a note with midi keyboard I hear it in half second. Changing buffer size does not fix it. My buffer size is set to 512.

So I don't use multiband compressor anymore but I want to use it. Will it be fixed on the next update?

Here is my setup:
Windows 7 64 bit
Cubase 6.0.2 64 bit
Intel Quad 3.0ghz (no overclock)
8 GB Ram
Steinberg MR816X (buffer size set to 512)
Steinberg CC121
AMD Radeon 5750


Thanks,
Cenk
Software: Windows 8 (64 bit), Cubase 7 (64 bit), Vienna Ensemble Pro, Steinberg VSTs, East West Play VSTs 64 bit

Hardware: Intel i7 3.4 Ghz CPU, 32GB DDR3 Memory, Steinberg/Yamaha MR816X DSP Sound Card & CC121 Controller, M-Audio Keystation, Event Reference Monitors, Rode NT2-A

User avatar
JHP
Member
Posts: 755
Joined: Wed Nov 03, 2010 1:58 pm
Contact:

Re: 6.02 patch - crackles!

Post by JHP » Wed Jun 01, 2011 10:14 am

Let me point out again that in general the Cubase 6.02 patch does not crackle, as the topic suggests.
-------------------------------------------------------------------------------------------------------------------------------------
Here are some more important technical facts that relate to some of the posts in this thread. Especially because the MBC now introduces more latency the following is important to realize.

We should distinguish between 1. latency introduced by plugins and 2. ASIO crackles. Let me point out some more important technical facts regarding 1. latency introduced by plugins.

We must differentiate between two types of plugins.
A. Those which introduce a latency
B. Those which don't introduce a latency

The reason why some VST's introduce a delay is because for instance they make use of look ahead technology in order to provide special functionality to the user or because it might take some time to process the signal being fed in to it because they use special calculation specifications.

In Cubase if you open the Plugin Information windows you can check your plugins and in the "Latency" column look up how much delay (in samples) is introduced if the plugin is inserted. Click on the latency tag to sort all of your plugins by latency. :!: You should realy do this right now if you are not aware of your plugin latencies.:!:

Let's say we have the MBC with a delay of 3926 (new 6.02) sams inserted in the project. What happens now is that the Automatic Plugin Compensation feature comes to use. This means that all the other tracks will also be delayed by the same amount of samples so the audio remains in sync when you play back. If we are working with a samplerate of 48 kHz one sample would be 1/48000 sec. So in this case the MBC will introduce 3926/48000 sec = 81.7916667 ms. So all the other tracks will also be played back 82ms later to remain in sync with the track that the MBC has been inserted on.
Furthermore we will for instance experience a 82ms increase of latency during input when we put the MBC on the VSTi out, FX Tracks, Group Tracks that the signal is routed to or on the Master Channel and then hit on our MIDI keys to play the VSTi. To make this more clear you can test this and add several latency introducing plugins to your recording channels or and the master channel. This is not a MBC issue but a natural behavior of all latency introducing plugins.

That tells us one thing for sure, as we require a low latency environment for recording VSTi's or non direct monitoring audio, we should not insert plugins that introduce latency on the tracks on which we would like to record or tracks that are linked to the tracks on which we would like to record (Audio tracks, VSTi outs, FX Tracks, Group Tracks that the signal is routed to or on the Master Channel). To be absolutely on the safe side one should consider not to use delay introducing plugins in the creational recording phase.

If you still do this you might want to consider making use of the "Constraint Delay Compensation" button on the upper left side of the project window when you start recording.

I hope that I could clarify some technicalities.
---
Regarding ASIO crackles there is two ways to prevent them. One, you can raise the buffersize, two you can reduce the strain on the system by using less processes.

Andreasm has stated that he is working on calming down the CPU consumption for the MBC regarding the problem that for small block sizes (<=128) it could happen that crackles might be introduced.

Digital audio engineering facts regarding latency introducing plugins and ASIO overloads that I am pointing out will remain.

Gr,
JHP
Jan Peters, QA
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

User avatar
Split
Grand Senior Member
Posts: 5285
Joined: Wed Dec 15, 2010 5:06 pm
Contact:

Re: 6.02 patch - crackles!

Post by Split » Wed Jun 01, 2011 10:41 am

And for those without a calculator that will be be 96ms at 44.1Khz !!!
??????Split
Cubase 10|MOTU 16A
Still at it... just!

NYC Composer
Member
Posts: 376
Joined: Wed Dec 15, 2010 11:08 pm
Contact:

Re: 6.02 patch - crackles!

Post by NYC Composer » Wed Jun 01, 2011 10:53 am

All that having been said, it would be nice to have a straight answer to this question-does C6.02 require somewhat more CPU power to run? Is it a bit less efficient than 5.5?
Regards, L.J.

_______________________________________________________

Cubase 10.5.12, 2019 iMac i9 8 core@3.6khz, OS 10.14.6, 72 GB RAM, scads of SSDs, Babyface Pro, OWC 4 bay Thunderbolt 3 enclosure, too many sample libraries, 90s American Series Strat, Taylor and Martin acoustics, Mexican Fender Precision.

User avatar
JHP
Member
Posts: 755
Joined: Wed Nov 03, 2010 1:58 pm
Contact:

Re: 6.02 patch - crackles!

Post by JHP » Wed Jun 01, 2011 11:37 am

NYC Composer wrote:All that having been said, it would be nice to have a straight answer to this question-does C6.02 require somewhat more CPU power to run? Is it a bit less efficient than 5.5?
I assume that C6.02 is more efficient and optimized especially if you consider the "Activate Steinberg Audio Power" feature but I'm not 100% sure as I did not do any a to b benchmark tests here. But the minimum system specifications for Cubase 6 are stated here:
http://www.steinberg.net/en/products/cu ... loads.html


6.02 is good, stable and clean and thats also how it feels.

Don't worry and get confused by the bit panicmongering title of this thread as the topic was created before the users have constructively pinpointed the issue to the MBC and buffersize settings as the thread progressed. ;)

So maybe the topic should be called "MBC at 128 or less buffersize could crackle". Be informed that because of enhancements and more complex calculation specifications after a fix in the MBC the MBC now also introduces more latency.

It has been stated that the MBC (Multi Band Compressor) in the 6.02 version could introduce crackles if you have buffersize set equal or smaller then 128 buffersize. Also consider what I wrote about plugin usage, ASIO facts and mixing and recording situations.

The 6.02 patch rocks! You can check the fixes and improvements in the version history from the respective download location.

Gr,
JHP
Jan Peters, QA
Steinberg Media Technologies GmbH
Hamburg, Germany
Check out Steinberg on YouTube, Twitter and Facebook!

Locked

Return to “Older Cubase versions”

Who is online

Users browsing this forum: James Heafy and 20 guests