[Solved ... sort of] Resolve Missing Files Problem

For users of legacy Steinberg Cubase software
Post Reply
dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

[Solved ... sort of] Resolve Missing Files Problem

Post by dmbaer »

I have searched this forum and found no resolution, so I'm posting this question.

I had a directory called Untitled 07 (or some such). It contained two empty subdirectories, Audio and Images. Nothing else. I deleted the parent directory.

From that point on, every project I tried to open gave me the "Resolve Missing Files" dialog. Nothing I could do seemed to correct it. I restored the Untitled 07 directory and contents from the trash bin (Win 7, Cubase 7.5) and the dialog went away. But the file cited as missing was not in the restored directory in the first place. In the second place, I could find no project that referenced the missing file. I'm quite new to Cubase, so I have very few projects that have any significance, so looking at each for a reference to the missing file was easy - there were none.

Now, I've gotten the annoying dialog to stop showing on each project open, so that's progress. But it makes no sense. Why was I seeing this warning in the first place? Also, should the "Restore Missing Files" dialog not have some option to say "delete reference, this file is not important" or something to that effect? I spend (wasted) a lot of time trying to sort out this non-problem that appeared to be a valid problem.

Thanks for any direction on this problem.
Last edited by dmbaer on Thu Jun 19, 2014 9:35 pm, edited 1 time in total.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

User avatar
silhouette
Senior Member
Posts: 1365
Joined: Fri Jan 14, 2011 12:45 am
Contact:

Re: Resolve Missing Files Problem

Post by silhouette »

Mmmmmm! This is an issue that has puzzled me quite a bit as on a number of occasions I have created a new track forgetting to name the project. On one occasion I it had defaulted to the C drive. I was recording parts that did not appear in the Audio and Image folders. I then realised that I had no idea where the parts were so looked in the pool to discover their location. I think they were in a previous project. I backed up the new project, then deleted all unused files in the old project. However I kept getting missing files. Actually I have a number of projects with this issue where I have no idea hoe to get rid of the Missing Files dialog.
Intel core i7 5960X CPU 3.0 GHz 64bit 32 gig RAM - Windows 10 - AMD RadeonHD 7700 - RME Fireface UC - Cubase 10.5 - UAD Solo + Duo + Quad - Nektar Panorama P1 - Komplete 12 - All uhe - Adam AX7 + Adam Sub 8 - BFD3 - Alchemy - PSP - FabFilter - Fender Telecaster- Wudtone Strat - Gibson L4, 335x2,330L,175 -Ibanez PM100 - Musicman Silhouette x 3 - Warwick Thumb Bass - Kemper Profiling Amp -https://soundcloud.com/silhouette-17

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

First of all let me reiterate that I got the warning dialog on every single project I opened, including new ones created from a more or less empty template (control room only stuff preset). It was not just some projects, and it always named the same "missing" file.

Also I forgot to mention that I could at no time find the Remove Missing Files menu option other than disabled. Had I had the chance, I would have tried that to see if it corrected the problem. But the command was always disabled.

By the way - is this the best place to post something like this? I'm not very experienced with the Steinberg forums. Would it have been better to post in Issues? Thanks for any guidance.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

indiescore
Member
Posts: 394
Joined: Sun Mar 27, 2011 7:47 pm
Contact:

Re: Resolve Missing Files Problem

Post by indiescore »

dmbaer wrote:I have searched this forum and found no resolution, so I'm posting this question.

I had a directory called Untitled 07 (or some such). It contained two empty subdirectories, Audio and Images. Nothing else. I deleted the parent directory.

From that point on, every project I tried to open gave me the "Resolve Missing Files" dialog. Nothing I could do seemed to correct it. I restored the Untitled 07 directory and contents from the trash bin (Win 7, Cubase 7.5) and the dialog went away. But the file cited as missing was not in the restored directory in the first place. In the second place, I could find no project that referenced the missing file. I'm quite new to Cubase, so I have very few projects that have any significance, so looking at each for a reference to the missing file was easy - there were none.

Now, I've gotten the annoying dialog to stop showing on each project open, so that's progress. But it makes no sense. Why was I seeing this warning in the first place? Also, should the "Restore Missing Files" dialog not have some option to say "delete reference, this file is not important" or something to that effect? I spend (wasted) a lot of time trying to sort out this non-problem that appeared to be a valid problem.

Thanks for any direction on this problem.
Through all of this are you actually missing any audio files, or is cubase just citing as you say?

The pool might be the key. Open pool and right click in it, select remove unused media, not to trash though.

Save , and reopen and if you get missing file message again, choose locate and then set the new path.

The original path you deleted was probably still showing in the pool as the current path therefore cubase was trying to phone home but with the wrong path. With Cubase if you have audio video files and then change the path to them by deleting folders it won't be able to see them anymore.
Windows 10 w latest update
Cubase 10 pro w latest update
INTEL CORE I7-4790K 4.0 GHZ + 10 % over clock , water cooled.
32GB DDR3 2133 MHZ
GIGABYTE Z97X-GAMING 7 Motherboard
Project drive M.2. Form factor , SSD
2x internal SSD, 2x external SSD USB 3

Svenne
Member
Posts: 725
Joined: Sun Sep 25, 2011 10:29 am

Re: Resolve Missing Files Problem

Post by Svenne »

Check the Pool. If there is an unused audio file lurking about there, it can cause these kinds of problems. I's easy to miss and, at least, worth checking.
Cubase Pro 8.5.20 + IC Pro, WaveLab Elements 9.0.30, Mac Pro 2.8GHz 8-core 8GB, 10.11.6 (El Capitan), MR 816X, Avid Control/Mix, iPad Air (128GB), Cubasis 2.0, iTrack Dock.

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

Thanks for the suggestions. I'll give it a try and report back if anything interesting comes of it.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

No joy. I opened the pool and for the first time saw the remove missing files command enabled. So I tried it but nothing changed.

So, I guess the important question is this: how does one safely delete a project? Clearly just zapping the directory is bad news because you end up with the missing file dialog. So how do you do it? There does not seem to be a "delete project" command that I've been able to find. Thanks for any enlightenment.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

Svenne
Member
Posts: 725
Joined: Sun Sep 25, 2011 10:29 am

Re: Resolve Missing Files Problem

Post by Svenne »

Did you remember to empty the trash in the Pool? It works just as in your OS. You must empty it to truly remove the (missing) files from the Pool (project).

Of cause there is no "delete project" command. Deleting a project isn't done from within Cubase. Close the project and delete the project folder, just like you delete any other file or folder.

If you post your systemspecs in your signature, you'll make it easier for us to help you.
Cubase Pro 8.5.20 + IC Pro, WaveLab Elements 9.0.30, Mac Pro 2.8GHz 8-core 8GB, 10.11.6 (El Capitan), MR 816X, Avid Control/Mix, iPad Air (128GB), Cubasis 2.0, iTrack Dock.

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

Svenne wrote:Did you remember to empty the trash in the Pool? It works just as in your OS. You must empty it to truly remove the (missing) files from the Pool (project).

Of cause there is no "delete project" command. Deleting a project isn't done from within Cubase. Close the project and delete the project folder, just like you delete any other file or folder.

If you post your systemspecs in your signature, you'll make it easier for us to help you.
I did not do the empty (at least after I did the remove missing files. Will try and report back.

>Close the project and delete the project folder, just like you delete any other file or folder.

Well, that's what got me into this mess in the first place. :)

I will put system specs into my sig - thanks for the suggestion.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

indiescore
Member
Posts: 394
Joined: Sun Mar 27, 2011 7:47 pm
Contact:

Re: Resolve Missing Files Problem

Post by indiescore »

dmbaer wrote:
Svenne wrote:Did you remember to empty the trash in the Pool? It works just as in your OS. You must empty it to truly remove the (missing) files from the Pool (project).

Of cause there is no "delete project" command. Deleting a project isn't done from within Cubase. Close the project and delete the project folder, just like you delete any other file or folder.

If you post your systemspecs in your signature, you'll make it easier for us to help you.
I did not do the empty (at least after I did the remove missing files. Will try and report back.

>Close the project and delete the project folder, just like you delete any other file or folder.

Well, that's what got me into this mess in the first place. :)

I will put system specs into my sig - thanks for the suggestion.
when this mess started, did the new project have the same name? I think a new name in a different top folder name, might help, so hard drive V now has a new folder called project 2....
Windows 10 w latest update
Cubase 10 pro w latest update
INTEL CORE I7-4790K 4.0 GHZ + 10 % over clock , water cooled.
32GB DDR3 2133 MHZ
GIGABYTE Z97X-GAMING 7 Motherboard
Project drive M.2. Form factor , SSD
2x internal SSD, 2x external SSD USB 3

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

indiescore wrote:when this mess started, did the new project have the same name? I think a new name in a different top folder name, might help, so hard drive V now has a new folder called project 2....
I honestly don't remember. I'm a fairly new Cubase user and I had all kinds of squirrelly experimental projects with "Untitled" in the project name. My intent was to get rid of the garbage, but I can't recall the purpose of many of those projects nor their history.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

User avatar
Rotund
Member
Posts: 619
Joined: Fri May 25, 2012 8:37 pm
Contact:

Re: Resolve Missing Files Problem

Post by Rotund »

Going forward,

1. Always start a new project by creating a new, properly named folder for the song.

2. When importing audio, use the setting "copy files" to directory or whatever it says.

If you do the first one above these issues should be a thing of the past.

Sounds like you have audio files in your "template" file that shouldn't be there.
Inboard:
Win7Pro 64Bit, i7 3770k, Gigabyte Z77-UHD5, 12gb Corsair (1600Mhz), Nuendo+Nek 6.5, Reaper 4.591, Samplitude Pro X2, Studio One 3.5, CD Architect 5.2, RME Raydat, UAD PCIe Quad+Duo.

Outboard:
Moog Model D (Vintage), Sub 37, Minitaur, Slim Phatty, DSI OB-6 Desktop, Prophet Rev2 8 Voice, Roland Integra 7, SE-02, Korg Prologue 16, Triton Le, Boss Dr. Rhythm DR-55, Sound Gizmo.

indiescore
Member
Posts: 394
Joined: Sun Mar 27, 2011 7:47 pm
Contact:

Re: Resolve Missing Files Problem

Post by indiescore »

Rotund wrote:Going forward,

1. Always start a new project by creating a new, properly named folder for the song.

2. When importing audio, use the setting "copy files" to directory or whatever it says.

If you do the first one above these issues should be a thing of the past.

Sounds like you have audio files in your "template" file that shouldn't be there.


Yes I think using untitled as name each time is causing cubase to point to old. Locations, Chang name and you should be good
Windows 10 w latest update
Cubase 10 pro w latest update
INTEL CORE I7-4790K 4.0 GHZ + 10 % over clock , water cooled.
32GB DDR3 2133 MHZ
GIGABYTE Z97X-GAMING 7 Motherboard
Project drive M.2. Form factor , SSD
2x internal SSD, 2x external SSD USB 3

Bantam
Junior Member
Posts: 118
Joined: Wed Jun 04, 2014 1:58 pm

Re: Resolve Missing Files Problem

Post by Bantam »

Did you omit something at installation? Maybe made a mistake doing something else entirely and didn't think it mattered?
Sounds like your templates (and Projects?) are missing certain files on loading. This is almost always due to the Installer app or the user. Rarely, could be defragmentation issues.
I'd reinstall Cubase and start again but try to remember every step (and if you did something when you installed last time don't do it this time).
And it's very important to defrag and clean up a Windows machine after installation.

Duh! didn't read slowly enough. "Untitled" files might just simply need naming. If you're still getting problems then consider a reinstall just in case.

Although there was this:
First of all let me reiterate that I got the warning dialog on every single project I opened, including new ones created from a more or less empty template (control room only stuff preset). It was not just some projects, and it always named the same "missing" file.
So I'll go with my original advice.
What was the name of the SAME "missing file"?
Was it a file you created or one from the templates? I sometimes find that the templates try and find files, samples etc. made by the template creator I presume that they are either not present in my Cubase installation (due to me rejigging something) or were stored at the creation point with a different destination.
(my guess)
If it picks up all your relevant files and you have a "do not show this again" button you could ignore them if you're pretty sure what the cause is.
i7 3.20gHz; 16gig ram; Win 8.1; Asus z87-k mother.

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

Rotund wrote:Going forward,

1. Always start a new project by creating a new, properly named folder for the song.
Yes, this is something I've learned since as I've gotten to know Cubase a little better.

It seems to me that the dialog for creating a new project could be a little more user friendly in this fashion. It should give you the option of naming both the directory (if a new one is to be used) and the project name in the same dialog. I've since learned how to make sure I get properly named directories, but this is probably something newbies run into all the time. In any case, very good advice - thanks.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

Bantam wrote:I'd reinstall Cubase and start again but try to remember every step (and if you did something when you installed last time don't do it this time).
And it's very important to defrag and clean up a Windows machine after installation.
Seems to me that cure is worse than the disease. It's way easier to leave an empty directory sitting there. For whatever reason, the warning dialog goes away, even though that directory does not contain the file cited as missing.

In any case, I seriously doubt this is an installation issue. The problem only started happening after I deleted a number of unwanted projects (all in directories name Untitled-something because I didn't know better at the time). As to defragging, that would make absolutely zero difference other than maybe allowing Cubase to start a bit faster.

Also, OT, but I have wanted to add my system information to a signature, but I cannot find where to do that. Can anybody point me to where I do that? Thanks in advance if you can.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

User avatar
Mauri
Senior Member
Posts: 1150
Joined: Thu Dec 16, 2010 3:17 am
Location: Adelaide AU
Contact:

Re: Resolve Missing Files Problem

Post by Mauri »

Once you're logged in, go to 'User Control Panel' at top left of the page, then click 'Profile' tab, then 'Edit signature'.
Type whatever you want in the empty field, hit 'Submit' and that's it.

Mauri.
Cubase Pro 10.5 x64 with jBridge | WaveLab Elements 10 | i7 5930K @ 4.6GHz (stable) | ASUS X99 Pro | 32GB RAM | | W10 x64 Dual Boot on 2 SSDs plus 3 SSDs for samples and project/audio files | Fractal Design Define R5 case | Noctua NH-D15 | AMD Radeon RX 580 | Vox ToneLab SE | Mackie HR624 MKII | 2 x UAD2 Solo PCIe | RME HDSPe AIO | 2 x 24" LED monitors...

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

Mauri wrote:Once you're logged in, go to 'User Control Panel' at top left of the page, then click 'Profile' tab, then 'Edit signature'.
Type whatever you want in the empty field, hit 'Submit' and that's it.

Mauri.
Thanks. Seems to have worked. :)
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

hikarateboy
Junior Member
Posts: 148
Joined: Fri Jan 28, 2011 6:41 pm
Contact:

Re: Resolve Missing Files Problem

Post by hikarateboy »

I had exactly this issue due to creating and using a template I created from a previous project where I had removed all the tracks from the project window but neglected to do the same for the pool. As such every new project complained about missing files. My first question would be does this happen when you create a new project from one of the stock cubase templates that you havent updated. If that works I'd guess its the same issue I had.
Running the latest version of Cubase on Win 10, AMD Ryzen 7, 40 gigs Ram, 3 displays, RME 5296, 24 ch of A/D - I/O, CC121, Numerous plugins from UAD, Slate, Soundtoys, Waves, etc. Bunches of outboard analog pres and compressors.

dmbaer
Member
Posts: 349
Joined: Fri Jul 05, 2013 7:30 pm
Contact:

Re: Resolve Missing Files Problem

Post by dmbaer »

hikarateboy wrote:My first question would be does this happen when you create a new project from one of the stock cubase templates that you havent updated.
I tried that and, as you speculated, I was able to close and reopen the project based on the stock template cleanly. No warnings about a missing file.

However, then I made a real breakthrough (probably not related to the previous step, but who knows?).

I opened a project that had a legitimate missing file. For this project, I had previously exported a mix to a wave file on the desktop. I then moved that file elsewhere. After that, when I opened the project, this time I got a message about two missing files: the one legitimately missing and the phantom missing file. I opened the pool and they were both there, actual under Audio and phantom under Trash. Ah, so this is how the pool is supposed to work! Previously the pool showed no files present and executing "remove missing files" had no effect be the pool evidently thought it was empty, even though Cubase had flagged a file as missing upon project open.

With both files in the pool, I executed "remove missing files" and this time it worked. Glory be!

So, a workaround seems to be the following. If you have a dialog upon project startup sating there's a missing file but that file is not listed in the pool do the following. Create a real missing file in whatever way is most convenient. Open the project and go to the pool. The phantom file will hopefully show up and a "remove missing files" command should do the trick.
David Baer

Hardware: Intel I7 8-core hyper-threaded; 16G RAM; Dual SSD drives; Roland Quad Capture
OS: Win 10 Pro 64-bit
DAW: Cubase 10.5 64-bit
Synths and effects: More than I care to contemplate, but only the 64-bit stuff ever gets used

SuperPups
New Member
Posts: 2
Joined: Sun Sep 29, 2013 11:16 pm
Contact:

Re: [Solved ... sort of] Resolve Missing Files Problem

Post by SuperPups »

Thank you, everything turned.

boblaughlin
New Member
Posts: 7
Joined: Sun Dec 13, 2015 9:24 am
Contact:

Re: [Solved ... sort of] Resolve Missing Files Problem

Post by boblaughlin »

i've been having the same problems of the Missing Files dialog when starting up with a Template (my own)
the solution as stated above is to open the Pool and right-click to select Remove Missing Files
IMPORTANT: then you need to re-save the template (same name OK)
the Missing files dialog will be gone the next time you use that Template

Dogaafrica
New Member
Posts: 1
Joined: Tue Sep 29, 2020 9:42 pm
Contact:

Re: [Solved ... sort of] Resolve Missing Files Problem

Post by Dogaafrica »

Sorry this is coming way too late, but to simple solution is to right click on the audio in pool then remove missing files.

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 2 guests