[BUG?] Audio events move when switching to musical mode

For users of legacy Steinberg Cubase software
Post Reply
User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

[BUG?] Audio events move when switching to musical mode

Post by LarsErik »

When I record an audio event and switch over to musical mode the start position of the event changes.

To reproduce the problem:

1. Create a new project and set the project bar offset to 2.
2. Create an audio track.
3. Set the locator to the first bar (-1) and record a few bars.
4. Make sure you have the "info line" visable in the project window and select the audio event you just recorded.
5. Open up the audio pool and select the "musical mode" checkbox for your audio event. Now the event has changed starting position for me. (The start value has increased.)
6. If I go back and forth between checking and unchecking the "music mode" the audio event moves for each click.

The problem is more obvious if you:

7. After completing step 3 above you right click the audio track and select "Duplicate Track".
8. Right click the audio event on the new track and select "Functions"->"Convert to real copy".
9. Open up the audio pool and check the "music mode" checkbox on the copied event. This moves the copied audio event about 20 to 40 bars for me.

Observations:

1. Happens with both mono and stero tracks in both 16bit/44 and 24bit/48 projects.
2. It doesn't happen if record and the audio event gets an "event snap point". (However staring at bar -1 I don't seem to be able to get a snap point in my audio event.
3. It doesn't happen if I import an audio file, I have to record a new audio event.
4. Happens in both 32 and 64 bit Cubase.
5. Happens when the project tempo is fixed as well when using a tempo track.
6. At first I though I had to have a bar offset larger then 0 but I've had this happen with the offset set to 0 as well.

Sincerely
LarsErik

Edit: I renamed the post to a better name.
Last edited by LarsErik on Mon Mar 14, 2011 1:34 pm, edited 3 times in total.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by LarsErik »

I'm not sure it's related to my problem above but when I recorded today an event snap point was created in bar position 23.3.2.0 and the event started at bar -1.

In the manual it says that event snap points are created by default in the beginning of the audio event. I'm quite confused about this.

This was a 24bit/48000kHz project and I was recording a mono track with the project tempo fixed.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by vic_france »

When you went into the Audio Pool (to switch on Musical Mode) did you check that the entered tempo was indeed correct (presumably, 120 BPM, if this was indeed a new Project)?
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by LarsErik »

vic_france wrote:When you went into the Audio Pool (to switch on Musical Mode) did you check that the entered tempo was indeed correct (presumably, 120 BPM, if this was indeed a new Project)?
Yes the audio event in the pool has the same BPM as the project before I switch to Musical Mode.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by LarsErik »

Am I the only one with this problem? The workaround for me is to not use a "project bar offset" but I would really like to be able to do so.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by vic_france »

You are right!
(mustn't have followed your recipe correctly first time).
But my findings are not quite the same, however..
Keep toggling "Musical Mode" on and off.. the audio event moves a bit later and later each time (like a slow "nudge"! ;) )
Here, it happens even with Project Bar Offset at zero.
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: Problem with audio events moving when using musical mode

Post by LarsErik »

vic_france wrote:You are right!
(mustn't have followed your recipe correctly first time).
But my findings are not quite the same, however..
Keep toggling "Musical Mode" on and off.. the audio event moves a bit later and later each time (like a slow "nudge"! ;) )
Here, it happens even with Project Bar Offset at zero.
Thanks a lot for confirming this issue, I really appreciate it.

I started to suspect that there was something wrong with my project template (that I created back on Cubase 4) so I made a new one from scratch but the problem with the "musical mode nudge"-effect happens anyways.

I can recreate this issue 100% of the time.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

goodbyenine
Member
Posts: 226
Joined: Tue Dec 21, 2010 2:10 pm
Contact:

Re: Problem: Audio events move when switching to musical mode

Post by goodbyenine »

See this thread: http://www.steinberg.net/forum/viewtopi ... =76&t=4445

There seems to be something really wrong with the whole time-stretch, musical mode, time warp thing.

Come on Steinberg!!! Respond please!
Late Mac Tower based studio (10.8.5) with N6.5 and 2nd N6.5 (10.8.5), RME Madi via 648, Nanoclock, M3000 x 4 Ext FX, Video via BM Decklink on MP, composition workstation Single Hexacore MP. Sync: MMC N6.5>N6.5. VE Pro 5 always online via slaves. UK TV Music production at 25fps 48k at all times. Softriad Raid management. Powercore 4 running via VE Pro slave, Altiverb hosted on slave as bank of Ext FX. Waves and other plugins. Kontakt 5 central to workflow.

DanielAyo
Junior Member
Posts: 161
Joined: Sat Dec 25, 2010 4:19 am
Contact:

Re: Problem: Audio events move when switching to musical mode

Post by DanielAyo »

goodbyenine wrote:See this thread: http://www.steinberg.net/forum/viewtopi ... =76&t=4445

There seems to be something really wrong with the whole time-stretch, musical mode, time warp thing.

Come on Steinberg!!! Respond please!
+1010

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by LarsErik »

Bump.
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by vic_france »

I have been experimenting some more with this..
1) The problem does not occur if recording started even one beat later than Project start.
2) Moving the event to a later position, and then toggling Musical Mode, does not fix the problem.
3) I tried "Set Definition from Tempo" (from the Audio menu), but that didn't make any difference.
4) Re-importing the file into the Project does not work around the problem (although importing a "non-infected" audio file does not have this problem).
5) I have found one workaround (but let's hope this is just temporary)..
Before toggling "Musical Mode", select the event, then Bounce Selection. It creates a new, replacement file of course, but this new file doesn't produce the bug.
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

Chris Beuermann

Re: [BUG?] Audio events move when switching to musical mode

Post by Chris Beuermann »

Entered in DevTrack for further investigation (28338)

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by vic_france »

Thanks Chris :)
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

User avatar
LarsErik
Member
Posts: 207
Joined: Thu Dec 16, 2010 2:29 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by LarsErik »

vic_france wrote:I have been experimenting some more with this..
1) The problem does not occur if recording started even one beat later than Project start.
2) Moving the event to a later position, and then toggling Musical Mode, does not fix the problem.
3) I tried "Set Definition from Tempo" (from the Audio menu), but that didn't make any difference.
4) Re-importing the file into the Project does not work around the problem (although importing a "non-infected" audio file does not have this problem).
5) I have found one workaround (but let's hope this is just temporary)..
Before toggling "Musical Mode", select the event, then Bounce Selection. It creates a new, replacement file of course, but this new file doesn't produce the bug.
I've found another workaround:

1. Select the recoded audio event.
2. Place project cursor within the selected audio event.
3. In the "audio" menu select "Snap Point To Cursor".

The created event snap point cures the musical mode "nudge" effect.

Sincerely
LarsErik
Cubase 10.5 Pro, WaveLab Pro 10, Windows 10 (64bit)
RME-Audio UCX, Intel Core I7 3930K 3.20GHZ, NVIDIA GeForce GTX

User avatar
vic_france
Grand Senior Member
Posts: 3330
Joined: Wed Dec 15, 2010 5:16 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by vic_france »

LarsErik wrote: I've found another workaround:

1. Select the recoded audio event.
2. Place project cursor within the selected audio event.
3. In the "audio" menu select "Snap Point To Cursor".

The created event snap point cures the musical mode "nudge" effect.
Ah yes, that works ! :) (but once again, only if the snap point is later than the project start)
Mac Pro Quad-Core (2009) 2.66 GHz | 16GB RAM | MOTU PCI-424/2408mk3|MOTU Midi Timepiece AV | Mac OS X 10.9.5 | Cubase 9.5.0| Logic Pro X 10.2.2| ProTools 11.3.1| Ableton Live 9.7.5| Reaper 562 | Studio One Pro 3.5.1

Egebjerg
New Member
Posts: 35
Joined: Fri Dec 17, 2010 12:08 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by Egebjerg »

By accident I described a related problem in an other thread (if interested se
http://www.steinberg.net/forum/viewtopi ... =19&t=6663) but vic_france guided me to this topic, which seems more relevant.

The problem seems to be related to how Cubase handles the start point of a clip when pre-recording is on.

A workaround could be to go into Preferences>Audio and set “Audio Pre-Record Seconds” to 0 (if you dare! next time you record you should be absolutely sure when to pres the record button :-))
iMac 27" | 3.06 GHz i9| 40GB | OSX 10.15.4 |
CB 10.5.12 | SPL 6.0.20 | Dorico Elements3 3.0.20 | behringer UMC404HD

DanielAyo
Junior Member
Posts: 161
Joined: Sat Dec 25, 2010 4:19 am
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by DanielAyo »

Egebjerg wrote:By accident I described a related problem in an other thread (if interested se
http://www.steinberg.net/forum/viewtopi ... =19&t=6663) but vic_france guided me to this topic, which seems more relevant.

The problem seems to be related to how Cubase handles the start point of a clip when pre-recording is on.

A workaround could be to go into Preferences>Audio and set “Audio Pre-Record Seconds” to 0 (if you dare! next time you record you should be absolutely sure when to pres the record button :-))
Workaround definitely works! ;) Probably the quickest workaround for the time being...

alexis
Grand Senior Member
Posts: 4417
Joined: Tue Dec 21, 2010 7:55 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by alexis »

Am I right that this hasn't been addressed in 6.02?
Alexis

-Cubase "Safe Start Mode" (CTRL-ALT-SHIFT)
-Get variable-tempo audio to follow a grid here,
-Replacing freely-timed section into a variable tempo project

Cubase 9.0.20; i5-4570 3.2GHz, 16GB RAM; W10 Pro 64-bit on Samsung SSD 840 Pro 256GB; Seagate 1TB SATA 600 Audio; UR28M; Motif8; UAD-2 Solo; Jamstix 3.6; RevoicePro3.3; EZDrummer 2

Kearley
New Member
Posts: 12
Joined: Fri Sep 13, 2019 5:59 am
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by Kearley »

(EDIT) Dupe, sorry.
Last edited by Kearley on Sat Sep 14, 2019 2:45 am, edited 1 time in total.

Kearley
New Member
Posts: 12
Joined: Fri Sep 13, 2019 5:59 am
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by Kearley »

I just started a forum account to add that the problem still exists in the latest version. Exactly as described here.
This thread was a big help in suggesting workarounds, thanks!

DaGa
New Member
Posts: 3
Joined: Fri Dec 21, 2018 5:50 pm
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by DaGa »

This is how you do it without moving the events:

1. Select all audio parts that you would like to put in musical mode
2. Go to the audio menu (top left corner, next to project)
3. Go to advanced
4. Click on "Set definition from Tempo"
5. Select "Save definition in project only"
6. Select "Set all tracks to musical time base"
7. Click on "ok"
8. There you go

It's also shown at the end of this video (starting at 05:30):

https://www.youtube.com/watch?v=AlyuVb52hAM

I hope that helps!

Kearley
New Member
Posts: 12
Joined: Fri Sep 13, 2019 5:59 am
Contact:

Re: [BUG?] Audio events move when switching to musical mode

Post by Kearley »

I haven't tested that yet, but thanks!

Post Reply

Return to “Older Cubase versions”

Who is online

Users browsing this forum: No registered users and 3 guests