Page 1 of 1

Installing Cubase 4 on Mac

Posted: Tue Aug 14, 2018 4:23 am
by agar700
Im needing assistance with a installation of an older version of Cubase 4 on my Mac Book Pro. The problem is my I tried to install it but I saying that I need to have a version of iOS greater than 10.5, which my version currently is High Sierra 10.13.6. Is there any way to install this or a higher version and still be able to use my registration blue key that I have?

Re: Installing Cubase 4 on Mac

Posted: Tue Aug 14, 2018 6:50 am
by Romantique Tp
Sorry, but it's not possible to install Cubase 4 on High Sierra. But even if it was possible, there would be a ton of issues thanks to all the changes made by Apple over the years.

To use Cubase on your Mac Book Pro, you'll have to upgrade to Cubase Pro 9.5:
https://www.steinberg.net/en/shop/buy_p ... ro-95.html

On top of this version being fully compatible with High Sierra, the most current versions of Cubase also offers hundreds of new tools and workflow improvements compared to Cubase 4, which definitely make a huge difference.

Re: Installing Cubase 4 on Mac

Posted: Tue Aug 14, 2018 11:01 am
by agar700
Thanks, Romantique. I was hoping to be able to install this and then see if it will upgrade itself to prevent me from having to re-purchase it again.